GPS is searching for location...searching...searching...not finding anything. PLEASE HELP!


New member
Dec 31, 2012
Visit site
So, I've had my EVO 3D for a few months now, and I'm pretty satisfied with it except for one thing. The GPS. At first. It worked pretty well; I used it on vacation in Florida and for the most part, it worked like a charm. But, sometime after, I don't know exactly when, I turned on Google Nav, and it got hung up "searching for GPS location" so I let it sit a while, but still, no dice after a half hour. And, since then, it hasn't worked reliably as it did in August. I have been searching the web for anything related, and I haven't found anything that works. I tried...

Updating the PRL
Battery pull
Clearing/updating AGPS cache
Various maps apps
Reinstalling Google Map
Letting it sit to gather data...this works sometimes, but as soon as I move it, it goes back to searching g to find the location.
I know some people mentioned that the app Skyvi messes it up, and I had that, so I cleared it, uinstalled it, rebooted etc.

Nothing seems to work...
Really, the only thing I didn't try was a hard reset because, and correct me if I'm wrong, if that fixes it, then the problem is a software update (I'm not rooted or using a custom ROM), and if that's the case, I can't do anything about it except wait for an update, correct?

So what I'm posting for is to know if A. Anyone is seeing the same lack of success, B. If anyone knows of something else I could try to fix it, or C. Anyone else with this problem has had any degree of success fixing it, even if they did something I tried.