[GUIDE] Troubleshooting Wi-Fi Connection Problems

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,726
4,890
113
Visit site
[Updated 10/26/18]

Wi-fi connection problems are relatively common issues on these forums. If you're experiencing difficulties, try some of the following:

1. On your device, go to System Settings/Wireless & Networks/Wi-Fi, select the Wi-Fi network that you’re trying to connect to, and tap “Forget.” Then reconnect by selecting that network again and entering whatever password that may be needed.

Screenshot_2013-10-25-15-28-56.jpg

If the network to which you’re trying to connect has a common or generic SSID (like “HHonors” at Hilton hotels, or “linksys," which is usually the default SSID for Linksys routers), then your device might be trying to use previously stored credentials from a past connection that won’t work for this new connection. So, for example, suppose you visited a Hilton last year and used their “HHonors” wi-fi. Your device remembers this connection unless you tell the device to forget it. If you go to a different Hilton now, the SSID for their wi-fi will still be “HHonors,” but the credentials that are saved on your device may not work. You need to forget your old “HHonors” network, then select the current “HHonors” network and log in again.

[TIP]This is why it’s a good idea to change the SSID of your own home wi-fi network to something unique, to reduce confusion for your device.[/TIP]

2. Reboot your router. Unplug its power, wait about 10 seconds, then plug it back in again. Wait another 10-20 seconds for the connection to reestablish.
If you’re not getting an internet connection on any device or computer in the house and the router reboot doesn’t work, also try rebooting your cable/DSL modem.

[NOTE]Modems often have a battery backup, so simply unplugging them won’t force a reboot. There’s usually a reboot/reset pinhole button on the back.[/NOTE]

3. See if the router’s security is interfering. Go to the router’s settings screen (you’ll need to check the user’s manual for your particular router to learn how to do this). Find the options for security, and turn it off temporarily. If you can connect, then you know that security is the main problem.

Obviously, it’s not ideal to leave your home network unprotected, so you’ll need to reactivate security, but this time, try a different protocol. If you were using WEP before (an older security protocol, which you should avoid these days), change it to WPA-PSK or WPA2-PSK. If you were using WPA or WPA2 already, try changing the encryption mode from TKIP to AES or vice-versa.

[WARN]Remember, don't leave your router's security off! Keep your home wi-fi network protected.[/WARN]
4. Turn off QoS in your router's settings. QoS stands for Quality of Service, and will try to prioritize certain connections over others (primarily useful if you have a TV with streaming video, or a game console that requires a very high speed connection). If your device isn't prioritized, its connection will suffer.

5. USB 3.0 connections can interfere with reception of the 2.4 GHz wi-fi band, if the port isn’t properly shielded (see this article:
Wireless Witch: The Truth About USB 3.0 and Wi-Fi Interference | Samara Lynn | PCMag.com).

6. For public wi-fi hotspots, remember that many require you to log in or accept terms and conditions on a welcome page before you can fully access the web. Until you do so, you may still see that a wi-fi connection is active on your Notification bar, but you won’t be able to access anything on the web. Open your browser and go to any URL--if it takes you to a welcome page instead, log in or accept the terms and conditions. If you turn off wi-fi later, and then turn it on again, you may have to go through the same process.

Typically, when you connect to one of these kinds of networks, you should see a window pop up with that login website. This is usually handled by a system app called CaptivePortalLogin. If you're not getting this popup login window, go to Settings>Apps and make sure you haven't disabled CaptivePortalLogin.

7. If you have a dual-band router (i.e., 2.4 GHz and 5 GHz), see if you can set your device to use only the 2.4 GHz band. Sometimes the Auto settings will cause problems. Go to System Settings/Wireless & Network/Wi-Fi, tap the Menu button again, and select Advanced/Wi-Fi Frequency Band.

2013-10-24.jpg

Then select "2.4 GHz Only" instead of "Auto":

2013-10-24 (2).jpg

8. In item #6 above, you can see an option for "Avoid Poor Connections." If you check this, then your device won't struggle to maintain a connection to a weak wi-fi network. However, this may also prevent your device from connecting to a network that it otherwise could use. Uncheck this option if the network to which you're trying to connect shows only 1 bar or so.

9. Make sure your date and time are correct. Check the Settings>Date & Time menu, and make sure "Automatic Date & Time" and "Automatic Time Zone" (if available) are checked. If there is a discrepancy between your device's date and time and that of the router, the connection may not work.

10. Turn off Wi-Fi Optimization. You can see the option in the screenshot above. This option is for battery saving, not for improving wi-fi performance. Turning optimization on will actually make the wi-fi radio activity more intermittent (in an attempt to save battery), and therefore might hinder the performance of some apps that require a more constant connection.

11. Disable IPv6. Although this is supposed to be the current internet communications protocol (succeeding IPv4), it seems that some servers occasionally have problems with it--and oddly enough, this includes Google servers. Log into your router's settings and look for an option to disable IPv6.

12. Try turning off Bluetooth. Bluetooth uses 2.4 GHz as well, so if you're relying on 2.4 GHz wi-fi and both are using the same channel, the Bluetooth signal can possibly interfere with wi-fi.

Thanks to Eclipse2K for suggestions and screenshots, brosko for the Date & Time tip, and Lupelamenta for the QoS tip!
 
Last edited:

Manda QoP

New member
Nov 19, 2013
1
0
0
Visit site
Really quick solution on my Nexus 5. Changed the router wif-fi channel to 8. It was on 13 to avoid clashing with any of the neighbours. I noticed that I was picking up all their wi-fi but mine said "not in range", so changed the channel and it connected immediately. Will need to have a play around now with my channel settings to make sure I keep my high speeds and don't share frequencies with too many neighbours, but it seems the Nexus 5 has issues on channels higher than 8.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,726
4,890
113
Visit site
That's a good point--if your wifi network is using the same channel as other networks in the area, you can get slowdowns or even dropouts. Most routers have the ability to choose a relatively open channel automatically. If you don't have this option, you can install an app like Wifi Analyzer, see which channels are relatively free, and change the channel your network uses in the router settings.
 

victorbrca

New member
Feb 22, 2014
1
0
0
Visit site
Great post. I would also add to enable and the disable Wi-fi hotspot. If for some reason it doesn't get fully disabled you will not be able to connect to a wi-fi.
 

dnaz4rzhzx

New member
Aug 3, 2014
1
0
0
Visit site
how to solve an wifi connection problem when it keeps connecting to another wifi connection even we have forgotten the connection and disable the auto connect?when i connect to my wifi it was connected for a few minutes and after that it disconects my wifi and trying to obtain ip addres from another open wifi network? help me to solve this
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,726
4,890
113
Visit site
Welcome to Android Central! What device do you have? There seem to be two problem: (1) your wifi connection gets dropped from your home wifi network, and (2) it keeps trying to connect to an open wifi network.

For problem 1, have you gone through the various tips in the main part of the guide? Turn off wi-fi optimization, and turn off any option that avoids a weak signal.

For problem 2, go to Settings>Wi-Fi, tap the menu button, then Advanced. Uncheck "Network Notification" and "Scanning Always Available."
 

Tromp Queen Jill

New member
Aug 8, 2014
1
0
0
Visit site
Just got my first android phone and it absolutely will not connect to our home wifi. We've tried all the suggestions you posted here and even did a factory reset. To no avail. I was in a public wifi zone today, though, and it connected perfectly there so I know the issue is at home. I am very frustrated and do not know what else to try.
We have U verse for our internet (high speed)
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,726
4,890
113
Visit site
Welcome to Android Central! Which phone do you have? You already tried temporarily turning off the security on the router?

On your phone, go to Settings>Wi-fi, long press your home network, and Forget Network. Then select it again to log back in. When entering your credentials, tap on the Advanced checkbox, and make sure Proxy is set to None. Also make sure DHCP is selected, although sometimes people have changed it to Static and entered a static IP manually--you just have to make sure you router is also set to a static IP. This is not as secure, but it can be a workaround.
 

2creus

Member
Oct 17, 2014
8
0
0
Visit site
Thanks. This looks clear and concise. I sent it to my friend but he really is not good at technology. It helps me though. Sent to my son also. He is my techie. 😉
 

Kenix Lau

New member
Nov 24, 2014
2
0
0
Visit site
Hi there, Thanks for the tips. I have tried all of the above but my phone is still unable to connect to my phone router.
I am using LG P769, my housemate and I are using a D-Link router. Just weeks ago when I came home from Vancouver, my android fall into the connecting - disconnected loops. Other devices (laptop, pc) in the house works fine. I reset my phone to factory default setting, it works for a few hours, then the same problem came back.
My phone can connect to other wifi in place like starbucks or other friend's house. But it doesn't work with at home. I changed the route's security setting to WPA2 only and TKIP only. My phone is connected, but then the rest of the house's devices (pc, laptop) are unable to connect!! This issue is very frustrating. Do you have any suggestion? Thank you lots!
 

dialronet

Member
Dec 6, 2014
5
0
0
Visit site
Hi there,

I bought my Nexus 5 back in February and have never had issues with it till 3 weeks ago. Wifi worked fine everywhere and one day at home it stopped working. It keeps showing that is connected but internet does not work. A couple of weeks later the new Android Lollipop roll into my phone and I hoped that would solve the issue, unfortunately it still does not work at home. At my work place it connects with no issues, so I assume is the phone because it worked for 6 months and before the android update at home, and nothing has been changed/updated in my router. I've tried everything you have posted in this thread and in other websites, however the only thing that helps temporarily is changing the channel in the router, but every time I go out and come back home, I have to change the channel once again. This is something that works once in a while and not all the time.

I don't know what else to try, I like my Nexus 5 a lot but this is becoming frustrating. Any guidance will be appreciated.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,726
4,890
113
Visit site
Hi there, Thanks for the tips. I have tried all of the above but my phone is still unable to connect to my phone router.
I am using LG P769, my housemate and I are using a D-Link router. Just weeks ago when I came home from Vancouver, my android fall into the connecting - disconnected loops. Other devices (laptop, pc) in the house works fine. I reset my phone to factory default setting, it works for a few hours, then the same problem came back.
My phone can connect to other wifi in place like starbucks or other friend's house. But it doesn't work with at home. I changed the route's security setting to WPA2 only and TKIP only. My phone is connected, but then the rest of the house's devices (pc, laptop) are unable to connect!! This issue is very frustrating. Do you have any suggestion? Thank you lots!

Welcome to Android Central! Sorry for the late response--I hadn't checked this thread for a while. What setting was the router on before? Was it WPA2/AES? That's usually the preferred setting for most modern devices--but older phones might have some difficulties with it.

Is the router's firmware up to date? It might be worth getting a new router--try getting one from a store that has a good return policy, so that you can bring it back if the same thing happens.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,726
4,890
113
Visit site
Hi there,

I bought my Nexus 5 back in February and have never had issues with it till 3 weeks ago. Wifi worked fine everywhere and one day at home it stopped working. It keeps showing that is connected but internet does not work. A couple of weeks later the new Android Lollipop roll into my phone and I hoped that would solve the issue, unfortunately it still does not work at home. At my work place it connects with no issues, so I assume is the phone because it worked for 6 months and before the android update at home, and nothing has been changed/updated in my router. I've tried everything you have posted in this thread and in other websites, however the only thing that helps temporarily is changing the channel in the router, but every time I go out and come back home, I have to change the channel once again. This is something that works once in a while and not all the time.

I don't know what else to try, I like my Nexus 5 a lot but this is becoming frustrating. Any guidance will be appreciated.

Welcome to Android Central! When you say that every time you go out and come back home, you have to change the channel, is it because it's reverting back to the poor channel? Or do you have to keep trying different channels each time?

What brand of router is it? Is the firmware up to date? As with the previous poster above, it might be worth trying a new router.
 

dialronet

Member
Dec 6, 2014
5
0
0
Visit site
Thanks for your reply. Yes it reverts back to the same channel, although not always works changing to another one; sometimes I have to go a check every channel and if lucky it works on one of those.

The router is a DLink DSL-G604T, I've checked and the firmware is up to date. I've been considering buying a new router as a last option, but still cannot understand why it worked fine for 6 months?
 

Trending Posts

Forum statistics

Threads
943,801
Messages
6,920,136
Members
3,159,241
Latest member
jermz1084