HELP! Nexus 7 stuck on "X" boot screen

arcoms

Well-known member
May 18, 2010
49
1
0
Visit site
I have a stock, unrooted, 32GB Nexus 7 and it has performed flawlessly. Even after the 4.2 updates, I didn't notice all the sluggishness most complained about.

However, over the last few days its been giving me problems. First it would do random reboots. Then it would just stop loading any kind of internet content until I turned it off and back on again. Then the most disturbing thing that started to worry me happened where if I turned it off it would get stuck on the "X" and it would have to press the power button to shut it down and try again.

Tonight, it won't do anything at all. I've tried doing a hard reset and it doesn't work. I'm pretty desperate.

As you can probably tell, I'm not the biggest tinkerer. I know basic trouble shooting but I'm not very advanced in doing backups or flashing ROMs or anything like that. So it really troubles me that my N7 might just be toast since I probably can't figure it out on my own. Any help would be greatly appreciated.

Sent from my Galaxy Nexus using Android Central Forums
 

Jaydax

New member
Apr 16, 2014
1
0
0
Visit site
The same thing happens with my Nexus 7 (2012) The only difference being that I get four coloured blobs merging and separating instead of the X. I've been factory resetting mine when it happens. It's pretty much hit and miss as to whether it works or not but I did find one method. After you've done a factory reset shut the Nexus 7 down. leave it 10 min and start it up again.

The fix isn't perfect. It will happen again. I begin to wonder if there is an incompatible app on my Nexus. Possible the Kindle app since that one started giving me an 'Unfortunately, Kindle has stopped working.' followed by other apps and services doing the same until my Nexus 7 shut itself down.

I also wondered about the possibility of an Android virus, however, I have Norton Mobile anti-virus installed and that said my device was clean.
 
Last edited: