Here we go... won't come on/boot

Batt4Christ

Member
Jan 10, 2014
12
0
0
Visit site
Last night, I was reading a book on my MeMo Pad HD7. All was well. Battery was down to around 50% when I was ready to sleep. I closed the Transcover and plugged in the power cord and went to sleep.

I got up this AM, picked up and unplugged the ASUS and took it with me to church. Got there and opened the cover. Nothing. So I pressed the power button... nothing. I did without it.

Got home a couple of hours ago and tried again. Found some instructions to try holding the power button down for a LONG time (as much as 3 minutes). Tried that... nothing. No signs of life whatsoever. I'm at a loss. This is my 2nd ASUS MeMo Pad HD7. First which was purchased end of December/early January would not update the OS, so it went back to the retailer. Picked this one up after receiving my refund on the first - this time at Walmart (January 11). It has worked fine until now. No other symptoms. No odd behavior. No nothing - until this morning when it won't come on.

I have sent an email to ASUS support, though my past experience with them is pretty pitiful at best. I suspect they will want to send me an RMA # and take a few weeks to diagnose/repair/replace/or play games with me- during which time I am out my pad.

So - before I start the agonizing process - anyone have any suggestions to try? I have tried the power button + down volume... that did nothing. I have tried plugging it in (power adapter is working) - nothing. I have held the power button for several minutes. :'(
 

Golfdriver97

Trusted Member Team Leader
Moderator
Dec 4, 2012
35,380
127
63
Visit site
Last night, I was reading a book on my MeMo Pad HD7. All was well. Battery was down to around 50% when I was ready to sleep. I closed the Transcover and plugged in the power cord and went to sleep.

I got up this AM, picked up and unplugged the ASUS and took it with me to church. Got there and opened the cover. Nothing. So I pressed the power button... nothing. I did without it.

Got home a couple of hours ago and tried again. Found some instructions to try holding the power button down for a LONG time (as much as 3 minutes). Tried that... nothing. No signs of life whatsoever. I'm at a loss. This is my 2nd ASUS MeMo Pad HD7. First which was purchased end of December/early January would not update the OS, so it went back to the retailer. Picked this one up after receiving my refund on the first - this time at Walmart (January 11). It has worked fine until now. No other symptoms. No odd behavior. No nothing - until this morning when it won't come on.

I have sent an email to ASUS support, though my past experience with them is pretty pitiful at best. I suspect they will want to send me an RMA # and take a few weeks to diagnose/repair/replace/or play games with me- during which time I am out my pad.

So - before I start the agonizing process - anyone have any suggestions to try? I have tried the power button + down volume... that did nothing. I have tried plugging it in (power adapter is working) - nothing. I have held the power button for several minutes. :'(

Perhaps trying a different cable, and allowing to charge for several hours.
 

zedorda

Well-known member
Mar 16, 2011
2,594
179
0
Visit site
Have you tried plugging it back in for awhile(being hours) then doing the hold power button thing again?
 

Batt4Christ

Member
Jan 10, 2014
12
0
0
Visit site
Well, I got home from evening services and decided to pick up my tablet. I pressed the power button and there red battery icon displayed for about 2 seconds. It didn't do that before.

So I plugged it in and I am posting this reply from my the Pad!
 

zedorda

Well-known member
Mar 16, 2011
2,594
179
0
Visit site
Discharged lithium-ion batteries can have odd behavior till they get fully charged again. I had a phone that I stored with a dead non-removable battery for about 2 months before trying to get it working again to use. It took 3 days plugged in to get it to start taking a charge again. It never had the same charge level.