Huawei Mate 9 has serious problem to sync with MS Exchange

wpjwong

Member
Feb 13, 2017
8
0
0
Visit site
Hi dear,

I tested Mate 9 in last few days and everything is good and satisfactory. I use the smartphone to sync my work email from MS Exchange 2010. After installing the "Corporate" account to the phone, it sync with email, calendar and contacts fine with real time push. The next day after i power up the phone again. It could not sync the Exchange with error message "Sync is currently experiencing problems. It will be back shortly". Then all the sync with email, calendar and contacts are stuck.

I started to search the forum from Internet and followed the advice to delete the Exchange account, erase the data on "Exchange Service", Mail, Calendar and Contacts apps followed by a reboot. After that I reinstalled the Exchange account. All mail, calendar and contacts came back nicely. Real time sync was running good. Then I shut down the phone until the next day. This morning, it came out good and I thought i have resolved the issues. After testing a whole day and confirmed the real time sync working fine. I power down the phone again and wait for a few hours to see if there is any problem. When it powered up this evening, the same symptom happened again....sync error.

I used Samsung Note 2 and Note 4 before switching to Mate 9, so far Samsung worked nicely with Exchange without this kind of problem. I am a heavy user on Exchange email using the phone, now the phone is useless to me, very frustrated!!!

Will try to call the customer service center tomorrow but just wonder if they can help on this kind of software compatibility issue.

Any advice or assistance from this forum is much appreciated!

Thanks!

Wong
 

Gayle Lynn

Well-known member
Jun 20, 2016
1,780
0
0
Visit site
2010 era software working with Android newest OS seems like comparability could be one issue.

What phone and OS did you have before? In all events, having a known trustworthy backup device is a must.

In ancient past they use to have to certify disk drives and controller boards to work, plus with the host OS That may seem quaint but it still does happen.

<http://forums.androidcentral.com/google-samsung-galaxy-nexus/271616-how-i-fixed-issue-my-samsung-phone-not-syncing-exchange-server-using-activesync.html>

<https://support.microsoft.com/en-us/help/10047/troubleshoot-activesync-with-exchange-server>
 

Gayle Lynn

Well-known member
Jun 20, 2016
1,780
0
0
Visit site
Add this reference - good walk thru of server side. Common to have issues with Android phones, especially when a new OS.

<http://www.techrepublic.com/blog/google-in-the-enterprise/troubleshooting-android-activesync-problems-with-exchange-2010/>

* <https://technet.microsoft.com/en-us/library/mt465748(v=exchg.150).aspx>

* Seems to require desktop computer
 

Gayle Lynn

Well-known member
Jun 20, 2016
1,780
0
0
Visit site
I assume yes, for now. Technet would not load on my Mate 9.

Enable dev mode and logging events should help someone on admin side.
 

PaulQ

Well-known member
Jan 6, 2011
1,984
29
48
Visit site
Alternatively, you might try a third party app to use your corporate email. I use an app called "Nine" - Not only does it work flawlessly, it has a lot of useful features. It's expensive by app standards but it is an outstanding mail app.
 

Dimas de Leon

Well-known member
Aug 22, 2016
562
0
0
Visit site
I use MS Exchange for work as well. I think they upgraded us to 2013 a few years ago. I don't have any issues with it.

You can install Microsoft Outlook and log in with your work credentials and it should link up.
 

jeepentj

Well-known member
Jun 28, 2010
289
0
0
Visit site
I connect to two Exchange accounts - one on 2010 and the other on 2013. Both work fine with no issues whatsoever. I also have one iMAP account and two POP3 accounts. None of them have issues either.

I love this phone and have zero problems with it but there sure seem to be a lot of other people whose experience is different - apps that are compatible for some and incompatible for others, Exchange issues, etc.. Sometimes these issues fix themselves after a reset, other times not. I don't know if I'm lucky or it's just a matter of time before I experience some weirdness.
 

wpjwong

Member
Feb 13, 2017
8
0
0
Visit site
Today, I reinstall Exchange account to native email app and then install "Mail Wise" and "Outlook Android". I tried 3 apps at the same time. Working in the office in the whole day using public wifi. Everything fine for 3 apps. I powered down and powered up a few hours later, still it could connect to server and sync well. I tried several times and every time it was good. Then I went back home and use my wifi at home. The speed is about 200Mbps in term of actual throughput. Now problem happened again. The native email app and Mail Wise could not sync and Mail Wise indicated that it could not connect to the server. Interesting enough, Outlook Android was still working perfectly.

Now it shows that Android 7.0 has compatibility issue or setting issues with Exchange 2010 but Outlook Android can live with this without problem. Will try to see if the two dead apps can reconnect to the server when i go back to office tomorrow. If it fail again, i will remove the apps and try gmail app.
 

wpjwong

Member
Feb 13, 2017
8
0
0
Visit site
Now I come back to office and use the public wifi at home to test again. Both native email app and Mail Wise can connect to the server. Everything working fine again. That's mean I need to check my wifi setting at home. I guess some new security protocol may have introduced by Android 7.0 which is barred at my home wifi.
 

wpjwong

Member
Feb 13, 2017
8
0
0
Visit site
Problem resolved. I cleared the cache of the email apps of the phone which have problem. Now it is working fine at my home wifi. Nothing has been changed at my home wifi in term of setting.
 

wpjwong

Member
Feb 13, 2017
8
0
0
Visit site
After everything was working fine in last 2 days, tonight the same problem happened again using either home wifi or mobile data. I have cleaned up the app cache and reboot the phone. Still the national email app and Mailwise could not connect to Exchange server. I use the browser to login onto OWA, the email worked fine which means the phone could connect to the Exchange server through the browser but not the apps.

I would very much suspect the email apps have some issues with Android 7.0.
 

Dimas de Leon

Well-known member
Aug 22, 2016
562
0
0
Visit site
Previously only available on IOS, Material Design-themed Email by EasilyDo now available on Android, simply called "Email. " Supposedly the fastest email app in the market and the best one for Unsubscribing. I just installed it, I was able to add my work email, yahoo and Gmail without a problem.

Might solve your issues.
 

wpjwong

Member
Feb 13, 2017
8
0
0
Visit site
Hi Dimas, thank you for the suggestion. EasilyDo is a good app for personal life organiser but may not be good to mix with business email.
 

edwin walke

Well-known member
Jan 6, 2016
249
0
0
Visit site
Previously only available on IOS, Material Design-themed Email by EasilyDo now available on Android, simply called "Email. " Supposedly the fastest email app in the market and the best one for Unsubscribing. I just installed it, I was able to add my work email, yahoo and Gmail without a problem.

Might solve your issues.

I tried easily do Email yesterday and it is great. Fast and easy to use. Thanks for letting the forum know.
 

wpjwong

Member
Feb 13, 2017
8
0
0
Visit site
Problem has been resolved. There is a new security setting at Android 7.0 when you set up Exchange server. "Security Type --> SSL/TLS (Accept all certificates)". I changed to this setting instead of "SSL/TLS". So far it is working fine.
 

Dimas de Leon

Well-known member
Aug 22, 2016
562
0
0
Visit site
Well, I'm having issues with work exchange email. I keep getting an error, "Failed to send email, connection problem" - I tried the "SSL/TLS (Accept all certificates)" but that didn't work.
 

Forum statistics

Threads
944,465
Messages
6,922,872
Members
3,159,567
Latest member
crowoverhoe