LG G3 Resolution messed up - how to stop processes on startup?

justimpressive

New member
Feb 11, 2016
1
0
0
Visit site
I'm running CM 12.1 on an LG G3 (VS985) with TWRP recovery.

I used an app called UI Tuner to change my resolution, thinking that it would revert back to normal after 15 seconds.. well it didn't. It crashed? when I did it, and then it started back up? with the super low resolution.

Now I'm stuck with a screen that's like 200x300 and the DPI is wayy off, so I can't really use the screen.

I used TWRP to manually delete the app, but the problem persists. The reason it doesn't just reset my resolution upon startup is because I had it set to change my resolution to 1920x1080 for better performance on startup. Is there a way to stop it from running on startup? I have access to TWRP still, and I can sorta do very limited things within my phone, but it's so small that all I can do is open apps and see the very tops of them.

I tried looking for a way to manually stop apps from running on startup, but all I can find are guides on how to use apps that you install.. which doesn't help at all.

I really would like to keep my current apps and setup and everything. I almost resorted to just flashing a new ROM, but I really don't want to do that.

I tried using ADB, but it says that there's no device found. I'm pretty sure I had USB debugging on, so I don't know why it can't find my phone... although I can't really see it to tell if it's on or not.
 

Rukbat

Retired Moderator
Feb 12, 2012
44,529
26
0
Visit site
adb can't find TWRP - which is what's running in your phone now. It needs the full Android running.

I'd ask on XDA - there's a setting in one of the startup data files that sets the resolution. Someone might be willing to write you a little app that you can flash from TWRP that will open that file and set it to normal resolution. (Or give you a way to run a terminal from TWRP so you can edit the file yourself, even if it means copying it out to a PC, editing it, then pushing it back to the phone.)