• Welcome to the all-new Android Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

LGL38C Optimus Dynamic Stuck in a bootloop. Tried to flash Rom! Any suggestions?


New member
Jan 19, 2016
LGL38COptimusDynamic Stuck in a bootloop. Tried to flash Rom!

LGL#*C (Optimus Dynamic) from walmart. android2.3.6ver
Decided to get into the custom rom world of android through the old device I had laying around. Hoping there's something out there helpful to get me out of this rabbit hole I've got myself into.
So. Successfully downloaded CWM on device. Very cool. Proceeded to look for roms I could flash; thought I found one. Wasn't exactly sure how to question compatibility with rom and device but trusted my gut and proceeded to download file, go to CWM, flash file from external SDcard.(Followed the directions) Then a nice ERROR came up while installing. I tried rebooting system to continue to current OS but just a nice fat LG sign forever. Proceeded to format everything, wipe caches, etc. Now I don't even think I have the stock system? I'll be signed on all day, please pass a paddle to help me out of sh*t creek. Thank you.