Not getting android messages notifications after Pie update

dbarnes2270

Active member
Jul 12, 2010
40
0
6
Visit site
I am noticing that text messages are coming through but no notifications are showing. I'm missing message announcements as well. My headset usually announces them. Anyone else notice this?
 

radgatt

Well-known member
Apr 19, 2010
1,689
15
38
Visit site
I don't have this issue with the Android Messages app. I have this issue with other apps. I thought it may have to do with restrictive apps within the adaptive battery but that was not the case.
 

Will_T

Well-known member
Oct 13, 2013
391
6
18
Visit site
I just posted another thread with a summary of the notification issues I am having with Pie on my Pixel 2XL. FWIW, I did find and follow instructions to allow apps all access so the battery controls would not be an issue. That did not help so, I then turned off the Battery Saver and the Adaptive Battery and that made no difference. Still no audible notifications of any type when the screen is off.
 

mahers

Well-known member
Jul 12, 2010
141
0
0
Visit site
Same issue for me as well. I get texts in a timely manner, but none of my other notifications come through like they should. Emails, credit card, alarm, forums/blogs...they come all at once, hours after the fact. I tried the same things mentioned above with battery saver, optimization and adaptive battery settings. I even tried to unrestrict background data usage, but nothing has worked so far. It's very frustrating when you rely on these notifications. Is this a hit or miss issue, or is everyone with a Pixel 2XL in 9.0 experiencing it?
 

ArkansasMarine

New member
Aug 22, 2018
1
0
0
Visit site
Same issue for me as well. I get texts in a timely manner, but none of my other notifications come through like they should. Emails, credit card, alarm, forums/blogs...they come all at once, hours after the fact. I tried the same things mentioned above with battery saver, optimization and adaptive battery settings. I even tried to unrestrict background data usage, but nothing has worked so far. It's very frustrating when you rely on these notifications. Is this a hit or miss issue, or is everyone with a Pixel 2XL in 9.0 experiencing it?

I'm having the same issue. After the recent update to Pie, my Kik sound alerts completely stopped. I've done a factory reset and it hasn't corrected the issue. I've adjusted volumes and restrictions til I'm blue in the face. Nada. Please fix this, Google.
 

Nauga

Well-known member
Nov 9, 2017
406
0
0
Visit site
Same issue for me as well. I get texts in a timely manner, but none of my other notifications come through like they should. Emails, credit card, alarm, forums/blogs...they come all at once, hours after the fact
I'm seeing the same kind of delay with Gmail notifications. I've tried checking it with AOD off and on using both Pixel launcher and Nova with system theme set either to automatic or dark and with a Google live wallpaper or a photo from my Downloads folder. I only got a successful result using Nova launcher with a jpeg wallpaper, AOD off, and the theme set to Automatic, . That was the only configuration that gave me an onscreen notification with a notification sound and without a ridiculous delay.
 

Mike Dee

Ambassador
May 14, 2014
23,368
191
63
Visit site
I'm seeing the same kind of delay with Gmail notifications. I've tried checking it with AOD off and on using both Pixel launcher and Nova with system theme set either to automatic or dark and with a Google live wallpaper or a photo from my Downloads folder. I only got a successful result using Nova launcher with a jpeg wallpaper, AOD off, and the theme set to Automatic, . That was the only configuration that gave me an onscreen notification with a notification sound and without a ridiculous delay.

I'll have to look for it. I haven't noticed anything.
 

mahers

Well-known member
Jul 12, 2010
141
0
0
Visit site
I don't know what AOD is. And I can't believe that using Nova vs the stock launcher would affect notifications. They aren't related in any way. It seems when I do get one for an app, then all of a sudden, I get all app notifications at once. I know Google implemented a doze feature as well as a battery AI process to monitor how we use our phones so they can maximize battery life, but this is ridiculous. I set up app notifications for a reason. I don't want to know something happened hours after the fact. Kind of defeats the whole purpose!!
I'm seeing the same kind of delay with Gmail notifications. I've tried checking it with AOD off and on using both Pixel launcher and Nova with system theme set either to automatic or dark and with a Google live wallpaper or a photo from my Downloads folder. I only got a successful result using Nova launcher with a jpeg wallpaper, AOD off, and the theme set to Automatic, . That was the only configuration that gave me an onscreen notification with a notification sound and without a ridiculous delay.

My issue is not the same. It's not just the sounds not coming through. I don't get any notifications real time. When they do decide to go through, I do hear the sounds. So I doubt this is the same issue. Plus, this started precisely after updating to Pie
This is evidently not a new bug or one exclusive to Pie. I just checked the Pixel User forum, and the same problem showed up there after an 8.1 update in January. People have been experiencing this notification sounds weirdness since January, update after update.

Today was the first time for me, though.

https://productforums.google.com/fo...mn54uW0VM;context-place=forum/phone-by-google
 
Last edited by a moderator:

Nauga

Well-known member
Nov 9, 2017
406
0
0
Visit site
I don't know what AOD is.
Always on display. And, the launchers are kind of related to the notifications since the notifications display on the lockscreen and launchers include settings related to the lockscreen, especially a wallpaper for the lockscreen.
 

mahers

Well-known member
Jul 12, 2010
141
0
0
Visit site
Always on display. And, the launchers are kind of related to the notifications since the notifications display on the lockscreen and launchers include settings related to the lockscreen, especially a wallpaper for the lockscreen.
Ok. Yeah. AOD is off for me. But I've been using Nova for years without issues, and am a beta tester as well. But, if you tested it with Nova and without, then that's not it anyway. Thanks
 

toy4rick

Well-known member
Sep 13, 2011
213
0
0
Visit site
My issue started when I began using Messages for Web, sometimes I don't get any notifications, other times it can be delayed for 5-30 mins

Any correlation here?

Rick
 

Nauga

Well-known member
Nov 9, 2017
406
0
0
Visit site
Anyone here also not hearing a charging sound when you plug the phone in to top up? I just noticed that this morning. Plugged and unplugged 3X and not a peep.
 

Nauga

Well-known member
Nov 9, 2017
406
0
0
Visit site
My issue started when I began using Messages for Web, sometimes I don't get any notifications, other times it can be delayed for 5-30 mins

Any correlation here?
Not for me, I don't think. I checked Messages on the Web out when it was a new thing, but I never actually used it since all of my texts come via Hangouts thanks to Project Fi. (Looks like my phone and computer are still connected via MOW though.)

I'm beginning to think my notification angst is related to a recent Google app update, like this suspicious looking ARCore update from yesterday.

ERP! 7:33 AM and I just got a notification with sound on my lockscreen. That's the first one since maybe 8 PM yesterday. A 24-hour phone bug??
 
Last edited:

Nauga

Well-known member
Nov 9, 2017
406
0
0
Visit site
ERP! 7:33 AM and I just got a notification with sound on my lockscreen. That's the first one since maybe 8 PM yesterday.
Sadly, that was the only Gmail notification I've received all day on my lockscreen. The phone has also failed to ring once. That may have been due to a WiFi reception problem, but I'm very annoyed by that missing ringtone.
 

mahers

Well-known member
Jul 12, 2010
141
0
0
Visit site
When you all wake up in the morning and grab your phones, do you have any notifications at all? I do not. It takes about 20 minutes or so for the phone to realize it's being used, and then they all flood in at once. This is pathetic.
 

Nauga

Well-known member
Nov 9, 2017
406
0
0
Visit site
When you all wake up in the morning and grab your phones, do you have any notifications at all? I do not. It takes about 20 minutes or so for the phone to realize it's being used, and then they all flood in at once. This is pathetic.
If you use Project Fi, you can try resetting the Fi app. It's no 100% cureall, but I am getting more notifications and notification sounds than I have lately, as long as I keep Always On Display off.

Settings > Apps > Project Fi > Storage > Clear cache/Clear storage > Tap the notification to "Finish setting up Fi on your phone"
 

mahers

Well-known member
Jul 12, 2010
141
0
0
Visit site
If you use Project Fi, you can try resetting the Fi app. It's no 100% cureall, but I am getting more notifications and notification sounds than I have lately, as long as I keep Always On Display off.

Settings > Apps > Project Fi > Storage > Clear cache/Clear storage > Tap the notification to "Finish setting up Fi on your phone"
Verizon
 

mahers

Well-known member
Jul 12, 2010
141
0
0
Visit site
Ok, so I may be onto something. I am not 100% certain, but I decided to turn off my ad blocker app today, and it "seems" that my notifications are coming in as they should. Is anyone else here using an ad blocker? Specifically, I am using AdClear from XDA. I still want to test a few others when I get home, so I will keep you all updated on how that goes. I would be curious to know if anyone else seeing this issue is using this app or a similar one.