PC recognizes Nexus but then I can't access my storage

ttwiitch

Well-known member
Dec 2, 2012
688
0
0
Visit site
I went to transfer some files from my PC the other day for the first time on my nexus, and the drivers installed fine. When I searched for my device under 'my PC' it wouldn't appear. I tried switching between media and storage, disconnecting and reconnecting, switching USB ports. Nothing worked.

PLEASE HELP :-(

Posted via Android Central App
 

dazzer87

Well-known member
Oct 27, 2013
142
0
0
Visit site
I have the same problem, but in my case I installed Startup Manager. Under this app there was a "media storage" (i believe this is the name) which I disable at start up. I went back in and enable it for start up and my nexus finally showed up on my pc.
 

Disturbed_Angel

Well-known member
Nov 8, 2009
137
2
0
Visit site
Have you tried to enable your phone as a media device? Settings ->Storage -> Menu in the Upper R Corner -> USB Computer Connection is MTP selected?
 

anon(847090)

Well-known member
Jul 8, 2012
6,655
31
0
Visit site
1. make sure Settings ->Storage -> Menu[3 dots on top right] -> USB Computer Connection is MTP
2. USB debugging is disabled (if you ever enabled it)
3. make sure the drivers installed is MTP drivers rather than adb device(you do this when you unlock/root nexus)
point 3 is important. thats the reason why its not getting detected
 

ttwiitch

Well-known member
Dec 2, 2012
688
0
0
Visit site
1. make sure Settings ->Storage -> Menu[3 dots on top right] -> USB Computer Connection is MTP
2. USB debugging is disabled (if you ever enabled it)
3. make sure the drivers installed is MTP drivers rather than adb device(you do this when you unlock/root nexus)
point 3 is important. thats the reason why its not getting detected

2. Where in setting do I check for USB debugging?

3. How do I check this? (I'm not rooted)

Posted via Android Central App
 

anon(847090)

Well-known member
Jul 8, 2012
6,655
31
0
Visit site
2. Where in setting do I check for USB debugging?

3. How do I check this? (I'm not rooted)

Posted via Android Central App

2. developer option.. if you have not enabled developer option then you wouldnt have enabled USB debugging. so skip this

3. Connect your nexus to PC-->Go to Control panel-->device manager

you will see something like Android adb in device manager
Right Click and click "Update device Software"
Click "Browse your Computer for driver Software"
Click "Let me Pick from a list of device drivers on my Computer"
Click Next, for the device list shown.
 

patruns

Well-known member
May 21, 2011
3,192
59
48
Visit site
2. USB debugging is disabled (if you ever enabled it)

stil1, why would you want to do this? It doesn't interfere with Windows seeing the phone and could be quite helpful some day if the phone ever gets bricked.
 

jj14x

Well-known member
Jan 9, 2011
995
24
0
Visit site
I went to transfer some files from my PC the other day for the first time on my nexus, and the drivers installed fine. When I searched for my device under 'my PC' it wouldn't appear.

Go to device manager, and look to see if Android device has an exclamation mark next to it - or if it installed correctly. If it didn't install correctly, go to Google USB Driver | Android Developers and download the drivers from there - read more at Diagnosing USB Driver and ADB issues in Windows - xda-developers
 

ttwiitch

Well-known member
Dec 2, 2012
688
0
0
Visit site
Thanks for all the replies. I will try this as soon as I get home from work and report back. Thanks again.
:)

Posted via Android Central App
 

srkmagnus

Retired Moderator
May 23, 2010
13,434
210
0
Visit site
If all else fails you can take a look at a wireless solution, suck as WiFi Explorer or Air Droid. Connects with your home wifi and you are able to browse the device via pc.

Sent from my Nexus 5 using AC Forums mobile app
 

jairusz

Well-known member
Jul 22, 2012
175
0
0
Visit site
2. developer option.. if you have not enabled developer option then you wouldnt have enabled USB debugging. so skip this

3. Connect your nexus to PC-->Go to Control panel-->device manager

you will see something like Android adb in device manager
Right Click and click "Update device Software"
Click "Browse your Computer for driver Software"
Click "Let me Pick from a list of device drivers on my Computer"
Click Next, for the device list shown.

I could access the Nexus 5 through adb and when it's in the bootloader/recovery but I could never get it to show up and access its storage and this worked. Thanks!
 

anon(847090)

Well-known member
Jul 8, 2012
6,655
31
0
Visit site
stil1, why would you want to do this? It doesn't interfere with Windows seeing the phone and could be quite helpful some day if the phone ever gets bricked.

windows sometime act weird when USB debugging is selected, even when the drivers are right... i have seen few people have this issue
 

InclusionInnovates

Well-known member
Aug 28, 2011
46
4
0
Visit site
2. developer option.. if you have not enabled developer option then you wouldnt have enabled USB debugging. so skip this

3. Connect your nexus to PC-->Go to Control panel-->device manager

you will see something like Android adb in device manager
Right Click and click "Update device Software"
Click "Browse your Computer for driver Software"
Click "Let me Pick from a list of device drivers on my Computer"
Click Next, for the device list shown.

Wow! ... Thanks, saved me ... all I would add is:

Click MTP, as opposed to ADB, and update
 

ttwiitch

Well-known member
Dec 2, 2012
688
0
0
Visit site
2. developer option.. if you have not enabled developer option then you wouldnt have enabled USB debugging. so skip this

3. Connect your nexus to PC-->Go to Control panel-->device manager

you will see something like Android adb in device manager
Right Click and click "Update device Software"
Click "Browse your Computer for driver Software"
Click "Let me Pick from a list of device drivers on my Computer"
Click Next, for the device list shown.

This did the trick! Settings were a bit different but I found it :)

Posted via Android Central App
 

GoGayleGo

Active member
Apr 28, 2012
41
0
0
Visit site
3. Connect your nexus to PC-->Go to Control panel-->device manager

you will see something like Android adb in device manager
Right Click and click "Update device Software"
Click "Browse your Computer for driver Software"
Click "Let me Pick from a list of device drivers on my Computer"
Click Next, for the device list shown.

I'm trying to do this, but get the following error:
MTP error.JPG

Any idea what to do with that?

Thanks!
Gayle
 

Trending Posts

Forum statistics

Threads
944,477
Messages
6,922,920
Members
3,159,573
Latest member
allirose