Pixel 7 connection issues

aknight123456

New member
Dec 6, 2016
2
0
1
Visit site
Morning all,

My pixel 7 won't connect to any PCs via usb. When I connect it it comes up with the usual usb selection menu. 9/10 it then disappears (or greys out the options if you've clicked on the menu) within about 5 seconds. If it doesn't disappear then my computer just says USB device not recognised.

I've tried uninstalling the device on the PC end. I've tried 4 different usb C to usb A cables. One usb C to usb C. Two different PCs. All with the same results.

Has anyone encountered this before or know of a solution?

Thanks in advance.
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
92,764
7,383
113
Visit site
That usually sounds like a cable issue
Have you tried clearing the port on the phone? Also try in safe mode
 

gcodori

New member
Jun 26, 2024
1
0
1
Visit site
I am having the same issue after the June update; the USB debugging shows up for a few seconds and then disappears from the notification bar. Phone still shows connected/charging though. ADB no longer shows devices. Even wireless debugging does not work, so not a cord issue.

Update - I've been able to enable wireless debugging, but the USB is still a no-go. I suspect this has to do with Google's desire to push their own cord use, since the last update Google added the warning in the notification bar about charging on third party cords.

While wireless debugging will stay in the notification area, USB debugging no longer does. It appears and then after 5 seconds it disappears.

Update #2, after rebooting the pixel, it is now working. So not a cord issue. I had not rebooted since the June 5 update. So even thought he phone reboots for updates I recommend rebooting after an update.
 
Last edited:

Forum statistics

Threads
946,040
Messages
6,926,039
Members
3,160,053
Latest member
veronika