Returning it...am I first?

PookiePrancer

Well-known member
Jul 17, 2010
1,110
51
48
Visit site
Activated my new Evo LTE this morning. It didn't take long to realize that data speeds were nowhere near what I had with my Evo 4G. Connection completely lost in places where my 4G would at least roam; web pages taking forever to load, if ever; apps taking minutes to download.... So I decided to drive around town and do some Speed Test runs, and the results shocked me. I averaged 200kbps down and 40kbps up after about 20 tests, in areas where my Evo 4G will routinely do 1600kbps down and 700kbps up.

When I read about poor data speeds in some of the early reviews, I thought maybe the blogger had gotten a bad unit, or Sprint was just bad in their area. Well, maybe I too got a bad unit, but in light of the difference with my Evo 4G, I KNOW the network isn't an issue in my area. Could I try a replacement? Sure, but based on those reviews, and feedback others are providing in these very forums, I'm thinking the Evo LTE may have flawed antennas. Beautiful device...absolutely beautiful...but a phone without a data connection is worthless.

So...I'm sending mine back for a full refund and return to pre-upgrade status. If you're having reception issues now, I urge you to dig deeper before your return window expires. Don't let the euphoria of a new phone lead you down a path of misery for the next two years as you deny what you know you're seeing.
 

Awake

Well-known member
Apr 9, 2010
145
5
0
Visit site
You cannot compare your previous device which you've had for quite some time with a newly launched device. All new devices have to go through provisioning. People were saying the same thing about the first EVO then the 3D. The same was said about the E4GT. Just give time. ;)

Sent from my EVO using Android Central Forums
 

ericj12

Well-known member
Nov 14, 2011
187
49
0
Visit site
i had issues when i first activated it. it worked, but then i later realized that i wasnt getting any calls or texts and data wasnt working when i was off wifi. i had to use the sprint csr chat to have them reactivate it but then the next morning text and voice were working but data wasnt. another csr chat and they got it all working. havent had a problem since.
 

cloak.n.dagger

Well-known member
Jun 24, 2010
1,055
89
0
Visit site
Activated my new Evo LTE this morning. It didn't take long to realize that data speeds were nowhere near what I had with my Evo 4G. Connection completely lost in places where my 4G would at least roam; web pages taking forever to load, if ever; apps taking minutes to download.... So I decided to drive around town and do some Speed Test runs, and the results shocked me. I averaged 200kbps down and 40kbps up after about 20 tests, in areas where my Evo 4G will routinely do 1600kbps down and 700kbps up.

When I read about poor data speeds in some of the early reviews, I thought maybe the blogger had gotten a bad unit, or Sprint was just bad in their area. Well, maybe I too got a bad unit, but in light of the difference with my Evo 4G, I KNOW the network isn't an issue in my area. Could I try a replacement? Sure, but based on those reviews, and feedback others are providing in these very forums, I'm thinking the Evo LTE may have flawed antennas. Beautiful device...absolutely beautiful...but a phone without a data connection is worthless.

So...I'm sending mine back for a full refund and return to pre-upgrade status. If you're having reception issues now, I urge you to dig deeper before your return window expires. Don't let the euphoria of a new phone lead you down a path of misery for the next two years as you deny what you know you're seeing.

Did you update the PRL? I read in another thread that a user experienced slow speeds, as you describe, but updated the PRL and found vast improvements in the speed. Just thought I'd mention it in case you hadn't tried that yet.
 

mykrlz182

Well-known member
Jun 21, 2011
96
9
0
Visit site
It cracks me up when people have the phone for 1 day and a couple of hiccups happen and it's off to return! First of you have 30 days to return, at least try to solve some of the problems with a csr. Second its a new device and it's probably going to have some issues. If you look at another thread here discussing radios, the general consensus seems to be improvements across the board. Maybe you got a bad batch, but give it a chance its a great phone!

From my long awaited and totally worth it EVO LTE!
 

Awake

Well-known member
Apr 9, 2010
145
5
0
Visit site
Did you update the PRL? I read in another thread that a user experienced slow speeds, as you describe, but updated the PRL and found vast improvements in the speed. Just thought I'd mention it in case you hadn't tried that yet.

I just realized my device updated the PRL automatically after activation. That does help.
 

TraderGary

Trusted Member
Apr 12, 2012
3,056
54
48
Visit site
What area are you in? I'm in the Atlanta area and mine is noticeably faster in both 3G and WiFi than my previous EVO. Maybe try taking it in to a Sprint service center and having it checked out first. I love mine and it is a total breath of fresh air. There's no way I'm parting with this jewel!
 
  • Like
Reactions: jnl813

b_thomas

New member
May 10, 2012
3
0
0
Visit site
The traffic on the network probably has a lot to do with it. All the people just getting the EVO LTE are going to be installing apps and using it a lot more than normal so the speeds of the network in general are going to take a hit. Just checked mine and got 2Mbps down and 1Mbps up which is the highest I ever got with the OG EVO, but during the workday I'm lucky to even get 1/4 of that speed.
 

PookiePrancer

Well-known member
Jul 17, 2010
1,110
51
48
Visit site
Did you update the PRL? I read in another thread that a user experienced slow speeds, as you describe, but updated the PRL and found vast improvements in the speed. Just thought I'd mention it in case you hadn't tried that yet.

Three times; made no difference. Soon as I reactivated the old Evo, 3G speeds were back to normal. I certainly hope I keep seeing reports like those I'm reading here though. I would definitely like to revisit this phone. But for now, since I was going to have to wait on a replacement anyway, I figured I'd wait on my own terms.
 

PookiePrancer

Well-known member
Jul 17, 2010
1,110
51
48
Visit site
It cracks me up when people have the phone for 1 day and a couple of hiccups happen and it's off to return! First of you have 30 days to return, at least try to solve some of the problems with a csr. Second its a new device and it's probably going to have some issues. If you look at another thread here discussing radios, the general consensus seems to be improvements across the board. Maybe you got a bad batch, but give it a chance its a great phone!

From my long awaited and totally worth it EVO LTE!

You have 14 days on an upgrade, and since I'm going on vacation, I really don't really have much time to figure out why my phone doesn't work. Better things to do, you know?
 

ImNoPrince

Well-known member
May 7, 2012
169
16
0
Visit site
Yea that Suxs My 3g here is good and this has been pulling way more consistent bars and Speeds then I had on my OG 4g . Once it latches onto my WiFi it holds it well and breezed through the 100+ apps it had to load. I knwo they have already started updating towers here for better and more3G as well as LTE so maybe that has something to do with it.
 

dtreo

Well-known member
May 4, 2010
504
33
0
Visit site
Yea that Suxs My 3g here is good and this has been pulling way more consistent bars and Speeds then I had on my OG 4g . Once it latches onto my WiFi it holds it well and breezed through the 100+ apps it had to load. I knwo they have already started updating towers here for better and more3G as well as LTE so maybe that has something to do with it.

Just curious, but how can you possibly use 100+ apps?? I have about 3 that are of any need or real use to me.
 

prissysox

Trusted Member
Jun 11, 2010
1,246
12
0
Visit site
Just curious, but how can you possibly use 100+ apps?? I have about 3 that are of any need or real use to me.

I usually have upwards of 180 apps. I use quite a bit but my niece and nephew use the rest.

Sent from my ASUS Transformer Pad TF300T using Android Central Forums
 

cgardnervt

Well-known member
Jun 24, 2011
3,556
118
0
Visit site
In my area when I had my Evo 3D is was avg around 200K In VT. But Sprint isnt all that strong here either. In Boston I got around 600K speeds. So the 3D has some of the same issues I think. I had it for about 9 months before getting the HOX on ATT. There have been many reports of Sprints network speeds over this past year. So its hard to say if its the network or device. I thought it was the device but then learned the network here had gone down hill.

Either way the HTC Evo LTE looks like an awesome device! I hope your able to figure it out and keep the phone! I played with my friends Evo LTE but no speed tests from him yet. Maybe after the weekend!
 
  • Like
Reactions: Anthonicia

cert15z

Well-known member
Jan 5, 2010
1,203
5
38
Visit site
The traffic on the network probably has a lot to do with it. All the people just getting the EVO LTE are going to be installing apps and using it a lot more than normal so the speeds of the network in general are going to take a hit. Just checked mine and got 2Mbps down and 1Mbps up which is the highest I ever got with the OG EVO, but during the workday I'm lucky to even get 1/4 of that speed.

There not of new Evo LTE out there. To many people still waiting on pre orders

Sent from my Galaxy Nexus using Android Central Forums
 

ImNoPrince

Well-known member
May 7, 2012
169
16
0
Visit site
Just curious, but how can you possibly use 100+ apps?? I have about 3 that are of any need or real use to me.

I use my Phone for everything, Banking, CreditCards if they have an App. , I travel a good bit and Apps just work well . For work I have 4 or 5 that I use several times a day and then all the Social media and Streaming apps. It adds up fast but if it makes my Life easier I will find an App for it.

This was also why I'm glad this phone allowed me to Upgrade my Evo with the memory leak issue it just got to be to much resetting and such to keep above memory warnings.
 
Last edited:

Trending Posts

Forum statistics

Threads
946,028
Messages
6,925,984
Members
3,160,048
Latest member
honem224