ROM flash fail

Karl Kulp

May 15, 2013
Visit site
This is fixed. Did it from the command line using fastboot, from Google Web Toolkit. I think it was due to with driver issues, but me no know. Loose nut behind the wheel. :)


N7 wifi (2012)
Kernel: 3.1.10-g05b777c
ROM: JB 4.2.2

Using Wug's Nexus Root Toolkit 1.8 on PC running XP. TWRP for recovery and backups.

I unsucessfully flashed Cyanogenmod 10.1 and a gapps package on my N7 (running Timur's kernel and Jellybean 4.2.2). Don't know why it happened, but the new ROM didn't install. All that showed in settings were the stock ROM and the custom kernel (Timur's) I had previously flashed. Tried several more times, getting errors of one sort or another. Finally, I buggered it up but good. Bricked.

From there I went through the following steps:

(These are really just the notes I was taking while I was doing this.)

1. Flashed back to stock with a backup that I made when I originally rooted and flashed the custom kernel.

2. Unlocked

3. Rooted

4. Flashed "cm-10.1.0" - Doh! Forgot gapps. CM 10.1 downloaded from

5. Nandroid backup

(Filename "Rooted_2014-1-29--17-21-28") - Abandoned... thought it was taking to long.

6. Flashed "" ROM & "". I don't think this worked. N7 does not boot into CM. CM does not show up in settings, either. There is another gapps package released simultaneously, which is about 8.5 megs smaller. Is this the problem? Gapps downloaded from

7. Nandroid backup

(Filename "Rooted_2014-1-29--17-21-28") - This backup worked. It took 52 minutes!
Backup deleted from device.

SuperSU and BusyBox are missing -> should these have been installed before flashing CM and gapps?

Root Checker (Free Android Tools) says su and busybox are present, and root access granted. Google Play shows they need to be installed. Installed them.

8. Haven't got this far yet -> Flash Timur's kernel "timur-usbhost-2013-04-21-cm10.1" -> I want this kernel for host mode + charging.

Sorry if I'm revisiting solved problems. I went through a bunch of old posts trying to find a similar issue. I did find a thread that suggested that an incorrect version of gapps might be the problem. If there is, indeed, a thread that covers this or pushes me in the right direction, feel free to direct me there.

muy gusto gracias,

Last edited:

Forum statistics

Latest member