[ROM] OUTDATED THREAD -= Dark Sense ROM v.1.1 =- 8/22/11

Status
Not open for further replies.

jondevere

Well-known member
Jan 18, 2011
1,600
504
0
Visit site
Re: [ROM] -= Dark Sense ROM v.1.1 =- 8/22/11

Nopes. Everyone else's works fine that have used this ROM. Try wiping everything and trying again.
 

jondevere

Well-known member
Jan 18, 2011
1,600
504
0
Visit site
Re: [ROM] -= Dark Sense ROM v.1.1 =- 8/22/11

I am sorry. You might be right, altho I have others that have updated and have no issues.
 

scrosler

ROM Developer
Nov 30, 2010
1,552
954
0
Visit site
Re: [ROM] -= Dark Sense ROM v.1.1 =- 8/22/11

I been reading it has to do with kernels being 2.3.3 instead of 2.3.4 since i have the HBoot 1.5

In theory if you have the HTCDev method of unlocking 1.5 you would not be able to flash this ROM because of that kernel difference. You would be, in theory, stuck with a 2.3.4 kernel on a 2.3.3 ROM. I dont know for sure so dont quote me on this... But I dont think that combination would boot.

I think you have something else going on here... Not sure what though. While on Jon's ROM can you go into settings -> about phone -> software -> and tell me the versions? The hit "more" and tell me what those version numbers are?

Also, did you do a FULL wipe before jumping from my ROM to Jon's?
 

jondevere

Well-known member
Jan 18, 2011
1,600
504
0
Visit site
Re: [ROM] -= Dark Sense ROM v.1.1 =- 8/22/11

In theory if you have the HTCDev method of unlocking 1.5 you would not be able to flash this ROM because of that kernel difference. You would be, in theory, stuck with a 2.3.4 kernel on a 2.3.3 ROM. I dont know for sure so dont quote me on this... But I dont think that combination would boot.

I think you have something else going on here... Not sure what though. While on Jon's ROM can you go into settings -> about phone -> software -> and tell me the versions? The hit "more" and tell me what those version numbers are?

Also, did you do a FULL wipe before jumping from my ROM to Jon's?
Good call. Thanks for the support. Im super busy back n forth with so much recently. Its def not the physical ROM but I wanna know as well, why its not. What is the common factor here. I heard one other person say they had that issue but they never advised if they figured out how they fixed it.

Once again. Thanks and good luck to u on getting the wifi to work.
 

La.productions92

Active member
Sep 3, 2011
25
3
0
Visit site
Re: [ROM] -= Dark Sense ROM v.1.1 =- 8/22/11

In theory if you have the HTCDev method of unlocking 1.5 you would not be able to flash this ROM because of that kernel difference. You would be, in theory, stuck with a 2.3.4 kernel on a 2.3.3 ROM. I dont know for sure so dont quote me on this... But I dont think that combination would boot.

I think you have something else going on here... Not sure what though. While on Jon's ROM can you go into settings -> about phone -> software -> and tell me the versions? The hit "more" and tell me what those version numbers are?

Also, did you do a FULL wipe before jumping from my ROM to Jon's?
Android Version
2.3.3
HTC Sense Version
3.0
Software
Dark Sense v 1.1
Kernel
2.6.35.13 g84f8edd
Baseband
0.97.10.0808
Build
1.13.651.7 CL83920
Browser
Webkit/533.1
PRI
1.24_003
PRL
21081
 

beezy

Well-known member
Feb 27, 2010
2,434
1,010
0
Visit site
Re: [ROM] -= Dark Sense ROM v.1.1 =- 8/22/11

Just installed this ROM coming from CleanROM 2.3 and when i go to turn on wifi it says error? Any ideas why?

Are you still having this issue? If so can you do one thing for me just to check somethings to see if we can pin point the issue.
Run these commands in command prompt
Code:
adb shell
if using terminal on phone then don't have to run this on.
Code:
su
only need to runif at $ and not #
Code:
ls /system/lib/modules

Does it give you a print out with a couple files listed? if so can you paste what it says.
 

scrosler

ROM Developer
Nov 30, 2010
1,552
954
0
Visit site
Re: [ROM] -= Dark Sense ROM v.1.1 =- 8/22/11

Good call. Thanks for the support. Im super busy back n forth with so much recently. Its def not the physical ROM but I wanna know as well, why its not. What is the common factor here. I heard one other person say they had that issue but they never advised if they figured out how they fixed it.

Once again. Thanks and good luck to u on getting the wifi to work.

No problem Jon. I guess thats why you always ignore me on gtalk! lol

Android Version
2.3.3
HTC Sense Version
3.0
Software
Dark Sense v 1.1
Kernel
2.6.35.13 g84f8edd
Baseband
0.97.10.0808
Build
1.13.651.7 CL83920
Browser
Webkit/533.1
PRI
1.24_003
PRL
21081

Also i picked the first there options under wipe if thats what your asking
Thats interesting... You never used revolutionary to attain s-off before the htc method?


Here is what was listed

ls /system/lib/modules
bcm4329.ko
sequans_sdio.ko
wimaxdbg.ko
wimaxuart.ko

Those look correct to me.
 

La.productions92

Active member
Sep 3, 2011
25
3
0
Visit site
Re: [ROM] -= Dark Sense ROM v.1.1 =- 8/22/11

No i was under the impression Revolutionary wasnt available for the 1.5 HBOOT so i never used it. My wifi works on your ROM but not Dark Sense
 

scrosler

ROM Developer
Nov 30, 2010
1,552
954
0
Visit site
Re: [ROM] -= Dark Sense ROM v.1.1 =- 8/22/11

Kernel
2.6.35.13 g84f8edd


WAIT, WHAT?!?!?!

Thats not possible, is it?

Beezey, he is on the kernel compiled for 2.3.4 but has a 2.3.3 ROM! I thought that wouldn't boot? I know it wont if its vice versa. (I am not a kernel guru yet)

Maybe his modules are mismatched!

Do you think if I just packed up the correct modules it would resolve the issue?
 

beezy

Well-known member
Feb 27, 2010
2,434
1,010
0
Visit site
Re: [ROM] -= Dark Sense ROM v.1.1 =- 8/22/11

WAIT, WHAT?!?!?!

Thats not possible, is it?

Beezey, he is on the kernel compiled for 2.3.4 but has a 2.3.3 ROM! I thought that wouldn't boot? I know it wont if its vice versa. (I am not a kernel guru yet)

Maybe his modules are mismatched!

Do you think if I just packed up the correct modules it would resolve the issue?

Yes sir please do that would help me out greatly i was going to package the boot and modules all together and make a zip but my pc has decided to reboot a couple for no reason. Thanks ahead of time.
 

beezy

Well-known member
Feb 27, 2010
2,434
1,010
0
Visit site
Re: [ROM] -= Dark Sense ROM v.1.1 =- 8/22/11

No no... NOT AT ALL!

There is nothing technically wrong... But there is... I'll explain later... No worries at all though!

Ill take this why you make the zip;)
There's really nothing wrong that can do any harm. Just seems that you might have a mismatch of kernel and modules.If we're right then the zip he's making will just replace the modules to match the kernel.It happens i've done it to myself a million times it's no biggie. As you seen the worst that happens is the kernel can't turn wifi on.This could happen by boot.img not properly flashing over the old one or failed nadroid there's several different ways.
 

scrosler

ROM Developer
Nov 30, 2010
1,552
954
0
Visit site
Re: [ROM] -= Dark Sense ROM v.1.1 =- 8/22/11

Okay good to know... look forward to the explanation, this is interesting

Indeed because up until I posted the "wait what..." I though this was impossible but I guess its not...

You are booting the latest kernel on an older-ish ROM base. People who try to flash older kernels on the newer-ish ROM base cant and get boot loops. I dont understand because I thought either situation would get you boot loops but apparently not.

I hope beezey can tell us why you can boot a new kernel with older ROM but not an older kernel with new ROM.

Beezy, bone stock boot.img and modules attached. Flashable, unsigned.
 

beezy

Well-known member
Feb 27, 2010
2,434
1,010
0
Visit site
Re: [ROM] -= Dark Sense ROM v.1.1 =- 8/22/11

WAIT, WHAT?!?!?!

Thats not possible, is it?

Beezey, he is on the kernel compiled for 2.3.4 but has a 2.3.3 ROM! I thought that wouldn't boot? I know it wont if its vice versa. (I am not a kernel guru yet)

Maybe his modules are mismatched!

Do you think if I just packed up the correct modules it would resolve the issue?

It's weird but not suprized with htc anymore.lol The kernel should really boot on any version 2.3.3/2.3.4 not much would of changed probably main changes were something in ramdisk if any. They probably just update kernel version not making any major changes but the change from 2.3.3 to 2.3.4 would mean have to have new modules. I wouldn't be shocked if you took the boot from 2.3.3 and made small changes it would probably boot.
 
Status
Not open for further replies.