Jerry Hildenbrand

Space Cowboy
Staff member
Oct 11, 2009
5,569
2,797
113
Visit site
**Note -- this is based on my experience with the exploit, and information from others. I have no X10 to test this myself, but have been assured that it works with all versions.**

Download the attached application (apk file) and use the Sideload Wonder Machine to install it.

You can then run the application, and by all accounts it will easily root your X10.

Anyone testing this method is encouraged to reply and share their experience :)

All credit for the application goes out to ardf69 at XDA-developers, who even shares his source code. Thanks ardf69!
 
  • Like
Reactions: Icon

Icon

Well-known member
Mar 24, 2010
111
16
0
Visit site
I got a Xperia for free from my Sony rep, so I activated it on a dealer line just for a toy to use. I used this method to root it, and it was successful. Thanks for the info, your awesome Jerry. However I do have one question. After I rooted, I tried to install Titanium to back up my phone, before I flashed any ROMs. However, when I open Titanium, it just force closes. I granted it SU permissions, but for some reason it still FCs. Any help would be awesome. Thanks in advance.

Icon
 

sami510

New member
Mar 31, 2011
1
0
0
Visit site
i keep getting the "unhandled exeption has occured in your application" message, ive tried hooking up the usb differently, other apk files like z4root and nothing, what do i do so i wont get thet message and the apk file installs to my phone? xperia x10a at&t
 

igornvidal

Member
Apr 23, 2011
5
0
0
Visit site
As I've noticed, the first post is from February and it wasn't tested.

This is how i did it on my X10 (works with all models)

Download flashtool, install drivers (\flashtool\drivers), enable usb debugging, plug usb and ROOT!

You can do it similarly with SuperOneClick.

More detailed instructions here.
 

ibanez85

New member
Jun 5, 2011
1
0
0
Visit site
I've read through the entire thread and did everything:
- "charge only"
- installed .NET4
- turned off USB mass storage device completely (by changing a key in regedit)
- debugging on
- confirmed on device manager that it's read as an ericcson device and drivers are up to date (from ericcson official website for x10).
I have an AT&T X10 with the official 2.1 update that recently came out.
I still get "device not found". Please help!! Many thanks in advance!
 

Ramslayer

New member
Jul 20, 2011
2
0
0
Visit site
I've read through the entire thread and did everything:
- "charge only"
- installed .NET4
- turned off USB mass storage device completely (by changing a key in regedit)
- debugging on
- confirmed on device manager that it's read as an ericcson device and drivers are up to date (from ericcson official website for x10).
I have an AT&T X10 with the official 2.1 update that recently came out.
I still get "device not found". Please help!! Many thanks in advance!

This is the same with me... I've been trying all day.
 

brett1

Member
Jul 23, 2011
6
0
0
Visit site
hi tried everything followed as much as i can, and people don'y mean to sound think but will it look any different when it's rooted?? how will i now if done corectlly??

brett1:-\:-\
 

ChillFactorz

Well-known member
Dec 21, 2010
108
4
0
Visit site
I have an AT&T X10 with the official 2.1 update that recently came out.
I still get "device not found". Please help!! Many thanks in advance!

I remember having that issue when my sis-inlaw first got phone last Nov, I think it had to download a Java SDK file, try Here or the Oracle website. I was using 1.6 at that time not sure if it is the same read up on it on the site. hope it helps, I'm not that knowledgeable on this subject, just remember having same issues and I think this was the fix.
 

jito_k

New member
Jun 6, 2012
1
0
0
Visit site
hi, when I downloaded the attatched file, it installed well, I began da ROOT, but it never ends copying files... it just stops at 'wifi off.. wifi on''. so what do I do nxt??
 

robyrocks51

New member
Jul 19, 2012
1
0
0
Visit site
When you try to root your X10. It will damage your wifi driver. I faced same problem with my X10. I was not able to root my phone either. And my wifi driver is also damaged. I'll never be able to use my wifi again. And i can't even update my firmware bcoz it needs wifi connectivity to update firmware. I'm trapped, no escape.
 

macbook5

Active member
Feb 16, 2013
43
0
0
Visit site
Hey guys
Before I root my 6 month old SGS3 still under warranty, I bought a used SE Xperia X10a (Rogers) running stock Android 2.3.3 so I can learn how to root a phone. I am a little hesitant to root my S3 and decided to wait til the warranty up in July, so in the meantime, thought I'd learn using the X10. So I was going to try the SuperOneClick method referenced above and follow some of the other instructions igornvidal posted above. Will do it on my crappy Windows Vista Dell POC machine instead of my mac. Is there anything else I need to know besides what is referenced and posted above?

Thanks!
Cathy