SD Card Problem

theBIG

Well-known member
Jan 9, 2011
55
8
0
Visit site
Sorry to have to start a new thread, but I don't see an existing, adequate answer--apologies if I missed it.

Evo 4G, stock 3.70 rooted, HW v3, 16GB cl10 Wintec microSD.

Getting ready to flash an aftermarket ROM today. Made my nandroids, rebooted, and I get the "SD card is mounted readonly" error, with the "tap here to fix" message. I recall this happening once before, months back, and I just reformatted the card to recover. I'd prefer to avoid that right now, as I haven't made a backup copy of my card in too long.

Is there a known fix to even temporarily properly mount the card so I can, in any way or fashion, copy it to my PC before reformatting?

Any apps moved to SD card aren't recognized in my launcher. Root explorer just freezes when I try to navigate the card. It looks like Amon Ra can navigate the card, but it's slooooooow... would flashing a nandroid backup fix the problem? I thought I'd ask here to see if there's a known solution before winging it on my own and possibly making my data unrecoverable, if it isn't already.

Thanks.
 

theBIG

Well-known member
Jan 9, 2011
55
8
0
Visit site
Some further info: I was finally able to read the SD card on my laptop (reader on my desktop must be shot, got nothing there and thought the card was totally dead.)

I found at least one corrupt file. I have nandroids in the /clockworkmod folder, and in the /nandroid folder, then there's a /NANDROYD folder, within which is 2.7GB (!) file with a random 2-character ascii name, which says it was created 7/16/1984 @ 10:54am. There is also a folder named /PROGRA~q, which indicates a file size of 0, and is unreadable in Windows. Clearly, one or both of these are the cause (result?) of the corruption.

But I'm still hoping to learn what the root problem is, I know others have experienced this but I haven't been able to find a cause (any forum that google's led me to, the end result was reformatting, but no cause or solutions.)

Also--anybody know which app uses a folder called "NANDROYD"?

EDIT: Nobody around today? Bummer.
To add further info... I recovered all data that I could--Windows wouldn't touch the corrupted /NANDROYD or /PROGRA~q folders, of course, but I figured the phone would format it just fine. AmonRa, wipe SDcard, seemed to work. Boot into Android, still the same situation (mounted readonly, can't change, can't format.) What to try next?
 
Last edited:

Forum statistics

Threads
943,945
Messages
6,920,737
Members
3,159,317
Latest member
lbburns87