So... why would my phone be stuck in roaming?


Well-known member
Dec 20, 2009
Visit site
I thought I'd try out liquid smooth, a 4.2.1 rom, up from a stock, rooted 4.1.1. Great ROM, overall, but I didn't think much of the Bluetooth sound for music: scratchy, jerky.

So, I thought I'd give CM 10.1 a shot. So, I downloaded CM 10.1 from the daily, made sure I had the Rom Manager recovery downloaded and it indicated it was installed.

But when I went into recovery, TWRP was the recovery that came up.

So, I tried to install CM10.1 with that. Probably not the greatest move, but it did seem to work... except for one thing: it showed I was roaming. I'm not. Never have with this phone. At some point in all of this, I got the dreaded "you've got unauthorized software on your phone warning..." I tried to get out of that screen, and wound up popping out the battery... and so on.

I thought it would be a setting or a problem that someone else had already fixed. so, I thought I'd better bail on that altogether, so I thought I'd try flashing (odin) the same stock rom I'd used to get 4.1.1 in the first place. The roaming warning came up and now, no matter what I do, it stays stuck on roaming.

Any suggestions? I've spent a few hours trying to solve this (6, so far) and searched all over... so any help would be appreciated.


Well-known member
Dec 25, 2011
Visit site
Had this exact problem. Googled forever. Restore stock via Odin. Boot in roaming.

Dial *2767*3855#

It'll reboot a few times a reprovision phone

Sent from my SCH-I535 using Tapatalk 2