Unable to Add New Contacts to Google via the Device

ERDude

Well-known member
Oct 21, 2009
489
2
0
www.droidtalk.net
Has anyone else experienced this?

I just noticed any new contacts I add via the Hero are added to the phone only, the option to make them a Google contact is gone from my Hero. I can sign into Google from the Mac and add contacts that way and they do show on my phone.

Any ideas why this happened? Is there a limit to the number of Google contacts you can add via the device?
 

voghan

Well-known member
Jan 30, 2010
592
8
0
Visit site
I've noticed this as well. When I rooted several of my contacts disappeared after I installed the new rom. Thankfully I have Lookout backing up my contacts and I could restore a couple of them.
 

ERDude

Well-known member
Oct 21, 2009
489
2
0
www.droidtalk.net
I'm not losing contacts, just can't add Google contacts via the phone. Tried every fix out there on the net I could find, finally had to hard reset. Man am I going to be ticked if 2.1 drops ota tomorrow.
 

willy900wonka

Well-known member
Feb 4, 2010
82
4
0
Visit site
I'm using the stock rom, and any contacts I add are from the phone are phone contacts. I have resorted to creating spare google contacts ( 1,2,3,... as names, and no other data ) on the computer, then syncing them to the phone. If I want a new google contact I edit the name and info. It does then resync back to the computer, with the new name and data.
 

willy900wonka

Well-known member
Feb 4, 2010
82
4
0
Visit site
Here's the fix, without wiping.

(Solved) Hero - Add New google contact - xda-developers
( post 4)
mtdoughty said:
I then compared the settings in data/data/com.android.htccontacts/shared_prefs with the current version on the phone. Sure enough there was a line missing from the phone version.

<boolean name="google_login" value="true" />

I was able to live with it until now.
I tried the changes and they worked. Used root explorer and edited the file and saved it, reboot and google type shows up and works. The best part is it didn't require a wipe.
 

fallonjp

Member
Mar 4, 2010
10
0
0
Visit site
So I tried another work around for this which was to go into Manage Applications then Google Apps and clear the history. Problem now is that when I try to log back in with my Google account I get this error:

Can't establish a reliable data connection to the server.
This could be a temporary problem or your SIM card may not be provisioned for data services. If it continues, call Customer Care.

Any way I can fix this without having to call Customer Care and doing a hard data reset?

Thanks.
 

Forum statistics

Threads
942,815
Messages
6,915,997
Members
3,158,665
Latest member
Ramki