Weird chainfire root problem on Galaxy S3 (SGH-T999), Android 4.3

  • Thread starter Android Central Question
  • Start date
A

Android Central Question

I tried rooting my wife's S3 so I can get all of her files moved to her new S7. First I tried CWM, then discovered the incredibly easy chainfire method ("CF"). CF is great for me because I don't care about flashing a new ROM, just getting access to files in the root directory, and the process is super easy.

The root process (which I've done before on several other Samsung phones) never seemed to "take," so I tried over and over seemingly without success. However, I downloaded a root checker and it says the phone actually IS rooted. But SuperSU crashes every time I try to use it, and nothing has root privilege.

My guess is, the problem is Knox security (which I believe got loaded with update to Jelly Bean). I've tried to kill it, and it does stop telling me that "a program was blocked due to security" when I do, but I still cannot get SuperSU or ROM toolbox pro or anything else to run.

Any tips or hints? I just want to get root access to the folders on this phone in order to get the last of my wife's files moved to her S7.

Thanks for any help!
 

Rukbat

Retired Moderator
Feb 12, 2012
44,529
28
0
Visit site
SuperSU runs fine under Knox (I had it running for years on a Note 3), so that's not the problem.

Are you certain that you used the Chainfire file for the T999, and not for some other variant of the S3? (That could cause all sorts of problems.)
 

craighaggart

Member
Aug 1, 2012
7
0
0
Visit site
SuperSU runs fine under Knox ... so that's not the problem.

I did wonder about that, since it still didn't run even though I did a forced stop on everything related to Knox.

Are you certain that you used the Chainfire file for the T999, and not for some other variant of the S3? (That could cause all sorts of problems.)

Yes, for certain it was the 999 version. The file is named CF-Auto-Root-d2tmo-sght999.

I also tried using different PCs with different versions of Windows, but ended up with the same result.

I'll attach a screen shot of what Advanced Root Checker sees. The error message for SuperSU is always the rather vague "Unfortunately, SuperSU has stopped." It pops up immediately.

Again, all I actually want is access to all files on this phone including the root directory. I have the paid versions of Titanium and ROM Toolbox, and I downloaded BusyBox and a couple of root browsers that worked great on my other (rooted) Samsung phones. This phone clearly doesn't know about BusyBox, and launching a root browser hangs up the phone with permanent white screen (I can get the power off or reboot option with the power button, but they don't work - I restart by removing/replacing the battery). I'm guessing all will be fine if I can ever get SuperSU to run, so that's my current focus.

-Craig
 

Attachments

  • S3screenshot.jpg
    S3screenshot.jpg
    282.6 KB · Views: 2
Last edited:

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,778
4,989
113
Visit site
I'm going to repost this in the T699 forum - I hadn't realized that there was an area specific to this phone!

-Craig

I hope you don't mind, but I'm actually going to move this thread to the S3 Rooting/ROMs forum, since that would probably give you the most specific traffic.
 

Forum statistics

Threads
943,933
Messages
6,920,694
Members
3,159,314
Latest member
rambo4id