Why isn't my Headset/earphone button working after downgrading from BOB1 to NH6?


New member
Jul 6, 2014
Visit site
Headset/earphone button not working after downgrade from BOB1 to NH6

I have Grand 2 with original Headset/earphone.

I found that after downgrade from kitkat 4.4.2 firmware BOB1 - to firmware NH6 my Headset/earphone button not working for call pickup/drop and also for music play/pause.

I have followed method from xda for for downgrading.

I have tried that Headset/earphone in my friends grand 2 mobile and the button working fine for call pickup/drop and also for music play/pause.

I have also purchased Samsung Original Headset/Earphones (HS-130 with volume controls), this is also not working on my Grand 2, but working on my friends grand 2.

I have also again upgraded to BOB1 with official method with kies 3 and firmware upgraded successfully. But still Headset button not working.

I have checked my mobile from Samsung service center, they reinstall the firmware but not succeeded and they told me that for its working complete mother board needs to be changed.

I have tried Sony's Smart Key App, Headset button Control and like this 2 to 3 apps from play store, but not success.

I have also checked with KeyTest app but my grand2 cant detect button press (nothing happend with headset button press while other button like phone volume button up/down, menu and back button shows),
while my friends Grand 2 detects with following code,
KeyEvent: KeyEvent { action = ACTION_DOWN, key code = KEYCODE_HEADSETHOOK, scanCode=226 ..... }

Then what should be my problem, please if any one can point out?

Any re flushing through Odin with any particular settings will help? Samsung service center had already tried by reinstalling latest firmware.

Please help me out. Thanks in advance.