Zagg Invisible Shield HD & Proximity Sensor Problems

Apr 22, 2010
17
2
0
Visit site
Hey Guys,

I was wondering if anyone who has the Invisible Shield HD installed is having the same issues as me. I had mine installed at best buy and the rep did it perfectly to where all the seems matched up, so I really had no complaints at the moment.

Upon using my phone after it was installed though I realized the proximity sensor wasn't functioning at all anymore, and when I looked at how the screen protector was set up, there is a notch for one light (which isn't listed in the user guide) but right next to it is where the proximity sensor is and it's completely covered by the screen protector.

So I was wondering if anyone else had this same issue and if they've been able to fix it by a means other than taking a razor blade to my phone...
 

kyouka

New member
May 25, 2012
1
0
0
Visit site
I have been having the same exact problem! I got a pack of the HTC ones that the sprint store had so I could get the 20% off. Has anyone tried those? I had the HTC ones on my 3D and they seemed to scratch up pretty quickly.
 

Mercury81

Well-known member
Jan 26, 2012
1,138
82
0
Visit site
I have been having the same exact problem! I got a pack of the HTC ones that the sprint store had so I could get the 20% off. Has anyone tried those? I had the HTC ones on my 3D and they seemed to scratch up pretty quickly.

I also purchased the zagg dry full body shield from Sprint Store and will attempt to put them on hopefully today...

sent from my Evo4LTE
 

SirThale

Well-known member
Jan 14, 2010
49
2
0
Visit site
Same issue here, and I've been wondering if it's the Zagg screen protector causing it. I've looked though and didn't see any other sensor that seemed to be covered - where are you seeing an additional one other than the notch?
 
Apr 22, 2010
17
2
0
Visit site
Same issue here, and I've been wondering if it's the Zagg screen protector causing it. I've looked though and didn't see any other sensor that seemed to be covered - where are you seeing an additional one other than the notch?

If you look closely right next to the notch there is a tiny rectangle that when you're on a call with have an amber light that comes on.
 
  • Like
Reactions: SirThale
Apr 22, 2010
17
2
0
Visit site
Also just an update. I took a razor blade to it this morning and basically extended our maybe 2cm from the notch and now the proximity sensor is functioning fine. So I can safely say that the Zagg protector was causing the problem.
 

AFR_NY

Well-known member
May 10, 2012
54
2
0
Visit site
Also just an update. I took a razor blade to it this morning and basically extended our maybe 2cm from the notch and now the proximity sensor is functioning fine. So I can safely say that the Zagg protector was causing the problem.

How do you know if the Proximity Sensor is working properly? I would like to test this on the Zagg Shield I just put on.
 
Apr 22, 2010
17
2
0
Visit site
Basically easiest way to test is to call someone, and then take the phone away from your ear. The screen should come back on, if it doesn't then you're having the same issue as me.
 
  • Like
Reactions: AFR_NY

jfenton

Well-known member
Aug 11, 2010
645
37
0
Visit site
Did you cut the shield with it on the phone...with a razor blade????????????????

I have emailed ZAGG and asked what they plan to do about the issue.
 

themuskr

Active member
Jun 10, 2011
30
7
0
Visit site
I have a Skinomi shield, which had no cut out your the sensor at all. So sounds like the skin is not at fault.

Sent from my EVO using Android Central Forums
 

rduncan49

New member
May 29, 2012
1
1
0
Visit site
Just got off the phone with Zagg. The rep told me that the screen protector was causing the problem. If you have bought the Zagg HD screen protector you need to call Zagg and report the problem. They don't actually get the phone when they design the screen protector. They just go by the pictures sprint releases. If enough people report it they will redesign the product and you will receive one for free.
 
  • Like
Reactions: Sh3ngLong

Sh3ngLong

Well-known member
May 16, 2010
450
75
0
Visit site
Thanks, will do.

But I'm not sure if it's entirely the screen protector's fault. People who don't have any screen protector on are also reporting this issue.
 
Apr 22, 2010
17
2
0
Visit site
Did you cut the shield with it on the phone...with a razor blade????????????????

Yes...was a truly scary experience, but it all worked out in the end with no scratches on the phone.

It was definitely the screen protector causing the issue as it's been working fine ever since I put it under the knife. Also I notified them of the issue yesterday, so hopefully enough people have told them about it that they'll just extend the notch cut to be about 3cm wide.
 
Last edited:

AFR_NY

Well-known member
May 10, 2012
54
2
0
Visit site
I am having the issue with the non-HD Shield.

I wont be taking a razor to my phone that was recently released from ITC prison. I will be getting a new Shield and cutting it before it is installed.
 

Mercury81

Well-known member
Jan 26, 2012
1,138
82
0
Visit site
I am having the issue with the non-HD Shield.

I wont be taking a razor to my phone that was recently released from ITC prison. I will be getting a new Shield and cutting it before it is installed.

Lol, treat that phone like it's your one and only. I think you would be much wiser to cut before placing it on the screen...:D

sent from my Evo4LTE
 

Trending Posts

Forum statistics

Threads
941,535
Messages
6,909,318
Members
3,157,958
Latest member
bacxiu