ZenPad 7 can't install apps

Mirski

Member
Feb 4, 2017
5
0
0
Visit site
A friend gave me this tablet to fix. He said that it won't download apps from google play. I decided to test it out and downloaded an app which after downloading and "installing" for a little bit gave me an error 504. My internet connection is fine, I can download apps on my phone just fine (OnePlus One) but for some reason they won't download on the tablet. I tried factory resetting multiple times with no success. I also tried downloading an apk from the internet and when i tried installing it it said "app not installed". I think it's the stupid "Zen UI", I think I'll try flashing a custom ROM on it as a last resort but before I do it is there anything you can suggest? Worst case scenario, what ROM would you recommend for that tablet?
 

Mirski

Member
Feb 4, 2017
5
0
0
Visit site
I haven't tried on a different network, but assuming he has the same problem and I can download apps on my phone just fine, I don't think it's the network. I am using my personal google account, but when he first gave me the tablet he was logged into his account and I got the same error. I also tried clearing data and cache on google play services and some other apps which I can't remember multiple times with no effect.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,974
4,001
113
Visit site
It's possible for one device to work on a given wi-fi network, and another to have issues, so it's still worth trying a different network. Also, try rebooting your router (by unplugging its power for 10 seconds, then plugging back in).
 

Mirski

Member
Feb 4, 2017
5
0
0
Visit site
Ok, I tired this and unfortunately it didn't work. I also tried downloading an app with my mobile data connection (which is actually faster than my WiFi strangely) and it also didn't work. Thanks for your help though if you know anything else let me know. I'm starting to think more about flashing a ROM on it (since it's pretty slow even after resetting it), can you recommend one?
 

Mirski

Member
Feb 4, 2017
5
0
0
Visit site
Same result, something interesting I've noticed is that every time I reboot the tablet, the "optimizing apps" screen shows up and does the "optimizing", as if I updated the software.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,974
4,001
113
Visit site
Flashing a ROM (or at least reflashing the stock ROM) might be a good idea, because it's starting to sound like the firmware got corrupted somehow. Sorry, but I don't have any direct experience with that, so I can't give you good recommendations. Check the forums at XDA-developers.com, or perhaps the Zentalk forums (the official ASUS forum).
 

Trending Posts

Forum statistics

Threads
941,474
Messages
6,909,019
Members
3,157,940
Latest member
Scrap