1. FutureTBoltOwner's Avatar
    First of all I apologize if there is already a thread like this I thought there was looked through and used the search function couldn't find it ... Anyways to my problem it seems everytime I turn on WiFi and then turn it off I have problems re establishing 4G connection my 4G does connect but only the up arrow lights up so I only send data but do not receive any and the only way I've found to correct it so far is to restart the phone ... Anyone else have this problem or solutions? Any help is appreciated
    03-20-2011 11:33 AM
  2. realitydigg's Avatar
    The arrows only light up when in use. They should not be lit most of the time. Make the switch then try to browse the web, if it works then you are getting downloaded data.
    FutureTBoltOwner likes this.
    03-20-2011 11:42 AM
  3. FutureTBoltOwner's Avatar
    I have tried to use web after turning off WiFi and letting the 4g connect all that happens is it tries to process the request and fails the webpage always says could not display this page check your connection and try again ... Like I said only the sending data arrow will light on and off the receiving arrow always stays off until I restart the phone
    03-20-2011 11:49 AM
  4. realitydigg's Avatar
    Are you in a marginal 4g area? Mine works well, but i get a few bars
    03-20-2011 11:51 AM
  5. FutureTBoltOwner's Avatar
    Well I would guess I'm in marginal (50%) signal strength for 4g most of the time where I use WiFi ... But today I left without turning off WiFi and got to my destination realized this and turned it off there and it is 100% signal strength for 4g where I'm currently at and I still had to restart my phone before I could get it to start receiving data again even gave it a few minutes before restarting to see of it could push itself through

    And on top of this its now telling me I'm in Chicago on the home screen of the phone
    ... Not even close
    03-20-2011 11:59 AM
  6. FutureTBoltOwner's Avatar
    03-20-2011 12:39 PM
  7. FutureTBoltOwner's Avatar
    Im still having no luck with this, so I guess my best bet is to avoid the WiFi for a little while until a solution presents itself, don't want to kill my new beauty by having to restart it 10 times a day
    03-20-2011 04:38 PM
  8. jdk2's Avatar
    You may have a defective device. Mine switches between 4G, 3G and wi-fi without issue. I use them all and have no problem with any data connection.
    03-20-2011 04:44 PM
  9. FutureTBoltOwner's Avatar
    I sure hope not, would hate to have to replace it with another one over this, I will hold out for a few days to assess the situation and see what happens, maybe it will help anyone who might know a solution to know I have verizon Fios for my home internet ... possibly a conflict of verizon signals when attempting to switch between wifi and 4G ... ?
    03-20-2011 05:01 PM
  10. realitydigg's Avatar
    Mine switches fine - don't know what to tell you. What are you running (downloaded that you added) on the phone is probably a good place to start
    03-20-2011 05:02 PM
  11. p08757's Avatar
    Instead of rebooting your phone, try going into airplane mode and back out. I have to do this on my DroidX every now and then. Clears up a nonworking connection almost every time.
    FutureTBoltOwner likes this.
    03-20-2011 05:12 PM
  12. FutureTBoltOwner's Avatar
    Instead of rebooting your phone, try going into airplane mode and back out. I have to do this on my DroidX every now and then. Clears up a nonworking connection almost every time.
    will have to give this a try, if that avoids restarting then I will be willing to live with it, as thats not such a hassle to be able to get it to reconnect with 4G

    and to realitydigg, do you mean everything I've done, apps from the market and anything added, if so gotta go get the ol phone and start listing
    03-20-2011 05:30 PM
  13. brobertsleo's Avatar
    I had that issue once. All I had to do was turn off mobile data then turn it back on. After that the 4G data started working correctly.

    Sent from my HTC Thunderbolt using Tapatalk
    FutureTBoltOwner likes this.
    03-20-2011 05:37 PM
  14. FutureTBoltOwner's Avatar
    I think I just actually stumbled upon my own solution, so basically for Wifi I was only using the widget on the second home page to turn it on and off, this time I decided to turn it off by going under the settings and presto 4G instantly connects with both arrows turning on to let me know I have a data connection before going gray, now the real test is leaving Wifi on for a while and then trying this. I only tried this by leaving on wifi for a few seconds, the other times where i was having trouble the wifi was on for well over 30 minutes each time so im gonna leave the wifi on for a while and then try, if the problem returns I will try the airplane mode method

    a round of thanks for everyone that tried to help
    03-20-2011 05:40 PM