06-23-2017 07:53 AM
37 12
tools
  1. Admantius's Avatar
    I have a S5 with Android version 6.0.1 and have this problem too. KingRoot doesn't have a root option for my device (model sm-G900p). I don't have any experience with rooting, so I'm nervous about bricking my phone. Can anyone suggest another rooting application that they trust?
    04-19-2016 06:09 PM
  2. baringer3's Avatar
    Was curious which version s4 you had before I try rooting I have the 545 / 5.0.1 but it has Knox installed and don't want to brick the phone!
    05-03-2016 02:17 PM
  3. QuentinOz's Avatar
    Hey guys, had the same issue with a droid turbo 2 moto from Verizon.
    Being in Australia I could not resert the smsc manually for some reasons but I didn't have to at the end.

    http://forums.androidcentral.com/ver...ml#post3394605

    This solved the problem for me with no need of rooting the phone which I was kind of reluctant to do.
    Going into the dialler parameter and follow the steps in the link.

    Hope it helps.
    08-05-2016 03:26 AM
  4. JwvH's Avatar
    I am also having the same problem. Switched from Verizon to t-mobile, now can't send texts.

    I used King Root to root my phone. Installed Advanced Signal Status, and opened Additional Info, but nothing happens.

    What am I doing wrong? Thanks.
    10-14-2016 09:02 PM
  5. cjohnk1's Avatar
    I have tried this method but after hitting Update nothing at all happens. If I leave the page and come back the line is empty as if I typed nothing at all.

    Any ideas?
    10-29-2016 07:02 AM
  6. Todd Matthews's Avatar
    Many of you have suffered the same as me. I found another string on this site that eluded to a fix. I followed it and was more precise and found the exact fix. 1) Rooted my phone using Kingroot (very easy 1-click root tool @ http://www.kingroot.net/) 2) Downloaded and installed the app Advanced Signal Status (https://play.google.com/store/apps/d...gnalinfo&hl=en) 3) Opened Advanced Signal Status app and clicked "Additional Info" (this opens the phone's hidden menu only accessible after rooting) 4) Under SMSC I changed the field to "+12063130004" for T-Mobile and pressed update. 5) I changed the preferred network type from LTE/GSM to GSM/CDMA Auto (uses the EDGE network) 6) Restarted the phone and it was able to send SMS messages thereafter.
    I hope this helps!!
    GalaxyS4user9000 likes this.
    10-31-2016 05:08 PM
  7. 1yoyojenny's Avatar
    I have a Droid turbo 2 and couldn't find my message centre number and couldn't call the number *#*#4636#*#* so I downloaded the app 4G LTE SWITCH and got it.. smsc ___ update, refresh or put the number in. My problem was I couldn't send or receive pictures so I used Facebook messanger as my default messaging app and I'm good now.
    01-15-2017 10:27 AM
  8. Jono Lach's Avatar
    I know this is an old post but I just wanted to sign up and say thanks for the help my cell phone company and Samsung could even get the problem fixed then I came across your post and tried everything and it works right away hopefully you get a chance to read this I really appreciate the help I almost feel like calling Samsung and my cell phone provider to tell them how to fix it because they are both useless
    04-24-2017 09:01 PM
  9. Jono Lach's Avatar
    I solved this issue for my girlfriend's phone on AT&T. Not sure if this exactly applies but here is what I learned/what i did:

    After a few hours of research i discovered the issue was two fold:
    1) Phone cannot send text messages through 4G (so disabling 4G LTE - i know this sux, and instead using HSPA - not thaaat bad)
    2) Cannot change the SMSC phone number the texts will go through

    Here is what I did:
    1) Rooted her phone using Kingroot (very easy 1-click root tool)
    2) Downloaded and installed the app Advanced Signal Status
    3) Opened Advanced Signal Status app and clicked "Additional Info" (this opens the phone's hidden menu only accessible after rooting)
    4) Under SMSC I changed the field to "+13123149810" for AT&T and pressed update ***Note you will have to find the corresponding number for TMOBILE
    5) I changed the preferred network type from LTE/GSM to GSM Auto (this disables 4G LTE and only uses HSPA)
    6) Restarted the phone and it was able to send SMS messages thereafter.

    Hopefully this works for TMOBILE as well (not sure if they have HSPA coverage).

    Good luck!
    I tried to quote your post but I hit the reply button instead hopefully you seen the message I wrote .

    Thx so so much
    04-24-2017 09:03 PM
  10. Jono Lach's Avatar
    I have a Droid turbo 2 and couldn't find my message centre number and couldn't call the number *#*#4636#*#* so I downloaded the app 4G LTE SWITCH and got it.. smsc ___ update, refresh or put the number in. My problem was I couldn't send or receive pictures so I used Facebook messanger as my default messaging app and I'm good now.
    Put the number in and then hit refresh . Then reboot phone
    Also have your carrier send your apn settings via text.message

    Sounds like it's your mms settings not set right .
    04-24-2017 09:04 PM
  11. ebonyglitter's Avatar
    I solved this issue for my girlfriend's phone on AT&T. Not sure if this exactly applies but here is what I learned/what i did:

    After a few hours of research i discovered the issue was two fold:
    1) Phone cannot send text messages through 4G (so disabling 4G LTE - i know this sux, and instead using HSPA - not thaaat bad)
    2) Cannot change the SMSC phone number the texts will go through

    Here is what I did:
    1) Rooted her phone using Kingroot (very easy 1-click root tool)
    2) Downloaded and installed the app Advanced Signal Status
    3) Opened Advanced Signal Status app and clicked "Additional Info" (this opens the phone's hidden menu only accessible after rooting)
    4) Under SMSC I changed the field to "+13123149810" for AT&T and pressed update ***Note you will have to find the corresponding number for TMOBILE
    5) I changed the preferred network type from LTE/GSM to GSM Auto (this disables 4G LTE and only uses HSPA)
    6) Restarted the phone and it was able to send SMS messages thereafter.

    Hopefully this works for TMOBILE as well (not sure if they have HSPA coverage).

    Good luck!
    Thanks, it worked for my T-mobile, with my courier's smsc, thanks again
    04-28-2017 04:48 AM
  12. GalaxyS4user9000's Avatar
    Worked perfectly. Thanks for step 5. My texts finally work after weeks of reading about this issue for hours.
    06-23-2017 07:53 AM
37 12

Similar Threads

  1. Auto Change Network Operators
    By farrsolo in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 08-17-2015, 05:52 AM
  2. Replies: 86
    Last Post: 07-27-2015, 12:29 PM
  3. Is the Serial Number the same as the IME?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-19-2015, 09:35 PM
  4. How can I have Hangouts read my messages using text to speech?
    By maximegousse in forum General Help and How To
    Replies: 0
    Last Post: 07-19-2015, 08:27 PM
  5. s4 ui failure
    By bj white in forum Ask a Question
    Replies: 0
    Last Post: 07-19-2015, 08:01 PM
LINK TO POST COPIED TO CLIPBOARD