1. Shadnic's Avatar
    I updated to 7.0 a day or two ago, completely stock Nexus 6P.

    Any time I leave a wifi-zone, there seems to be a 50% chance that my phone will lose all data connections. I'll show full bars, and if I go into network settings it says I'm connected to LTE, however the LTE icon is gone from my status bar and my phone cannot connect to the internet at all.

    I've tried resetting mobile data, toggling airplane mode on/off, and even turning the phone on/off. SOMETIMES one of these will work, but most of the time, no dice. Nothing will get my phone to reconnect to the network and it's essentially unusable until I am home again where I have wifi.

    I figure it must be related to the google connectivity service being enabled since that looks for wifi to connect to. It keeps connecting me to "cable wifi" networks which require a sign in (which never works), however even if I turn this option off, or even turn wifi off entirely, my phone still won't reconnect to the LTE network (tmobile in case it matters).

    Anyone experience this or have any idea how to troubleshoot?
    09-22-2016 12:58 AM
  2. darksome's Avatar
    Did you have this resolved? I'm having the same issue since Nougat 7.1.1 on Nexus 6P and also on T-Mobile.
    12-28-2016 09:33 PM
  3. RabbiGlickman's Avatar

    You and about everyone else on the planet.
    Experiencing the same problem with a Moto Z.

    Only solution I've read is to go back to Marshmallow

    Fortunately for me I'm still within return period for my carrier. Back it goes.
    02-05-2017 06:54 PM

Similar Threads

  1. Heavy data connection issues Nexus 6P
    By longtime44 in forum Nexus 6P
    Replies: 2
    Last Post: 09-23-2016, 10:28 AM
  2. Nexus 6P phone audio not working after Nougat update
    By idiomsavant in forum Android 7.0 Nougat
    Replies: 2
    Last Post: 09-23-2016, 09:05 AM
  3. Nexus 6 still on July security update?
    By wezi427 in forum Google Nexus 6
    Replies: 4
    Last Post: 09-22-2016, 07:48 AM
  4. Why Indian Nexus 6p doesn't have volte
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-21-2016, 10:34 PM
  5. Some Nexus 7 files not accessible to Win 7 PC
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-21-2016, 09:29 PM