1. AC Question's Avatar
    Understand that, it allow same user for different devices.
    I had google account for my Samsung Note3, recently i had bought Samsung tabs 8.4, trying to connect to 'Playstore', however there is error message 'No connection - Retry'
    10-07-2014 01:14 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! On your Tab S, do all other Google apps work, like Gmail, Google Drive, etc.? Have you tried going to the App Manager, selecting Google Play Store, and Clearing Cache/Data?
    10-07-2014 01:34 AM
  3. maple_autumn's Avatar

    I had tried to clear the cache for 'google playstore' and check my devices time. It functioning properly. Do you have any other advice.

    Thank you
    10-07-2014 01:52 AM
  4. B. Diddy's Avatar
    Did you also Clear Data from Google Play Store?

    Also consider removing your Google account from the phone, then adding it back.
    arifbsantoso likes this.
    10-07-2014 02:13 AM

Similar Threads

  1. Anyone try DK36 magnetic charger with z3?
    By Jonathan Lin1 in forum Sony Xperia Z3
    Replies: 4
    Last Post: 01-14-2017, 03:23 PM
  2. Replies: 0
    Last Post: 10-07-2014, 12:27 AM
  3. Replies: 0
    Last Post: 10-06-2014, 11:58 PM
  4. Nexus 7 2nd Gen 16gb - Encrypted with Broken LCD + Digitizer with Cyanogenmod - Backup Data?
    By MadDogTen in forum Google Nexus 7 (2013) Rooting, ROMs, & Hacks
    Replies: 0
    Last Post: 10-06-2014, 11:33 PM