1. AC Question's Avatar
    Hi, I'm running sm-a300h. Seems that I've deleted my partition layout, or at least did something to it. I've mad a mistake trying to format my external memory, and deleted things I wasn't supposed to. I've tried flashing pit, as well as the rest of the stock firmware, but no luck. I came across a thread which described a problem similar to mine, but there's no link to the /sys/devices/platform/usb_mass_storage/lun0/file. The directory doesn't exist at all (the usb_mass_storage one). Everything else seems to be working fine. The partition layout seems to be looking fine. Is there anything I can do to enable my external memory? Any help is appreciated.
    11-12-2016 08:36 AM
  2. Golfdriver97's Avatar
    Welcome to the forums. Have you tried having the phone format the card?
    Laura Knotek likes this.
    11-12-2016 10:54 AM
  3. SilenceAbyss's Avatar
    I don't have the possibility to check/format the sd card on my phone, because it won't recognize it at all. It won't recognize any sd card for that matter. After flashing pit, i got the normal partition table back, but I still cant use my external sd card slot for some reason. Not even twrp detects it / wants to format it. I've basically done the clean install and yet nothing helped. I'm not really familiar with how android maps the external storage, so I can't really pinpoint to the problem in hand.
    11-12-2016 12:35 PM
  4. SilenceAbyss's Avatar
    This is quite similar to the problem I have.
    11-12-2016 01:21 PM
  5. Golfdriver97's Avatar
    Have you tried reformatting the card on a PC?
    11-13-2016 10:10 AM
  6. SilenceAbyss's Avatar
    Yes, and on another phone. Works fine. Seems that I need mnt and system from someone who has a working phone.
    11-13-2016 12:08 PM
  7. Rukbat's Avatar
    /mnt is a folder. Just use a file manager to create a new folder at /, name it mnt, and you're done. (You can't create /system because a) there are a lot of files in there and b) the ROM has to be rooted to do that, but flashing the ROM should restore it.)
    11-13-2016 03:52 PM
  8. SilenceAbyss's Avatar
    I have the both folders, but it seems that I'm missing a file that's needed to be called by a function that's responsible for managing the external storage, or something. Even after flashing the stock rom the problem is persistent. Afterwards, I've rooted it, and went through the both folders (mnt and system), but I don't really know what to look for. In the sys folder I don't have /sys/devices/platform/usb_mass_storage, although I'm not sure that the folder is used across devices.
    11-14-2016 05:00 AM

Similar Threads

  1. use sd card as portable or internal storage?
    By robinhelenehebert in forum Moto Z
    Replies: 4
    Last Post: 11-13-2016, 06:59 PM
  2. Replies: 1
    Last Post: 11-13-2016, 03:59 PM
  3. Battery Drain Problem
    By Droid7 in forum Moto Z
    Replies: 2
    Last Post: 11-13-2016, 03:54 PM
  4. Lenovo A319 problem
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 11-12-2016, 05:45 AM
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 11-11-2016, 04:55 PM