1. Android Central Question's Avatar
    I go to the option on my Google app, and it literally turns right back off when I try to turn it on, by itself! It's really annoying.
    05-09-2018 04:37 PM
  2. Jason Dominguez2's Avatar
    I am having exactly the same problem. Any ideas?
    05-11-2018 08:48 AM
  3. djrakowski's Avatar
    Welcome to Android Central!

    Have you given the app permission to access the microphone? Go to Settings->Apps, scroll through the list until you find Google, then tap on it. Open "Permissions," then ensure the "Microphone" toggle is enabled.

    If you need additional help or have more questions or details to share, please join the site so you can reply in this thread. See this link for instructions on how to join Android Central.
    05-11-2018 09:07 AM
  4. kizwiz's Avatar
    Did you guys find a fix for this? I'm havin the exact same problem (and it's seemingly nothing to do with microophone Permission settings).
    05-22-2018 04:01 PM
  5. MasonSavoy's Avatar
    This does nothing. It's not a permission issue. It's been a consistent problem.
    05-31-2018 09:19 PM
  6. TimHarms1's Avatar
    I just experienced this problem but fixed it in a way I don't understand. Farther down that same settings page that has the toggle for "Access with Voice Match", I had to toggle on "Use Screen Context." Worked for me after that.
    Julia Sanders likes this.
    06-21-2018 12:28 PM
  7. Richard Maeby's Avatar
    I had the same problem on my Moto Z2 Force but found the fix. Instead of going to the Ok Google assistant settings go to your home screen and swipe right to show the Google app. Than tap lines on top right corner and selsect settings >> Voice >> Voice Match and than you will the sliders for voice match. As soon as I did this it worked perfectly.
    flashstepped likes this.
    06-24-2018 12:19 PM
  8. dililllili's Avatar
    I just experienced this problem but fixed it in a way I don't understand. Farther down that same settings page that has the toggle for "Access with Voice Match", I had to toggle on "Use Screen Context." Worked for me after that.
    Yep. Took me a month to figure this out, even with your comment... Moderately pissed off.
    I had to:
    1. Toggle 'Use Screen Context' off (since it was on already)
    2. Toggle 'Google Assistant' off
    3. Go back to the previous page
    4. Re-enter the phone's voice settings
    5. Toggle 'Use Screen Context' on again
    6. Toggle 'Google Assistant' on again
    7. Am now able to turn on 'Access with Voice Match'

    Not 100% sure if I did everything in that order, or if they're all vital to making it work, but those are all the things I did to fix it (crucially the going out and back into it thing). Happy Googling, friends.
    anon(10492676) and SenorPopo like this.
    07-03-2018 03:10 AM
  9. flashstepped's Avatar
    I had the same problem on my Moto Z2 Force but found the fix. Instead of going to the Ok Google assistant settings go to your home screen and swipe right to show the Google app. Than tap lines on top right corner and selsect settings >> Voice >> Voice Match and than you will the sliders for voice match. As soon as I did this it worked perfectly.
    This worked for me, thanks!
    07-05-2018 11:10 AM
  10. Julia Sanders's Avatar
    Yep. Took me a month to figure this out, even with your comment... Moderately pissed off.
    I had to:
    1. Toggle 'Use Screen Context' off (since it was on already)
    2. Toggle 'Google Assistant' off
    3. Go back to the previous page
    4. Re-enter the phone's voice settings
    5. Toggle 'Use Screen Context' on again
    6. Toggle 'Google Assistant' on again
    7. Am now able to turn on 'Access with Voice Match'

    Not 100% sure if I did everything in that order, or if they're all vital to making it work, but those are all the things I did to fix it (crucially the going out and back into it thing). Happy Googling, friends.
    Ha! It worked for me too. Thanks so much, was driving me crazy!!!
    07-10-2018 07:10 PM
  11. anon(10492676)'s Avatar
    Thnkyou.. It worked for me
    07-21-2018 12:10 AM
  12. Helpless man's Avatar
    Yep. Took me a month to figure this out, even with your comment... Moderately pissed off.
    I had to:
    1. Toggle 'Use Screen Context' off (since it was on already)
    2. Toggle 'Google Assistant' off
    3. Go back to the previous page
    4. Re-enter the phone's voice settings
    5. Toggle 'Use Screen Context' on again
    6. Toggle 'Google Assistant' on again
    7. Am now able to turn on 'Access with Voice Match'

    Not 100% sure if I did everything in that order, or if they're all vital to making it work, but those are all the things I did to fix it (crucially the going out and back into it thing). Happy Googling, friends.
    Plz tell me the order. It's not working for me. "Access with voice match" and " unlock with voice match" options are in grey.
    Plz help.

    Thanks in advance..!
    Aakash 1 likes this.
    08-05-2018 11:21 PM
  13. Nikki Helms's Avatar
    I'm having the same issue on my OnePlus5t. Help!
    Androman123 likes this.
    08-06-2018 04:50 AM
  14. Androman123's Avatar
    Me too! Same issue with OP5T.. also I'm trying to do the 7 steps solution but I can't see and toggle the 'use screen control'.. only after turning 'Google assistant' on.. help?
    08-06-2018 06:45 AM
  15. Erik SCS's Avatar
    I'm having this issue on my LG V30+. I did the 7 steps too and didn't work. Did you solve your problem?
    08-14-2018 07:37 PM
  16. sgfx's Avatar
    This is a small modification to the actions above that worked for me (Nexus 6p) after the original actions still did not work 3x ...

    I had to:
    1. Toggle 'Use Screen Context' off (since it was on already)
    2. Toggle 'Google Assistant' off
    3. Go back to the previous page

    * Exit program
    * turn phone off
    * turn phone back on
    * Toggle 'Google Assistant' on
    then ...

    5. Toggle 'Use Screen Context' on again
    6. Toggle 'Google Assistant' on again
    7. Am now able to turn on 'Access with Voice Match'
    Thaks dililllili for a starting point..
    (b.t.w. djrakowski: ... Assistant is not in the app list. it is part of the system.. at least on my nexus 6p)


    This worked for a wile but soon I found it turned off again. I think my google home keeps shutting me down because both the phone and the google home attempts to answer my "hey googles". in the past it told me it was sutting it down but it was back on when i was away from my house or i could yurn it on manualy .. but now it just locks me out. If so then im agervated that my $500 phone is being sutdown by my $50 .. (not so smart) Speaker.
    SenorPopo and Glyn Parsons like this.
    08-15-2018 12:38 AM
  17. SenorPopo's Avatar
    Thank you sooo much!! These edited steps worked perfectly on my Pixel 2 XL!
    08-23-2018 05:53 AM
  18. Jsto65's Avatar
    I had the same problem, "access with voice match" would turn off as soon as I would turn it on.

    I was able to get mine fixed.

    I went to phone settings - apps - Google - permissions
    *Everything was already turned on*
    But I toggled the mic permission off and back on
    Went to the Google app - settings - voice - and I was then able to turn on "access with voice match" and retrain to match my voice

    Hope this helps
    Ammw87 likes this.
    09-01-2018 12:03 AM
  19. Sean McNamara4's Avatar
    I’m having the same problem can’t Access voice match I’ve got google Assistant on my android tv box i go into settings on google go to voice match but it’s greyed out is there a fix on this or something to do with google update which is 8.19.10.21.arm64 or is it something to with Google Assistant
    09-06-2018 05:12 AM
  20. UrbanBurban54's Avatar
    I’m having the same problem can’t Access voice match I’ve got google Assistant on my android tv box i go into settings on google go to voice match but it’s greyed out is there a fix on this or something to do with google update which is 8.19.10.21.arm64 or is it something to with Google Assistant
    After trying all of the other suggested actions, mine still wasn't working. I found that when I toggled "Access with Voice Match" on, I would quickly click "Delete Voice Model." My device (GS8) would tell me to use the feature I would have to retrain the assistant. I clicked okay and retrained and so far it has seemed to stay on.
    09-10-2018 10:12 PM
  21. pizza_pablo's Avatar
    I finally got Google assistant to accept my voice samples and even unlock / wake a dark phone on an LG G6.
    I uninstalled the Google app, under settings > general > Google. It didn't actually uninstall, but deleted updates and disabled the Google app.
    I rebooted and turned it back on and was able to do everything I wanted. It was an older version with slightly different terminology and 3 voice samples as opposed to four, but who cares?
    09-10-2018 10:30 PM
  22. Ammw87's Avatar
    I had the same problem, "access with voice match" would turn off as soon as I would turn it on.

    I was able to get mine fixed.

    I went to phone settings - apps - Google - permissions
    *Everything was already turned on*
    But I toggled the mic permission off and back on
    Went to the Google app - settings - voice - and I was then able to turn on "access with voice match" and retrain to match my voice

    Hope this helps
    This worked PERFECTLY on my Samsung Note 9. None of the other suggestions did a thing, so I'm super glad my 48 hour frustration has ended. Thanks a bunch!!!
    09-11-2018 11:05 AM
  23. Dennis Drabinski's Avatar
    Weirdly my exact same problem was fixed with a restart of the phone.
    09-18-2018 04:40 AM
  24. John Pippin's Avatar
    I just experienced this problem but fixed it in a way I don't understand. Farther down that same settings page that has the toggle for "Access with Voice Match", I had to toggle on "Use Screen Context." Worked for me after that.
    Makes absolutely no sense to me, but it worked. Randomly started having this issue earlier today. I read the above, and think no shot in hell, but I'm tired and just wanted something to fix it.

    I turn the 'use screen context' off and once again try to turn on 'ok google' and it stayed on that time. Turned 'use screen context' back on, and all is back the way it was yesterday. Odd.
    09-19-2018 12:00 AM
  25. Priyaabhashini Devarajan's Avatar
    I finally got Google assistant to accept my voice samples and even unlock / wake a dark phone on an LG G6.
    I uninstalled the Google app, under settings > general > Google. It didn't actually uninstall, but deleted updates and disabled the Google app.
    I rebooted and turned it back on and was able to do everything I wanted. It was an older version with slightly different terminology and 3 voice sales as opposed to four, but who cares?
    Thank you it worked for me
    09-20-2018 03:11 AM
66 123

Similar Threads

  1. PayPal is Now Available on Samsung Pay
    By gernerttl in forum Samsung Galaxy Note 8
    Replies: 17
    Last Post: 05-11-2018, 02:49 AM
  2. why doesn't storage ever finish caluting
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 05-09-2018, 04:41 PM
  3. Why does my Samsung Galaxy S3 tab keep turning off and on?
    By jwyenberg in forum Ask a Question
    Replies: 1
    Last Post: 05-09-2018, 04:37 PM
  4. Why can't i download the stickers on my GOsms
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 05-09-2018, 04:31 PM
  5. However can I answer a phone call on my gear fit2 pro
    By Android Central Question in forum Samsung Gear Fit 2 Pro
    Replies: 0
    Last Post: 05-09-2018, 04:13 PM
LINK TO POST COPIED TO CLIPBOARD