1. windowlick3r's Avatar
    Hi, my galaxy started getting really (too) warm while using 3G (although it shows only H, rarely 3G). It's a bit odd because I've had it for years and but it was never getting this warm.
    In about 5 mins it gets uncomfortably warm, I'd even call it hot. As soon as I turn my data off, it slowly starts cooling down.

    Is there a fix for this? Again, I've never had a problem with this before.
    08-08-2015 02:04 AM
  2. Javier P's Avatar
    Hi, welcome to the forums! There could be a problem with your battery or your SIM card / slot. Have you noticed any other problem such as battery drain? You could try using a different battery and see if the problem persists.
    08-08-2015 09:11 AM
  3. windowlick3r's Avatar
    Thank you!
    Why the SIM card?
    Yes, the weirdly fast battery drain is also there, but again, only when using mobile internet. Could putting it on charger with battery pulled out act as a different battery, just to test this?
    08-08-2015 09:31 AM
  4. Javier P's Avatar
    Using mobile data is going to demand more resources from your phone than being connected to WiFi. That's normal and you can expect a higher battery use when on mobile, or even the phone getting warmer than normal. But it seems that your phone is getting unusually hot and very quickly. Do you have a weak network signal?

    You said that you have your phone for several years so it's possible that the battery is not holding as it used to and then getting warmer. Remove it and check for any deformation. Place it on a flat surface (both sides) and try to spin it. If it spins freely that means there's a bulge and you need to replace it as soon as possible.

    Another possibility is that there's is a problem with your SIM tray connections or with the card. Things get old You could try removing it and place it back in again.

    I'm not sure about that test charging without the battery.
    08-08-2015 09:57 AM
  5. windowlick3r's Avatar
    I live in a center of a capital city, so as far as I understand the signal shouldn't be bad. But I noticed it's always the H icon, never 3G, and I used to see 3G icon a lot more before.

    The battery looks good and flat.
    I tried removing the SIM card, I hope you didn't mean changing the tray
    I remember doing this on one of my phones, but probably wasn't this one since it won't turn on without a battery.

    Also, I remember Chrome destroying my battery a few months ago - I tried both with Firefox and just turning mobile data on and not even using the phone, same thing happens.
    08-08-2015 03:08 PM

Similar Threads

  1. Will a Verizon G2 work on AT&T?
    By muckrakerX in forum AT&T LG G2
    Replies: 7
    Last Post: 08-25-2015, 12:31 AM
  2. Replies: 2
    Last Post: 08-09-2015, 06:28 PM
  3. My phone can't open an mp3 file
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-08-2015, 01:48 AM
  4. Replies: 0
    Last Post: 08-08-2015, 01:07 AM
  5. why my phone's camera show yellow screen
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-08-2015, 12:35 AM
LINK TO POST COPIED TO CLIPBOARD