1. Waterdroid's Avatar
    Hi all,

    My N4 is acting strange when connected to my PC (Win7) via a micro-usb cable.
    Whenever it is plugged in in both my USB 3.0 or 2.0 port and the micro-usb port on the N4, my N4 will keep connecting and disconnecting for as long as it's plugged in. It goes very fast, almost as if someone is repeatedly turning a flashlight on and off. My screen will keep waking up and my PC, strangely enough, does nothing since I haven't been able to find my N4 at 'My computer' for the last week (tried about everything with drivers). I've tried about 3 micro-usb cables and they all do the same.

    I think either the usb flex in my N4 is damaged or something else is going on in my device, it could be water damage since I have been in a few rainy days where I'm sure my device has gotten pretty wet. Question is, what can I do to fix it? I don't know anything about 'RMA' and such, I live in the Netherlands and got my phone in Germany.

    Thanks for your help guys.
    02-28-2014 09:07 AM
  2. ToastQ's Avatar
    I'm having the exact same problem! Although with me it was working fine until I tried installing drivers, and then it all went to hell. It's immensely frustrating though, because I really don't know what to do.
    02-28-2014 07:32 PM
  3. Waterdroid's Avatar
    Okay, so it wasn't the hardware. It was indeed the drivers.

    For some reason I fixed this, without a clue what actually did it. I installed the Google USB Driver via SDK Manager (installed with the help of this guide) and got my phone to be usable with my PC (no disconnecting and connecting anymore) and use it with no USB-debugging enabled as an MTP-device.
    However, I still couldn't get my ADB working, turns out that if I enable USB-debugging, then uncheck MTP and replug my device in the usb-port, it'll get recognized as ADB device.

    Sorry for the unclear explanation, it's the best I can do.
    Good luck ToastQ!
    03-01-2014 02:01 PM
  4. Anmol Verma's Avatar
    I am having a issue that the phone is charging and there is no more adb fastboot or mtp happened 3 4 days ago please help me!!
    03-02-2014 03:50 AM
  5. rcav8's Avatar
    It is a USB Power setting
    1. Go to Power Options on your computer
    2. Click 'Change plan setting' on your chosen plan.
    3. Click 'Change advanced power setting' on your chosen plan.
    4. Expand 'USB Settings' .
    5. Expand 'USB selective suspend setting' and change it to disabled.for On battery and Plugged In
    02-01-2016 07:24 PM

Similar Threads

  1. Galaxy S4 (4.3): All contacts are saved to device. Can I change them to Google instead?
    By Andrew Quann in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 27
    Last Post: 02-11-2017, 04:12 PM
  2. Replies: 5
    Last Post: 07-23-2014, 02:03 PM
  3. Is there a way to disable back to top function when returning to previous menus?
    By Droidboner in forum Android 4.0 Ice Cream Sandwich
    Replies: 0
    Last Post: 02-28-2014, 07:48 AM
  4. Lync 2013 Android App causing People (Contacts) app to crash
    By handyd in forum Motorola Droid MAXX
    Replies: 0
    Last Post: 02-28-2014, 07:48 AM
  5. Viewing HDR photos on Mac and PC
    By trido#AC in forum AT&T Samsung Galaxy Note 3
    Replies: 0
    Last Post: 02-28-2014, 07:27 AM