1. Johnnyram's Avatar
    Good day to you, esteemed forum members.

    I have registered today in order to find out if I can get a glitch fixed.

    I also foresee this forum being really useful for hints and tips. So, onward with my little problem:

    I'm in the UK and got a Nexus 7 32GB on the release day in early November. I've left it absolutely stock and installed a few games and apps.

    I have been presented with the update to JB 4.1.2. I'm currently on JB 4.1.1. Each time I have accepted the update, the Nexus shuts itself down (I assume this is normal) and reboots and I get the Droid with the exclamation mark.

    When it has rebooted, it's still on 4.1.1. This has happened 3 times now. I have examined the message and there's no doubt about what it wants to do.

    Anyone any ideas why it won't update? Perhaps there's a faulty app or game known to prevent it?

    I would have thought it was fairly foolproof and automatic.

    Thanks in advance
    12-10-2012 06:43 AM
  2. Johnnyram's Avatar
    Plenty of "views" but no answers. I have found another thread on the subject but nothing conclusive for a stock N7.

    I don't fancy "flashing the factory image" either thanks.

    I'll wait. In the meantime another question:

    What will I lose if I "clear data" from the Google Services Framework? Will I lose Apps, music, word files, saved games, todays newpapers, books, or what?

    12-11-2012 02:56 AM
  3. gigabitex2's Avatar
    It should take the update as long as your system is stock..no customization. It should also show what has failed. Ex..Google maps etc. Clearing Google services won't delete apps or anything important but I think you have to sign back in to gmail and any other linked accounts. I would try to clear cache and make sure you haven't deleted ANY system apps/data such as Google pinyin ime or Google Korean ime. Good luck!

    Sent from my Nexus 7 using Android Central Forums
    12-11-2012 11:35 AM
  4. snorky3706's Avatar
    I have the same issue. I tried to side load with adb commands. Everything went fine until it started to install the update. It fail the same as the OTA update. Here is the error message. Assert failed: apply_patch_check (emmc:/Dev/block/platform/sdhci-tegra.3/by_name/lynx 500736... and more numbers. The build is jro03s.
    I also tried reset to factory but the update still failed
    12-11-2012 03:59 PM
  5. Michael Zedeler's Avatar

    Did you find out what the problem was?


    12-12-2012 05:24 PM
  6. jmac335's Avatar
    Hello All
    I too have recently purchased a Nexus 7 32GB and was receiving the same upgrade errors you mentioned. My build was also JRO03S.
    I have been able to upgrade by flashing a factory image. Check out XDA page "forum.xda-developers.com/showthread.php?t=1907796"
    Follow the steps, (I grabbed the latest 4.2 from google) with the following caveat under step 4 of flashing the ROM

    > fastboot erase boot
    > fastboot erase cache
    > fastboot erase recovery
    > fastboot erase system
    > fastboot erase userdata
    > fastboot flash bootloader bootloader-grouper-4.13.img
    > fastboot reboot-bootloader
    > fastboot -w update image-nakasi-jop40d.zip

    The first time I tried it I did not add the command line in to reboot the bootloader and it failed, stating I was still on 3.39.

    What bugged me the most is that the build JRO03S is not listed under the Nexus 7 at all at googles site for the factory images "developers.google.com/android/nexus/images#nakasi"

    Good Luck and many thanks to "comminus" over at XDA for the guide!
    12-12-2012 07:18 PM
  7. Johnnyram's Avatar
    @Michael Zedeler

    No, I have not worked out what it is yet, but I will have a look at jmac335s suggestions, but I haven't a clue where to start with all the ">fastboot etc" instructions but he has provided some links (many thanks jmac335) which look concise and may even be ***** proof.

    I will investigate when I get a little spare time (and can apply some concentration to the task), probably week commencing 22nd December.

    I will let you know how I get on.

    Thanks for all your assistance so far.
    John R
    12-17-2012 03:08 AM
  8. Johnnyram's Avatar
    Hi Jmac - I have just found your PM - thanks - I'm having a look there now. Cheers JR
    12-18-2012 04:01 PM
  9. Johnnyram's Avatar
    I have just done a Factory Data Reset from the Backup and Reset menu. The update came through but still exactly the same result - I'm still on 4.1.1 so will have a go at jmac335s suggestion. I'll be back. Cheers
    12-20-2012 01:59 PM
  10. Johnnyram's Avatar
    Still no luck. I'm not technical enough to go through jmacs suggestion so I will attempt to get a swap at PC World.

    Surely it can't be the hardware so not much point sending it back to ASUS.

    Any further suggestions please let me know Cheers JR
    01-26-2013 05:40 AM
  11. gigabitex2's Avatar
    Sorry to hear that you're still having issues. You may want to head over to xda and look at "Wugs Toolkit" from that kit you will be able to root/unroot lock/unlock flash stock images, make backups and much much more. The biggest problem people seem to have with it is installing the proper drivers. It may take a little reading to figure it out..but I'm pretty sure it will help!

    Sent from my Nexus 7 using Android Central Forums
    01-26-2013 11:06 AM
  12. Allan Shipley's Avatar
    My galaxy nexus has carrier settings hard coded blocking update . Carrier said would have to send to supplier to revise .
    02-10-2013 09:35 PM

Similar Threads

  1. Rooted 2.2 won't update to 2.3.340 & an embarrasing ?
    By insuranceguy in forum Motorola X Rooting, ROMs, and Hacks
    Replies: 15
    Last Post: 02-28-2011, 08:41 AM
  2. Won't update to 2.2.1
    By seasideclub in forum Google / HTC Nexus One
    Replies: 4
    Last Post: 11-15-2010, 10:14 PM
  3. My MAC won't connect to EVO WiFi
    By Jenayalynn in forum HTC EVO 4G
    Replies: 4
    Last Post: 09-03-2010, 12:38 AM
  4. My Evo won't update
    By Memfus_boi in forum HTC EVO 4G
    Replies: 0
    Last Post: 07-09-2010, 09:17 PM
  5. My DROID died. Software update to blame?
    By matrix2004 in forum Motorola Droid
    Replies: 12
    Last Post: 12-18-2009, 12:37 PM