01-09-2014 08:43 AM
47 12
tools
  1. pauldroidr2d2's Avatar
    I haven't noticed any problems with the wifi on my phone.
    08-24-2010 01:22 PM
  2. vincey2kr1's Avatar
    Just replaced my droid , I was able to replicate the problem at the verizon store with there router before they would exchange it. Got home and the same problem with wifi dropping signal and reconnecting...
    08-28-2010 10:36 PM
  3. DeepThought#AC's Avatar
    switch your router to "g". I read that elsewhere...it worked for me
    08-29-2010 08:49 AM
  4. Jonegross's Avatar
    I have the wifi issue and cell signal issue too. It is very inconsistent. Most the time the wifis work just fine, but occasionally it will go into spastic mode. I change some things on the network, think I fixed it. But in reality the problem is still there, its just that its not there all the time. I'm thinking its more of a hardware/memory issue. Its pretty much the same with cell signal. Works fine most the time but then goes into spazz mode where it drops signal, tells me I'm not connect, cant get web pages....all in an area were signal is perfect with other phones. I figure this is one of those type of problems that will never get fixed, inclinded to get a different phone. But really verizon doesn't offer anything I am intere
    08-29-2010 12:47 PM
  5. pool_shark's Avatar
    I haven't noticed any problems with the wifi on my phone.
    I haven't either. I hook up with the wifi at my house and my girlfriend's house. It stays connected until I turn it off.
    08-29-2010 02:00 PM
  6. Mysticist's Avatar
    Try going to settings -> Location & Security- > uncheck Use Wireless Networks
    This seems to have cleared mine up, and I'm on my 3rd replacement Droid 2. I ended up checking for the return of the on/off bug with each app install & change I made. When I turned on Use Wireless Networks for Beautiful Widgets the wifi issues returned. I hope this helps,
    vincey2kr1 likes this.
    09-28-2010 09:18 AM
  7. vincey2kr1's Avatar
    I think this actually might be working now Thanks Mysticist!
    10-01-2010 10:51 PM
  8. elvyrorie's Avatar
    I had this problem and I got really angry at first. Try disabling the WMM on your router. That fixed the problem with mine. I have Netgear router.
    10-02-2010 11:29 PM
  9. stephenandrew's Avatar
    I have also come to know from my friends that droid 2 has some issue with wifi.But i personally never face any sort of issue
    10-06-2010 10:20 AM
  10. Bushido Brown's Avatar
    Let me clarify, that I have yet to experience my WiFi just dropping. My problem was that it would seemingly struggle a bit reconnecting to WiFi aster idling for a bit.

    That issue has been rare.
    10-06-2010 10:48 AM
  11. faithie's Avatar
    Ok. I think I fixed the problem for mine and I hope this helps others.

    Hardware: Moto Droid 2 with Netgear router
    Problem: On-Off, On-Off issue and dropping connections after a few minutes

    Solution:

    On the netgear router:
    1. Disable WMM
    2. Use WPA2-PSK [AES] ONLY
    3. Mode Up to 145 mbs NOT 300 mbs
    4. Channel- This is the major problem for me. All of my neighbors (10 of them) are using channels 3,4,5,6,7. Get wifi analyzer free from droid market and do a scan. Pick a channel that is NOT being used by your neighbors. Usually channel 11 is the most free.
    5. Wireless Card Access- can be on but add your phone Mac address in there.
    6. In the router status- find out what the LAN ip address. For Example : 192.168.0.1 or 192.168.1.1 and write down the DNS servers. usually there are 2 of them.


    On your phone:
    1. In the advance settings, set wifi sleep policy to never.
    2. unchecked auto IP
    3. check static IP
    4. Under IP address, put the Lan IP address and the last digit, pick an IP that is not in use. like.. 192.168.0.85
    5. Gateway is your Lan IP (192.168.0.1)
    6. Netmask: 255.255.255.0
    7. DNS 1: Whatever it is on your router.
    8. DNS 2: Whatever it is on your router.
    9. If you are using tasker or any other auto profiles to turn on your wifi when you are at home based on your GPS location, don't do that. If you are walking in the middle of your house and lost the GPS connection, it will turn off your WIFI.

    My Droid 2 was going crazy: On-off, on-off, disconnects after a few minutes. etc.

    With the settings above- I am connected for 2 days until I manually turn it off either on the widget or under wifi settings. I don't think the wifi widget was the problem.

    I "think" the problem is that the phone is not as good as a normal built-in wifi or usb wifi. It gets confused when there are too many signals. And, the newer routers have multiple bands that go a long distant. I can walk with my phone about 400 feet from my house and still be connected. The auto IP will get you stuck since it's waiting for the DHCP Sever to give your phone an IP from the router. This takes anywhere from 1-50 seconds.

    Hopes this helps. I know the procedure is long but it works for me. Just set it one time.

    Later!
    10-16-2010 01:01 PM
  12. gkips's Avatar
    After reading this whole thread - which I would recommend anyway as it has lots of good insights - I discovered something I had been doing "wrong."

    When connecting a computer to my wifi network, I typically use the ASCii passphrase instead of the hex key, and my Droid 2 was no different.

    It suddenly occurred to me that the on/off/on/off might be the Droid having some sort of password failure. I deleted the old 'remembered' listing for my wifi on the Droid, turned off wifi, turned it back on, and used the hexadecimal WEP key instead.

    Success! My Droid connected immediately. To be fair, I did turn off WMM before doing this, but it did not initially help with the problem.
    10-18-2010 10:55 PM
  13. SRP's Avatar
    Many thanks to those who have posted possible solutions that worked for them. It assisted with being able to piece together a solution that has worked for me. As with most problems of this nature, its likely unique to your environment.

    My environment, Droid 2 at home, D-Link DIR-825 Router h/w B1, now at firmware level 2.03NA (shipped with 2.02NA).

    While I am convinced the Driod 2 has a firmware problem as we have both a Droid 2 and an HTC incredible (the latter works flawlessly in the same space) and I need to address that back at the Verizon store, in the meanwhile I wanted to at least try to get it stable on the network at home. So using various suggestions from this forum, I spent some time going through them. None of the suggestions worked for this combo.

    I was however convinced given the symptoms (on off on off, never on the network for more than a second) and it always seemed the droid was always saying "waiting for address..." or such.

    So I thought about the static addressing a bit, I didn't really want to put the phone in that mode, so I though I would use the mac address and get the router to hand out the same reserved IP. There the fun started. The router was convinced that the mac address was invalid (it starts with F8, most addresses start with 00). So off to the D-Link site, yes they were getting many hits on their forums for invalid addresses, and they did have a firmware upgrade, so I downloaded and installed that. The phone was still not happy with just the upgrade, but when I assigned a reserved address, solved... the phone is now 100% stable on the home network. So while I'll leave the why's to more capable DHCP experts, this experience may help others on their quest to get this working at least at home.

    Hopefully Motorola will over time find and flash the firmware to fix this, or adopt a new chipset or such. I will be working with the Verizon store to pursue this. My thanks to those who posted their solutions, it was beneficial to get me looking in the right places.
    11-01-2010 09:01 AM
  14. iamjoshfrank's Avatar
    We received our Droid 2 and Incredible by FedEx yesterday. Now we are learning to use them.

    Our Droid 2 is having the same Wifi problems reported here - cycling On, Off, On, Off. When it does stay on and tries to connect to our wireless network (correct password is entered and saved), it gets stuck on "Obtaining IP address."

    In a nutshell:
    New Droid 2. No new apps/widgets installed.
    Turning Wifi to On: usually sends it to Off, On, Off, On cycle indefinitely.
    When it does stay on, it gets stuck "Obtaining IP address"
    Apple Airport Express modem
    Edit: password mode is set to WEP on the Airport Express. But when the Droid 2's Wifi finally sticks to "On," and shows the available networks, it says the password mode is WPA/WP2 PSK. Why the discrepancy?

    The Incredible's Wifi turns on, stays one, and quickly connects to our home network with no problem.

    Shouldn't they both behave the same?
    11-06-2010 10:49 PM
  15. tarekahf's Avatar
    I am facing the same proglem:

    - WiFi sudden disconnections,

    - on/off/on/off/off after I turn off then on.

    How to fix ?

    Tarek.
    11-07-2010 02:46 AM
  16. iamjoshfrank's Avatar
    Woke up this morning to see the Droid 2 had the 2.3.20 update ready to be installed. We ran the update, re-started, and...

    The cycling of On/Off/On/Off seems to be corrected on first use.

    However, it still gets stuck at "Obtaining IP address" and then seems to time-out. The Wifi flips to "disconnected" and then comes back on and re-scans for networks.

    I tried forcing it to forget our network and then connecting to it fresh, re-entering the password, but...no luck. Same issues.

    Heading to a coffeeshop this morning for breakfast and we will try connecting to their network.

    Also...still no issues with our Incredible. Strong and steady on the same home wifi network that our Droid 2 can't seem to figure out.
    11-07-2010 07:25 AM
  17. MarkLiebs's Avatar
    I tried all these steps below and at first thought it worked, I was able to connect solidly and with full signal strength.

    However, all was not well for long.

    I was unable to surf the internet at all while connected. I rebooted the phone with the same result. Had the phone forget the network and reconnect, and now I am back to on/off/on/off etc.

    I am using a droid x, but my wife got the droid 2 and is having the same result. I am going to try the steps I quoted below on hers now and see what happens.

    edit: I did another forget/connect and it seems to be fixed, at least for now.

    Ok. I think I fixed the problem for mine and I hope this helps others.

    Hardware: Moto Droid 2 with Netgear router
    Problem: On-Off, On-Off issue and dropping connections after a few minutes

    Solution:

    On the netgear router:
    1. Disable WMM
    2. Use WPA2-PSK [AES] ONLY
    3. Mode Up to 145 mbs NOT 300 mbs
    4. Channel- This is the major problem for me. All of my neighbors (10 of them) are using channels 3,4,5,6,7. Get wifi analyzer free from droid market and do a scan. Pick a channel that is NOT being used by your neighbors. Usually channel 11 is the most free.
    5. Wireless Card Access- can be on but add your phone Mac address in there.
    6. In the router status- find out what the LAN ip address. For Example : 192.168.0.1 or 192.168.1.1 and write down the DNS servers. usually there are 2 of them.


    On your phone:
    1. In the advance settings, set wifi sleep policy to never.
    2. unchecked auto IP
    3. check static IP
    4. Under IP address, put the Lan IP address and the last digit, pick an IP that is not in use. like.. 192.168.0.85
    5. Gateway is your Lan IP (192.168.0.1)
    6. Netmask: 255.255.255.0
    7. DNS 1: Whatever it is on your router.
    8. DNS 2: Whatever it is on your router.
    9. If you are using tasker or any other auto profiles to turn on your wifi when you are at home based on your GPS location, don't do that. If you are walking in the middle of your house and lost the GPS connection, it will turn off your WIFI.

    My Droid 2 was going crazy: On-off, on-off, disconnects after a few minutes. etc.

    With the settings above- I am connected for 2 days until I manually turn it off either on the widget or under wifi settings. I don't think the wifi widget was the problem.

    I "think" the problem is that the phone is not as good as a normal built-in wifi or usb wifi. It gets confused when there are too many signals. And, the newer routers have multiple bands that go a long distant. I can walk with my phone about 400 feet from my house and still be connected. The auto IP will get you stuck since it's waiting for the DHCP Sever to give your phone an IP from the router. This takes anywhere from 1-50 seconds.

    Hopes this helps. I know the procedure is long but it works for me. Just set it one time.

    Later!
    11-12-2010 11:56 AM
  18. kenficara's Avatar
    I installed wifi analyzer as recommended (great app) and found an uncrowded channel. Set my router to use that channel instead of auto, and the problem cleared up. Made no other changes.
    11-19-2010 01:32 PM
  19. Music Ian's Avatar
    VZW phone rep told me to return mine to the store for a new in the box droid 2. Bought it online. He even called my local store to check stock. Good there. Return your phone. We both got bad phones.
    did you buy your d2 from? I bought mine on ebay for half price, so I'm wondering if after activating my service I could do this, as I have the same issue.
    01-13-2011 12:47 AM
  20. azkid's Avatar
    I have a Netgear router WNDR3700-100NAS and a Droid 2. The finals solution for me was to go into my router where I found the routers pin under wps settings. I then went into wireless settings on my droid and told it to forget my current wireless settings. I then used the wps pin instead of my normal passphrase that I use and guess what a rock steady wifi connection. Hope this helps someone.
    01-25-2011 11:21 AM
  21. iwyl's Avatar
    i was having problems w/ our router (d-link dir-655), so work replaced it w/ a netgear n600 (wndr3700v2) .. maybe it wasnt the router after all?!?!

    i tried several times w/ all of the afore mentioned configurations .. lowering security from wpa2 to tkip or wep worked, but are not viable options security-wise on my network. frankly, lowering from either wpa handshake to wep is an inexcusable "fix". the time it takes to set-up a wep handshake isn't worth the lackluster security it provides. work requires a wpa minimum w/ wpa2 personal/enterprise recommended.
    i settled on the wpa2(eas)+wpa(tkip) as the best all-around solution for the network but was experiencing the problem over & over again... such a great router, built in media server, upnp, dual-band, etc..

    my final solution required me to forget all remembered networks & use the wps (button push handshake) to connect, but in order to use the wps function i had to broadcast my ssid .. temporarily.
    i know not everyone will have this option & i wish you all luck w/ it. since initiating this solution, my network is rock-solid & fast as hell.
    02-16-2011 09:52 AM
  22. Robert Barber's Avatar
    Change the DHCP settings on your router to anything other than forever.
    01-09-2014 08:43 AM
47 12
LINK TO POST COPIED TO CLIPBOARD