1. coulterm85's Avatar
    I just bought a new drone and my phone is supposed to connect to it via Wi-Fi. The problem is that every time I connect to it my phone says no internet and disconnects from it. I already went into the advanced settings under Wi-Fi and made sure that the option to avoid bad Wi-Fi connections was turned off. I used my sons cheap Kyocera phone and it connected fine. Thanks in advance.
    KUKULCANWARRIOR likes this.
    03-02-2017 06:19 PM
  2. Tim1954's Avatar
    Did you have to download a plugin for the drone?
    BergerKing likes this.
    03-03-2017 01:18 AM
  3. coulterm85's Avatar
    Just the promark vr app
    03-03-2017 09:35 AM
  4. ChipperQ's Avatar
    I had the same problem with a DROID MAXX 2 running Android version 6.0.1, it's apparently due to captive portal detection being enabled. I got it to work by modifying the phone's IP settings for the connection to the drone's wifi.

    On the phone's list of available wifi networks, tap and hold the one for the drone (mine appears as "P70-VR-1F5500") and then tap "Modify". Then change the IP settings from DHCP to Static (under Advanced) and set the IP address to 192.168.1.1, Gateway to 192.168.0.1, Network prefix length to 24, DNS1 to 8.8.8.8, and DNS2 to 8.8.4.4 Then tap Save.

    Then when you connect to it you'll get a notification/prompt telling you there's no internet and asking you if you want to stay connected -- tap Yes. There's also a box you can tap to let it know it doesn't have to ask you that every time you connect to the P70's network. Hopefully that will work for you too...
    05-10-2017 12:29 PM
  5. Zekir's Avatar
    129.168.0.1-1.0-fra 8.8.8.8.-8.8.4.4
    05-30-2017 04:38 AM
  6. tech-NO's Avatar
    I was having the same problem with my drone that I bought for my technology club, when I stumbled on to this! thank you so much! It saved me probably a 3 hour long phone call with Promark!
    12-22-2017 09:56 AM
  7. fatboytiges's Avatar
    I had the same problem with a DROID MAXX 2 running Android version 6.0.1, it's apparently due to captive portal detection being enabled. I got it to work by modifying the phone's IP settings for the connection to the drone's wifi.

    On the phone's list of available wifi networks, tap and hold the one for the drone (mine appears as "P70-VR-1F5500") and then tap "Modify". Then change the IP settings from DHCP to Static (under Advanced) and set the IP address to 192.168.1.1, Gateway to 192.168.0.1, Network prefix length to 24, DNS1 to 8.8.8.8, and DNS2 to 8.8.4.4 Then tap Save.

    Then when you connect to it you'll get a notification/prompt telling you there's no internet and asking you if you want to stay connected -- tap Yes. There's also a box you can tap to let it know it doesn't have to ask you that every time you connect to the P70's network. Hopefully that will work for you too...
    Thank you so much Chipper, I tried absolutely everything to get my camera to run through my phone & nothing worked.
    But your method worked a treat. Cheers
    03-25-2019 03:49 PM
  8. Uncle Spongehead's Avatar
    I was disappointed when this didn't work for me. I later found out that turning mobile data off worked for me.
    04-27-2019 01:08 PM
  9. Aaron5644189's Avatar
    I was disappointed when this didn't work for me. I later found out that turning mobile data off worked for me.
    I literally signed back into my ancient account to personally thank you. I ran so much different software, different OS's, different devices, I was about to go the very difficult route of using a raspberry pi to try and make a server to connect to it from my computer. I saw your post thought "no way, it can't be just that" turned on Airplane mode and connected to the wifi, and when it booted immediately I almost yeeted myself out my window from pure frustration/relief. Thanks mate.
    09-22-2019 10:34 PM
  10. Rui Gouveia's Avatar
    I just bought a new drone and my phone is supposed to connect to it via Wi-Fi. The problem is that every time I connect to it my phone says no internet and disconnects from it. I already went into the advanced settings under Wi-Fi and made sure that the option to avoid bad Wi-Fi connections was turned off. I used my sons cheap Kyocera phone and it connected fine. Thanks in advance.


    Try HT-UFO app on Google play store
    07-08-2020 06:59 PM

Similar Threads

  1. Replies: 1
    Last Post: 07-15-2020, 03:49 AM
  2. How can I allow system notifications?
    By Android Central Question in forum Ask a Question
    Replies: 5
    Last Post: 07-09-2020, 10:47 PM
  3. What do I do if my phone is stuck on the lock screen?
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 07-08-2020, 11:45 PM
LINK TO POST COPIED TO CLIPBOARD