07-20-2017 11:24 PM
282 ... 45678 ...
tools
  1. dmagikwand's Avatar
    I'm starting to think mine is a hardware defect. If I have my phone in my picket and push it against my leg, it skips every time. And if I have the battery door off and push hard just to the right of the camera it skips too. Maybe a sensor?
    I took apart, pressed and prodded as hard as I could without fear of breaking something over every inch of the back of the device several times and I couldn't tell any difference by anything I did. Sometimes I would get a stutter but I was never able to duplicate anything so I chalk it up to the usual random skipping.
    05-21-2015 09:59 PM
  2. sparksd's Avatar
    Going back to the idea that this problem is related to CPU slowdown: I found this app on the Play Store (RedEye Stay Awake):

    https://play.google.com/store/apps/d...eye.free&hl=en

    I downloaded the free version and have been trying it out. With this enabled and the screen turned off, I've listened to several songs consecutively over Bluetooth without a single skip. I'm not ready to commit to this as a confirmed workaround yet but I wanted to get this out there for others to give a try.
    After more testing, using this app doesn't seem to make a difference. Also had skips running with the timer app mentioned in earlier posts. Went back to using the screen-on workaround and no more skips. Think I'll just stick with that.
    hotzeug likes this.
    05-21-2015 10:06 PM
  3. dmagikwand's Avatar
    I turned the phone on, connected bluetooth, set it in Ultra, turned ultra off, reconnected bluetooth; Running AT&T Lollipop. I use the Google Music player. I do not use any streaming like Pandora, just music I have put on the phone. I am not using any memory card either. just the built in memory on the phone.
    It is not working for me but I went back down to Kitkat 4.4.4 from Lollipop 5.0 awhile back so Kitkat is what I used to try it. Is there anybody else out there that tried this that is running Lollipop? I took me some time and effort to get back down to 4.4.4 and I'd rather hear feedback from others before I re-upgrade to 5.0 to try this. Anyone?
    05-21-2015 10:12 PM
  4. dmagikwand's Avatar
    After more testing, using this app doesn't seem to make a difference. Also had skips running with the timer app mentioned in earlier posts. Went back to using the screen-on workaround and no more skips. Think I'll just stick with that.
    I gave the RedEye app a shot as well. I did it both with just the CPU awake and the fully awake feature and the screen off. Even gave them the 0.99 cents for the full version. I noticed maybe a bit longer between skips, but only gave it about an hour before I gave up.
    I also ran the timer app, the RedEye app and turned on the "assistive light" simultaneously for awhile with the screen off and no real improvement.
    I'm even starting to believe the overall audio quality in addition to the skips is poorer with the screen off. Tinny highs, muddier sounding mids and lows, closer to distortion at higher volumes with screen off. More apparent in well produced rock music that has many layers than in, say, something like a Norah Jones track where there might purposely be more empty space between the vocals and instrumentation. Observations with headphones at higher volumes. This is a listener subjective statement of course...I can't prove it.

    I'll stick with the "screen on" workaround for now as well *sigh*.
    05-22-2015 12:14 AM
  5. kgk1985's Avatar
    I think the bluetooth radio goes into too low of a power state when the screen is off. Mine barely reaches my head unit when I stand right outside my driver's door
    05-22-2015 12:26 AM
  6. lawrence_author's Avatar
    I'm not sure if the problem has already been solved, but yesterday I went out for my daily walk and began having the skipping problem right from the start. In fact, the skipping only happens when I'm out on my walk. I've yet to have it happen at home. This time, it skipped once or twice EACH song. I normally have my Note 4 in a front pouch around my waist. Frustrated, I decided to try something different. I took my phone out and held it as I walked. For the next hour or so, it did it only twice. When it did skip, I noticed it did it when I held it waist high or lower. Perhaps the solution is not to have it too enclosed and not too far away from the earbuds or is this just a wishful thinking? I'll be looking for such a holder to confirm my "theory". Once or twice an hour I can live with.

    Has anyone else tried this (or any other) "experiment"? I'd love to hear other possible solutions. Thanks.

    Lawrence
    05-22-2015 06:22 AM
  7. samwifi's Avatar
    I'm not sure if the problem has already been solved, but yesterday I went out for my daily walk and began having the skipping problem right from the start. In fact, the skipping only happens when I'm out on my walk. I've yet to have it happen at home. This time, it skipped once or twice EACH song. I normally have my Note 4 in a front pouch around my waist. Frustrated, I decided to try something different. I took my phone out and held it as I walked. For the next hour or so, it did it only twice. When it did skip, I noticed it did it when I held it waist high or lower. Perhaps the solution is not to have it too enclosed and not too far away from the earbuds or is this just a wishful thinking? I'll be looking for such a holder to confirm my "theory". Once or twice an hour I can live with.

    Has anyone else tried this (or any other) "experiment"? I'd love to hear other possible solutions. Thanks.

    Lawrence
    I've tried using the note in all different positions/elevations etc.. and still have the problem. I'm convinced it's really not a blue tooth issue. I can connect and talk on a Plantronics headset all day without one skip. Somehow when the phone goes into standby, Google/samsung allow other things to interfere with the smooth playing of music. Or the cpu goes into a state it can't smoothly sustain the playing of music. Very frustrating and personally, this is the last straw for me.

    Posted via the Android Central App
    05-22-2015 07:21 AM
  8. anon(8114070)'s Avatar
    OK, since more than just me have found the screen left on helping, I posted a bug report on Google:

    Issue 95294: Bluetooth streaming audio dropouts when screen is off, Android 4.4.4

    When streaming music over Bluetooth, audio dropouts are occurring when the screen is off. If the screen is left on the audio dropouts do not occur. Multiple users are seeing this behavior with the Samsung Note 4 running 4.4.4 (http://forums.androidcentral.com/sam...ing-audio.html).

    https://code.google.com/p/android/issues/list
    I just read through the entire issue list for this (https://code.google.com/p/android/is...94#makechanges) and found no solution but it did trigger a possible fix for me. Following is what seems to be working for me.
    Possible Solution
    I have the GS5 Lollipop 5.0, Sprint
    Go to Settings > General > About > click on the Build multiple times until the developer option is turned on or you see an option to turn it on. I already had it turned on and I don't recall what I initially did.
    Now go back to Settings > General > Developer Now scroll down several screens (almost at the bottom) and turn on "Use NuPlayer (experimental)" Now exit out of the setting.
    Prior to this change I would get BT dropouts using my headset (LG HB730) for phone calls, listening to music or listening to AudioBook, e.g. anytime I was using BT.
    zeuswsu likes this.
    05-22-2015 03:12 PM
  9. zeuswsu's Avatar

    I just read through the entire issue list for this (https://code.google.com/p/android/is...94#makechanges) and found no solution but it did trigger a possible fix for me. Following is what seems to be working for me.
    Possible Solution
    I have the GS5 Lollipop 5.0, Sprint
    Go to Settings > General > About > click on the Build multiple times until the developer option is turned on or you see an option to turn it on. I already had it turned on and I don't recall what I initially did.
    Now go back to Settings > General > Developer Now scroll down several screens (almost at the bottom) and turn on "Use NuPlayer (experimental) Now exit out of the setting.
    Prior to this change I would get BT dropouts using my headset (LG HB730) for phone calls, listening to music or listening to AudioBook, e.g. anytime I was using BT.
    Worth a try. Thanks for the suggestion.
    05-22-2015 03:59 PM
  10. samwifi's Avatar
    I fixed my bluetooth skipping by going back to kitkat. mostly gone now - happens rarely.. this is clearly a lol-pop problem. What a joke.... and a hassle.
    05-22-2015 05:12 PM
  11. sparksd's Avatar

    I just read through the entire issue list for this (https://code.google.com/p/android/is...94#makechanges) and found no solution but it did trigger a possible fix for me. Following is what seems to be working for me.
    Possible Solution
    I have the GS5 Lollipop 5.0, Sprint
    Go to Settings > General > About > click on the Build multiple times until the developer option is turned on or you see an option to turn it on. I already had it turned on and I don't recall what I initially did.
    Now go back to Settings > General > Developer Now scroll down several screens (almost at the bottom) and turn on "Use NuPlayer (experimental)" Now exit out of the setting.
    Prior to this change I would get BT dropouts using my headset (LG HB730) for phone calls, listening to music or listening to AudioBook, e.g. anytime I was using BT.
    Interesting, I'll try it out.

    There were issues with NuPlayer at least early on. In the original 5.0 rollout, it was on by default but people had problems (I don't recall what and I can't find the threads on it) so it was turned off by default in later Lollipop versions.
    05-22-2015 05:18 PM
  12. sparksd's Avatar
    Interesting, I'll try it out.

    There were issues with NuPlayer at least early on. In the original 5.0 rollout, it was on by default but people had problems (I don't recall what and I can't find the threads on it) so it was turned off by default in later Lollipop versions.
    Follow-up: the NuPlayer problem cropped up on my Nexus 7 tablet and is discussed here:

    The Worst Bugs in Android 5.0 Lollipop and How to Fix Them

    So looks OK for the Note 4 but please post any unusual behavior if you see it.
    05-22-2015 05:57 PM
  13. sparksd's Avatar

    I just read through the entire issue list for this (https://code.google.com/p/android/is...94#makechanges) and found no solution but it did trigger a possible fix for me. Following is what seems to be working for me.
    Possible Solution
    I have the GS5 Lollipop 5.0, Sprint
    Go to Settings > General > About > click on the Build multiple times until the developer option is turned on or you see an option to turn it on. I already had it turned on and I don't recall what I initially did.
    Now go back to Settings > General > Developer Now scroll down several screens (almost at the bottom) and turn on "Use NuPlayer (experimental)" Now exit out of the setting.
    Prior to this change I would get BT dropouts using my headset (LG HB730) for phone calls, listening to music or listening to AudioBook, e.g. anytime I was using BT.
    So tried this and still get dropouts. Went back to screen on and no dropouts.

    You mention having dropouts with audiobooks - is that using the Audible app? I only have this with music, not with the Audible app. And in both cases the audio content is stored on my external card, not internal memory.
    05-22-2015 06:04 PM
  14. dmagikwand's Avatar
    You mention having dropouts with audiobooks - is that using the Audible app? I only have this with music, not with the Audible app. And in both cases the audio content is stored on my external card, not internal memory.
    I've always had the same the dropouts on the Audible app. Same frequency of occurrence as music. Audible app and books are on device storage. Music cuts whether live streaming, card, or device storage.
    05-22-2015 07:21 PM
  15. dmagikwand's Avatar
    I think the bluetooth radio goes into too low of a power state when the screen is off. Mine barely reaches my head unit when I stand right outside my driver's door
    I've been planning to test this as soon as I can. I have a back parking lot at work that is unobstructed by any objects. I plan on leaving my phone at a spot and pacing out the reception distances with both the screen on and the screen off to see if there is a significant change. Will report back.

    Update: Tested outdoors without obstructions. There was practically zero difference in the Bluetooth range--- screen on vs screen off.
    05-22-2015 07:35 PM
  16. anon(8114070)'s Avatar
    So tried this and still get dropouts. Went back to screen on and no dropouts.

    You mention having dropouts with audiobooks - is that using the Audible app? I only have this with music, not with the Audible app. And in both cases the audio content is stored on my external card, not internal memory.
    Sorry I failed to mention, for the audiobooks I'm using Listen Audiobook Player. Currently for music I use the default app. I've used my phone rather heavily today either making long phone calls (10-15 minutes) and listening to audiobooks (about three hours) and during this time I had zero dropouts. My books are stored on my 64GB SD card.

    BTW currently I manage the books on the SD card by connecting the phone to my PC (Win 8.1) and using my file explorer app (Xplorer2) to delete books I've listened to or add more books. Currently the book player cannot delete files on the SD card the developer is working on the issue.
    05-23-2015 12:40 AM
  17. rmausser's Avatar
    I'm not sure if the problem has already been solved, but yesterday I went out for my daily walk and began having the skipping problem right from the start. In fact, the skipping only happens when I'm out on my walk. I've yet to have it happen at home. This time, it skipped once or twice EACH song. I normally have my Note 4 in a front pouch around my waist. Frustrated, I decided to try something different. I took my phone out and held it as I walked. For the next hour or so, it did it only twice. When it did skip, I noticed it did it when I held it waist high or lower. Perhaps the solution is not to have it too enclosed and not too far away from the earbuds or is this just a wishful thinking? I'll be looking for such a holder to confirm my "theory". Once or twice an hour I can live with.

    Has anyone else tried this (or any other) "experiment"? I'd love to hear other possible solutions. Thanks.

    Lawrence
    The fix for this appears to be turning off wifi, AND going into wifi settings > Advanced and turning off "always allow scanning" and "network notification"

    What is happening is that the wifi chip is snooping for wifi connections while you walk, and as you pass by a store, etc etc, it finds a wifi ping.

    It doesnt actually connect, but the wifi/bluetooh radio in Samsung devices is a single all-in-one component.

    This short "ping" is enough to draw some resources away from the bluetooth connection, thus causing a2dp profile (thats the audio connection) to skip.

    It wont happen when you are stationary, as you aren't moving in space and thus, exposing the phone to a new location and new wifi signals it can snoop on.
    05-23-2015 06:55 PM
  18. sparksd's Avatar
    The fix for this appears to be turning off wifi, AND going into wifi settings > Advanced and turning off "always allow scanning" and "network notification"

    What is happening is that the wifi chip is snooping for wifi connections while you walk, and as you pass by a store, etc etc, it finds a wifi ping.

    It doesnt actually connect, but the wifi/bluetooh radio in Samsung devices is a single all-in-one component.

    This short "ping" is enough to draw some resources away from the bluetooth connection, thus causing a2dp profile (thats the audio connection) to skip.

    It wont happen when you are stationary, as you aren't moving in space and thus, exposing the phone to a new location and new wifi signals it can snoop on.
    Tried that - doesn't work for me.
    05-23-2015 07:16 PM
  19. zeuswsu's Avatar
    What's weird is it never skips in my car but always skips when connected to my bose Bluetooth speaker. So annoying, this with other issues are enough to get me to lean towards getting an iPhone when I'm due for an upgrade. I've never considered buying an iPhone before but Google seems to be putting out buggy updates lately.

    With that said the screen on fix using the timer seems to be working so thanks for that.
    05-23-2015 08:56 PM
  20. samwifi's Avatar
    What's weird is it never skips in my car but always skips when connected to my bose Bluetooth speaker. So annoying, this with other issues are enough to get me to lean towards getting an iPhone when I'm due for an upgrade. I've never considered buying an iPhone before but Google seems to be putting out buggy updates lately.

    With that said the screen on fix using the timer seems to be working so thanks for that.
    I could not agree more. I've always thought apple products were just dumb and always loved android only. But recently I was forced to buy an iPad air 2 because of work related needs that are optimized on the ipad. It works so well, I got rid of my note 10.1. My family wants to admit me to the ER because now I can't say enough about how well the iPad operates.. so I'm now considering an iPhone in the future.. I can't believe I just typed that... but smooth streaming bluetooth music is paramount for me along with fast uninhibited UI.

    Posted via the Android Central App
    05-24-2015 07:57 AM
  21. dmagikwand's Avatar
    What's weird is it never skips in my car but always skips when connected to my bose Bluetooth speaker. So annoying, this with other issues are enough to get me to lean towards getting an iPhone when I'm due for an upgrade. I've never considered buying an iPhone before but Google seems to be putting out buggy updates lately.

    With that said the screen on fix using the timer seems to be working so thanks for that.
    You don't have to use the timer. It was just an experiment I did based on the CPU sleeping theory that was either extremely lucky for a couple of days or there was an additional process (or processes) working together with it that I have not been able to replicate.

    All you need is the screen on fix that the others came up with. Keep your screen dim unless you are using it and turn off the timer to save as much battery as you can.
    05-24-2015 08:30 PM
  22. Degineth's Avatar
    Really unfortunate for Verizon users as the fact that there is a work around and that the issue isn't prevalent on all carrier variants points to a kernel issue. If only bootloaders on the other variants weren't locked people could at least install other kernels in an attempt to increase minimum cpu frequency while screen is off to try to combat the issue. Agree with sparksd that more people need to complain about it to elevate the issue.
    05-24-2015 09:42 PM
  23. dmagikwand's Avatar
    I've noticed we've gotten 10 more complaints logged at google in the past 4 days. Up to 75. Possibly because this thread was brought back to life. If you are having this issue please post it here at Google. Maybe nothing changes, but it can't hurt. https://code.google.com/p/android/is...94#makechanges
    It only takes about 5 minutes or so.
    hotzeug and Jade Moon like this.
    05-25-2015 10:54 PM
  24. Jetta392's Avatar
    You don't have to use the timer. It was just an experiment I did based on the CPU sleeping theory that was either extremely lucky for a couple of days or there was an additional process (or processes) working together with it that I have not been able to replicate.

    All you need is the screen on fix that the others came up with. Keep your screen dim unless you are using it and turn off the timer to save as much battery as you can.
    I too have the skipping problem. I believe it started after installing Lollipop. I use an app called keep Screen which allows you to choose what apps to keep the screen from timing out. It also has the option to dim the screen to min (which I have it set) or to leave it at max brightness. I can still read the screen with the dim setting.The drain on the battery is minimal. Once you leave the app you are using, the screens brightness returns to how you have it set. I'm hoping they will fix this annoying problem.
    hotzeug likes this.
    05-26-2015 12:05 AM
  25. dmagikwand's Avatar
    I too have the skipping problem. I believe it started after installing Lollipop. I use an app called keep Screen which allows you to choose what apps to keep the screen from timing out. It also has the option to dim the screen to min (which I have it set) or to leave it at max brightness. I can still read the screen with the dim setting.The drain on the battery is minimal. Once you leave the app you are using, the screens brightness returns to how you have it set. I'm hoping they will fix this annoying problem.
    The screen (at least on the GS5) gets very dim, too dim to read, but I'm I'm sure it is good for my battery and screen. I find myself in normal room light having to guess where the button is to change the brightness back to auto. I've navigated Android screens for 6 years so and the brightness button location has never changed that I remember, so no biggie there. I compared it to my GS3's lowest brightness setting and the difference is remarkable in how much lower my 5 will go.
    05-26-2015 07:20 PM
282 ... 45678 ...

Similar Threads

  1. What's a Good Bluetooth Kit for your Vehicle/Note4?
    By DMarie04 in forum Samsung Galaxy Note 4
    Replies: 10
    Last Post: 03-23-2015, 12:41 PM
  2. Replies: 1
    Last Post: 01-03-2015, 10:08 AM
  3. Why do the images on my Note 4 looked blocky?
    By bedfordharpist in forum Samsung Galaxy Note 4
    Replies: 3
    Last Post: 01-02-2015, 04:04 PM
  4. Replies: 0
    Last Post: 01-02-2015, 10:35 AM
  5. For the Samsung Galaxy Note 4 is there a simple audio reminder app?
    By isabel95 in forum Samsung Galaxy Note 4
    Replies: 0
    Last Post: 01-02-2015, 08:46 AM
LINK TO POST COPIED TO CLIPBOARD