1. OGroteKoning's Avatar
    When I upgraded to 2.3.5 I used XXKI4 because that is what was on my phone. Because it was the Netherlands version, I installed XWKJ3 kernel. All is well. Now that I want to flash 2.3.6, can I pick any 2.3.6 firmware or must it be something to do with XXKI4?

    Sent from my Galaxy S II
    01-25-2012 12:50 PM
  2. Meiji's Avatar
    It doesn't need to be related. Actualy it's recomended that both rom and kernel share the same code (KH4 in both for example), or the closest possible. If you install a 2.3.6 kernel in a 2.3.5 rom, it might not work properly or not work at all. It doesn't need to be a rom or a kernel specifically for your country either (although some might have a bit issue with GPS or 3G if you're from a different continent where the rom was made).

    You can pick any 2.3.6 rom, but I recommend the KL1 Open Europe in case you wanna try the official Samsung rom which is clean and crap free (by crap I mean all those useless apps carriers tend to install). Once installed, you can then try any other custom rom based on the KL1 (I recommend RetuRnROM, Turkbey, Criskelo).

    Although, there's a slight possibility your phone's not fully compatible with 2.3.6. If so, you might experiment one or several of the next syntoms: sudden loss of phone signal and/or 3G (sometimes they get back quickly, others you might need to reboot your phone), random reboots, random notifications of Kernel Panic. Check how your phone works, and if you get any of these and gets annoying, you might need to go back to 2.3.5. The possibility is small but it's happened, it happened to me for example..
    OGroteKoning likes this.
    01-27-2012 10:48 AM
  3. OGroteKoning's Avatar
    Thanks. You are the first person in 5 forums to answer my question properly. I downloaded 2.3.6 KL1 Open Europe earlier. I still unsure if I should flash it though. My current 2.3.5 version actually runs like a rolex. Battery life is good anx the phone runs very smooth. With multi upload down, I don'know if I can get things like JKay's installed again. So I might just resist the temptation to fiddle ... decisions decisions decisions ..........

    Sent from my Galaxy S II
    01-27-2012 01:25 PM
  4. Meiji's Avatar
    Hehe, well, 2.3.5 is not that different from 2.3.6, just small changes, so you can stay with your current version. Only if you flash a KL1 based custom rom after installing it then you'll notice great improvements. Plus, the first stables custom ICS roms are right after the corner (RetuRnROM might release its final beta this weekend and they say it'll be as stable as a final release). So, it might be worth the wait for ICS instead of flashing the KL1.
    OGroteKoning likes this.
    01-27-2012 05:32 PM
  5. skulldroid67's Avatar
    My current 2.3.5 version actually runs like a rolex. Battery life is good anx the phone runs very smooth.
    Well if it ain't broke..don't fix it I agree with Meiji, may be best to wait for ICS
    01-29-2012 11:02 PM
  6. boggsterman's Avatar
    No need to wait for ICS, you can run an "alpha" of ICS based CM9 now, there are some bugs that still need working out but i've been using it for weeks and it does everything i need. you can find it here:

    [ROM][IML74K][4.0.3] CyanogenMod 9 experimental Build [DEVELOPMENT ONLY!] - xda-developers

    Trust me you wont want to go back to GB once you've tried it out.
    skulldroid67 likes this.
    01-30-2012 01:21 AM
  7. skulldroid67's Avatar
    That's good to know since I'm finally going to root my device today. Think I'll check this build out. Thanks
    01-30-2012 06:13 AM
  8. Meiji's Avatar
    Go ahead! =) Current ICS roms still have some issues that need to be fixed as boggsterman pointed out, but there're plenty of alphas and betas out there. You can try some if you want and check how they work. Some of them still lack features like camera, usb, sd card, and some apps like skype, whatsapp, etc, still don't work properly. I use many of those features daily so I decided to wait for a more stable version, but it's your choice.
    01-30-2012 10:55 AM
  9. searchercam2001's Avatar
    2 weeks ago

    i bought the samsung galaxy tab P1010 (wifi only). i then realise there has never been a firmware update available in my country since release.
    it came with froyo 2.2.1

    my front camera didnt work in most apps because they wanted gingerbread

    i installed the firmware update released in the uk gingerbread 2.3.6 worked perfect i then phoned samsung and asked when there will be a update released no1 could tell me. so i told him i updated with firmware from the uk. he then tells me i lose my warrenty..i told him its ok if it breaks and is gonna cost thousands to fix ill send it back to them in a million pieces rapped in a black bag so they can throw it in the trash with all there other crap

    im in south africa and its not as this tab was cheap so why they cant give us updates i have no idea
    03-26-2012 05:47 PM
LINK TO POST COPIED TO CLIPBOARD