06-20-2019 06:56 AM
45 12
tools
  1. kaasweckal's Avatar
    When you plug in the phone to charge (or start wirelessly), the screen comes on. Is there any way to disable this?

    Its a bit annoying to always need to turn the screen off after putting it down to charge.
    Hi,
    I had the same issue. I have a dynamo on my touring bike which charges my phone at odd times. To optimize energy comsumption, I want to prevent the screen to turn on each time charging start.
    I solved it with a Tasker script. Just google Tasker for android.
    I made up a profile, that comes active when charging starts. The profile then triggers a taskk, which simply puts the phone back to locked state. It works perfectly. I linked the same task as a exit task too, so that screen also stays off, when charging stops.
    Cheers
    beermattuk likes this.
    06-02-2018 04:06 AM
  2. fuqHALO's Avatar
    When you plug in the phone to charge (or start wirelessly), the screen comes on. Is there any way to disable this?

    Its a bit annoying to always need to turn the screen off after putting it down to charge.
    Wow, lots of unhelpful and rude people here.
    I know EXACTLY what you're talking about!

    The full screen notification that pops up every time you set it on the wireless charger? It always screws up whatever app was open or will freeze the screen. It doesn't go away right away either. Super annoying. Well..i found a fix on a much more helpful forum... reddit!

    Here's what I did and it worked!
    "If you go to apps and choose "show system" from the three dot menu, you will find inductive charging. Just disable that app and the notifications will stop. it keeps wirelessly charging too!"
    07-24-2018 08:52 AM
  3. kneeL_official's Avatar
    This is so infuriating that there is no setting for this. What were they thinking? SO annnoying!
    07-24-2018 01:42 PM
  4. kneeL_official's Avatar
    Wow, lots of unhelpful and rude people here.
    I know EXACTLY what you're talking about!

    The full screen notification that pops up every time you set it on the wireless charger? It always screws up whatever app was open or will freeze the screen. It doesn't go away right away either. Super annoying. Well..i found a fix on a much more helpful forum... reddit!

    Here's what I did and it worked!
    "If you go to apps and choose "show system" from the three dot menu, you will find inductive charging. Just disable that app and the notifications will stop. it keeps wirelessly charging too!"
    The above-mentioned setting doesn't exist in Samsung Galaxy S8+ and cannot find anything similar
    07-24-2018 01:59 PM
  5. beermattuk's Avatar
    Yeah all the replies saying "why does it bother you" etc aren't helping. Thing is phones should have PREFERENCES to suit each individual depending on how they like to use it. If you're a great fan of your screen pointlessly coming on while charging then that's great for you, but not everyone is. There should be an option to disable it.

    For me I think it's a ridiculous feature, because when I'm plugging my phone in I want to charge it, so why would it automatically do something that drains the battery? kaasweckal has given one example, but there are other times when your charging is intermittent, for example a car ignition turning on and off, solar charges, etc; or just if you're in a rush! Why would it do something that drains the battery, when you're trying to charge it?? Stupid! In my case, the USB C has broken, so the charger falls out very easily, and you keep having to push it back in. If you're in a bit of a rush, the screen flashing on every time you plug it back in doesn't help with giving your battery a quick boost! And there is always the screen coming on in the dark issue. If you're out sailing or camping or something, it can take your night vision 10 minutes to recover from seeing a bright light, yes I know you can look away etc but you don't always think, especially after a long day.

    It's just a pointless feature we'd be better off without. And if some people like it then fair enough but google/android please put something in the preferences to disable it.

    In the meantime, kaasweckal's tasker idea is probably the closest thing we have. I use a program called "automate", i can probably write a flow in there. That'll help with the battery drain problem, but not with the blinding light in the dark issue.
    07-30-2018 08:46 AM
  6. Sir Trampsuli's Avatar
    When you plug in the phone to charge (or start wirelessly), the screen comes on. Is there any way to disable this?

    Its a bit annoying to always need to turn the screen off after putting it down to charge.
    I cant charge battery because screen turn on and when its on it doesnt allow to charge phone
    08-26-2018 01:44 AM
  7. XGC75's Avatar
    Another person deeply annoyed by this. I like to press the power button on my way to placing the phone on a wireless charger. It is my intent for the screen to be off. Obviously. I pressed the power button. Yet when the phone goes back on the charger, the screen turns on. It's annoying enough that the screen stays on for 10 minutes (my timeout), but when I'm playing full-screen captive games, the screen turns on indefinitely and won't even charge!
    09-10-2018 07:09 AM
  8. TFBisquit's Avatar
    Hmm I can understand the annoyances about this. But look at it like this, when you choose 10 minutes screen time-out there is some downside to it also, this particular complaint for example.
    In settings/advanced functions the top one is smart stay, while it isn't flawless it usually keeps my screen on when I'm looking at it.
    You might give it a try and see if your regular timeout can be reduced.
    I have 30 secs for example.
    09-10-2018 11:45 AM
  9. filanto's Avatar
    My issue with the screen coming on is when it is fully charged and the screen turns on when I'm driving early in the morning and the phone is in the charger in front of me. It blinds me because of its brightness. I don't need it to turn on because I can easily see the led change

    I have my screen timing off after 10min, so if i dont turn it off manually, it will stay on for that long.

    Its annoying in several situations, such as when dark in bed, and place it on the wireless charging pad on the bedside table, I then have to manually turn it off, otherwise the ceiling is lit up for 10min. Likewise, in the car it stays on , therefore taking longer to charge than it should.
    11-13-2018 10:09 PM
  10. RogerThat99's Avatar
    Agreed. Mine comes on when I plug it in. I hit the power button to turn it off. I don't like that, but I can live with it. What I hate is that the screen comes back on when fully charged. It lights up the whole room.

    I have had an S3, S6, and S7, and none of them did this. Just the S8.
    11-14-2018 09:54 PM
  11. RogerThat99's Avatar
    Does it have to do with the "Always On" app?
    11-14-2018 10:06 PM
  12. tkmilbaugh's Avatar
    Hi,
    I had the same issue. I have a dynamo on my touring bike which charges my phone at odd times. To optimize energy comsumption, I want to prevent the screen to turn on each time charging start.
    I solved it with a Tasker script. Just google Tasker for android.
    I made up a profile, that comes active when charging starts. The profile then triggers a taskk, which simply puts the phone back to locked state. It works perfectly. I linked the same task as a exit task too, so that screen also stays off, when charging stops.
    Cheers
    Could you share more details about your Tasker script? I have Tasker, but have not found it very intuitive to create a script such as you have described.
    12-10-2018 10:07 AM
  13. larrykay's Avatar
    I haven't found a way to keep it off, but I did find this:
    Tasker for Android - Profiles: Screen Time-out Settings While Charging
    I use it to shut the screen off immediately when placed on charge.
    12-10-2018 10:31 AM
  14. Adcolor's Avatar
    Here is what I did to minimize the glaring screen, as well, the CHARGED display, and the CHARGING cycle.

    A couple of these came from this thread, thanks to the contributors.

    Reference info: note8, android 8.0.

    Turn off phone charged notification: system settings>notifications>advanced (will show as advanced notification settings once selected)>(3 dot menu) show system apps> systemui>battery full>importance low (no sound or lights).

    Set blue light filter to on. You can set the time window if you like.

    Set the time window for AOD for your sleep window so it stays off.

    Set your AOD background/wall paper to black. This will still flicker on when charging begins.

    Set the screen lock when inactive timer to 30 seconds. Though I didn't try another setting, I was also optimizing battery life, I found that the "charging" annunciator (AOD pop up screen) only stayed on about 3 seconds. I suspect that is about 10% of the inactive timer setting.

    One other thing, I'm still getting this set up, go through your reminders and change the settings. My calendar reminder is set to something like 10 hours. The 'bling' went off as my wife was nodding off. I was "reminded" to work on that.

    Ok, not concerned with the why, just with the best solution for what we have to work with. Maybe android 9 will fix this.
    01-17-2019 09:32 AM
  15. Daniel Carmichael's Avatar
    Good day everyone. Solution is simply to install Macrodroid app on your phone and set a macro that will keep the screen off when charging at night.

    Works great with my S7 Edge
    02-25-2019 01:07 PM
  16. James Monica's Avatar
    I know this is an old post. I was searching for the answer to the same questions as the OP. Obviously I came to the wrong place. the majority of the replies are comments about how the person can't understand why this would be annoying to the OP, or why doesn't he just do this or that. Its none of your business why he has his phone settings the way he does or why it annoys him that the screen turns on when he starts to charge. It really annoys me too and not that I feel I owe an explanation as to why its an annoyance but I will humor you. I use a cheap Qi charger and the phone has to be placed exactly in a certain spot for it charge. If I have to touch the phone to press the power button once it starts charging, it usually gets moved off that sweet spot and so I will have to adjust it, it then starts charging again and then I have to hit the power button again and start the cycle over again. It defeats the main purpose of a Qi charger. And yes so it's F'ing annoying.
    04-10-2019 01:24 PM
  17. vfdev's Avatar
    +1 same problem with Qi charger and +1 to stop discussing "why". Would be great having a real advice. Thanks in advance

    I know this is an old post. I was searching for the answer to the same questions as the OP. Obviously I came to the wrong place. the majority of the replies are comments about how the person can't understand why this would be annoying to the OP, or why doesn't he just do this or that. Its none of your business why he has his phone settings the way he does or why it annoys him that the screen turns on when he starts to charge. It really annoys me too and not that I feel I owe an explanation as to why its an annoyance but I will humor you. I use a cheap Qi charger and the phone has to be placed exactly in a certain spot for it charge. If I have to touch the phone to press the power button once it starts charging, it usually gets moved off that sweet spot and so I will have to adjust it, it then starts charging again and then I have to hit the power button again and start the cycle over again. It defeats the main purpose of a Qi charger. And yes so it's F'ing annoying.
    04-24-2019 01:39 AM
  18. methodman89's Avatar
    When you plug in the phone to charge (or start wirelessly), the screen comes on. Is there any way to disable this?

    Its a bit annoying to always need to turn the screen off after putting it down to charge.
    Open Settings, select Sounds and Vibrations, toggle off Charging Sounds. Good luck
    04-24-2019 02:50 AM
  19. GreenRaccoon23's Avatar
    The only way to do this is through root privileges. Tasker is the solution I used for years before I needed to stop rooting my devices.

    As others have stated, shortening screen timeout is an unacceptable solution to this problem. It does not solve the problem; it just attenuates one of the effects of the problem. It also results in the phone requiring more user interaction--turning the screen back on more frequently--throughout the rest of the day, and the whole problem is that the phone is requiring extra user interaction of needing to turn off the display after it begins to charge. Shortening screen timeout not only does not solve the underlying problem, it also creates a similar problem which occurs even more frequently than the original one.

    I remember trying to figure this out 10 years ago for Android 2.2 Froyo on my OG Droid, and many other people were asking the same thing. If people have been asking Google for this feature for 10 years, and Google hasn't implemented it yet, I doubt they will any time soon, if ever.
    06-20-2019 12:48 AM
  20. kaasweckal's Avatar
    Could you share more details about your Tasker script? I have Tasker, but have not found it very intuitive to create a script such as you have described.
    Sorry for late reply ^^
    Pretty simple:

    New Tasker Profile, which becomes active if: "State: Power Any"
    Task: "System Lock" (may only work if root)
    Set the same task as Exit task too. Voilla.
    06-20-2019 06:56 AM
45 12

Similar Threads

  1. Screen protector - yes or no
    By pseudoware in forum Samsung Galaxy S8 & S8+
    Replies: 25
    Last Post: 06-16-2017, 03:10 PM
  2. Big Screen
    By Brandi King3 in forum Ask a Question
    Replies: 1
    Last Post: 06-14-2017, 10:52 PM
  3. Replies: 0
    Last Post: 06-14-2017, 10:25 PM
  4. Replies: 0
    Last Post: 06-14-2017, 09:55 PM
  5. I am unable to unlock my note 4....
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 06-14-2017, 09:20 PM
LINK TO POST COPIED TO CLIPBOARD