1. reederrr's Avatar
    So, I've had my Galaxy S II since yesterday and I was toying around with it all day playing with different apps, getting games, etc. Then around 5:30 p.m., I found that I was no longer connected to the internet. Now, I never connected my phone to my home network, it came out of the box connected to "attwifi" which seemed to be faster than my own internet as we have a lot of computers connected and games going, etc. I'm now unable to connect to attwifi as it says "Not in range" under it but at the top it's showing 3 bars, not sure if that's the wifi but I'm guessing it is.

    Has anyone else had this problem and if so can you help? I did however get an app that I thought may have caused the problem but I don't know how. It was some kind of battery saver that I was told helps a lot and I later decided I didn't like it so I uninstalled and then this happened. I have tried restarting the phone, letting it sit while off for hours, coming back to it and trying again and I've gotten no luck whatsoever. I'd really like to solve this problem today as this is my first smartphone and I'd like it to continue working as it did before.
    12-26-2011 10:13 AM
  2. reederrr's Avatar
    Please, someone help us, we're really needing a solution for this problem :/
    12-26-2011 01:48 PM
  3. Wookiee's Avatar
    "attwifi" is an AT&T-owned wifi hotspot, just as its name implies. They're all over, at places like Starbucks, McDonalds, Barnes & Nobile. AT&T allows subscribers to connect to these hotspots when you are in range of them, for no charge.

    It sounds to me that you were, at one point, near one of these hotspots and have since moved away from it. The 3 bars to which you are referring is likely your cell tower connection, which is different than your wifi connection. You're going to have to get back in range of the hotspot or connect it to your home network. Otherwise, you'll have to use whatever data package that you're signed up for with your cell contract.

    If none of that solves your problem, I would recommend visiting an AT&T store and speaking with them.
    reederrr likes this.
    12-26-2011 02:06 PM
  4. reederrr's Avatar
    well, the thing is it seems like the hotspot moved since I was sitting in this very spot for most of the day using it. Is it possible that this connection is off now? I thought that the phone would have internet access everywhere regardless of where I was, I thought the only think that could change was the signal of the connection.

    Why does my friend have connection everywhere on his Iphone and I don't? I'd like to find a way where I too can have connection to the internet everywhere.
    12-26-2011 02:45 PM
  5. Wookiee's Avatar
    Your friend has access to the internet everywhere through their cellular data connection, which is available almost anywhere that you can make a phone call. The attwifi hotspot that you were connected to is short-range, limited to a few dozen feet (depending on obstacles such as walls that can degrade or block the signal). It is possible that the hotspot you were using was disabled.

    Assuming you signed up for a data package with your phone contract, you don't need to use wifi to access the internet (however, it is usually preferable to use wifi given a choice).

    Try these steps:

    • Pull down the notification bar from the top of the display.
    • Press the "Wi-Fi" button to turn wifi off. The icon will change from green to white, indicating it is off.
    • Close the notification bar by swiping upward from the bottom of the display, or by pressing the back arrow button.
    • Press the Applications icon on the home screen.
    • Find and press the Settings button in the Applications drawer.
    • At the top of the list, select Wireless and network.
    • Scroll all the way down to the bottom and select Mobile networks
    • Make sure Use packet data has a green check mark in the box.

    You should now be able to use the internet anywhere that your phone has a cellular connection. Be advised that you may incur charges if you do not have a data package with your contract.

    If you want to use wifi again, repeat the first two steps.

    If this does not help, call AT&T or visit an AT&T store and have them sort it out for you.
    reederrr likes this.
    12-26-2011 04:06 PM
  6. reederrr's Avatar
    I followed all of your steps and data packets are now being used yet I am still unable to connect to the internet. I know for a fact that my plan allows me to use this and I don't understand what is stopping it from connecting. I'm able to text and make phone calls but not connect to the internet using data packets. I'm actually not quite sure if I ever even did connect to "attwifi" as I now see that it could have easily been data packets and it was just showing that attwifi was there at one time. I never took the time to see exactly what it was that I was connected to until it went out where I went and checked wifi connections and saw attwifi not in range. That's where I assumed that that's what I was connected to but I'm thinking now that it was data packets.

    I will try to communicate with AT&T about this but if you think you can help anymore than you have then please do. Thanks a lot Wookiee, that helped me out a lot and should help lead to the solution.
    12-26-2011 04:32 PM
  7. gsrrr's Avatar
    Do you see "H+" next to the signal bars in the status bar at the top?
    reederrr likes this.
    12-26-2011 04:41 PM
  8. reederrr's Avatar
    No, I do not see an "H+" anywhere.
    12-26-2011 04:59 PM
  9. gsrrr's Avatar
    No, I do not see an "H+" anywhere.
    That means you are not connected to the AT&T data network. I am not sure what may be causing this because it may be a number of causes.

    Let's try this. Does it say you are connected to a wifi network? <-something like this in the status bar at top?

    If you are, then you might be connected to it but it's not allowing you to browse the web. If that is the case, we can just disconnect the phone from the wifi network so it can connect to the at&t data network.

    Go into menu>settings>wireless and network>wifi settings> and hit the wifi box and disconnect from the wifi network. You might need to hit the 3rd box in that screen to stop it from automatically connect to at&t hotspots. The phone should automatically connect itself to the at&t data network and you should see "H+"

    Do you by any chance live close to a Starbucks or McDonalds? They have free at&t hotspot wifi and you might have connected to them automatically. Maybe they closed for the holidays at 530 and turned off their hotspot.
    reederrr likes this.
    12-26-2011 05:28 PM
  10. reederrr's Avatar
    No, I am not connected to any wifi at the moment and I still see nothing up there but my signal, battery and the time.
    12-26-2011 05:29 PM
  11. reederrr's Avatar
    Okay, I contacted AT&T via livechat and the problem was solved. Turns out all I had to do was reset to factory settings. I don't exactly know why this was the case but he asked me to do that and it did the trick.

    If you're also having this problem then I suggest you try resetting your phone as it worked for me. Thanks to Wookiee and gsrrr for the help, thumbs up guys!
    12-26-2011 09:41 PM
  12. richb89600's Avatar
    Won't connect to ATTWifi SOLVED:
    Go to the bottom of your list of available wifi networks and touch "Add WiFi Network"
    Add SSID "attwifi" (no quotes)
    Touch Save
    Return and you'll have 2 attwifi listings, but it will connect perfectly.
    Jorge Salazar1 likes this.
    01-11-2012 04:22 PM
  13. Jorge Salazar1's Avatar
    I just purchased a T-Mobile LG L9 a couple of weeks ago. I love the phone, but the only problem was with the wifi not connecting to any AT&T WiFi hotspots such as Starbucks or Barnes & Noble. The WiFi worked well everywhere else, and I couldn't figure out what was wrong. I've had several Android smartphones including a few iPhones, and never had that problem before. I returned the phone to T-Mobile twice, and the problem continued, until out of the blue, I found your post. I tried it and now it just works, like magic! You have no idea how much you've helped me. I still don't understand the reason why this worked, but I'm just happy to have found the solution. Thank you so much!
    02-14-2013 10:20 AM