A mod to allow 3rd party apps to write to SD has screwed up my tablet, please help!!


AC Question

Hi, I have a Digiland DL1010Q tablet with kitkat 4.4.2

Apologies in advance if this post is a little long, but I wanted to be thorough in my explanations in order to better my chances of getting the problem solved.

Kitkat 4.4.2 apparently doesn't allow 3rd party programs to write on an external SD card and since I wanted that functionality back (and I have root access), I decided to do the "Sdfix" modification. It has an app for it in the play store but I decided to do it the manual way as described in many threads online.

The modification is basically to edit the /system/etc/permissions/platform.xml file and add in the WRITE_EXTERNAL_STORAGE category the line "<group gid="media_rw" />". This is supposed to give back write permission on sd card to 3rd party apps.
Now the issue is that the particular instructions I was looking at didnt mention reeditting this file's permission after making the edit so the permissions might have not been at 644 (rw- r-- r--) after I made this edit...

Once I rebooted the tablet it booted up fine but once on the desktop, I started getting a bunch of messages that apps were crashing in the background. The tablet came from factory with 2 partitions, one for the OS and the main part of the user apps, and a secondary partition called "INTERNAL STORAGE" with the extra install files for the largest user apps and some settings, etc... The issue seems to be that this secondary partition now cannot be accessed unless i use es file explorer with root access and navigate to the mnt/media_rw/sdcard0 folder (the internal storage has always been referred as sdcard0 before, so the name isnt new). So basically without root, the apps cant access that data partition and load their settings,etc and load properly. At least thats what I think is happening but I could be wrong.

The weird part is that even with root, I can only access the content of the internal storage through es file explorer if I go through the mnt/media_rw/ folder, if I go through other folders, I can't seem to access the content. Without root explorer access, es file explorer can't even access the content of the mnt/media _rw folder. If I go through the "sd card analyst" tool in es file explorer, it would normally display the content of the internal storage, but it now fails and say that it doesnt have the right permission (even if es file explorer has root explorer access).

I have since edited the platform.xml file permissions to make sure they were at 644, reboot, no luck.
I then reverted the changes to platform.xml and made it identical to what it was at the beginning, reboot, no luck and es file explorer navigation was identical.

Through my many googling attempts I found a few other people who had this issue and one user's recommended fix involved deleting the file /data/system/packages.xml (which he said gets modified when platform.xml changes), clearing the cache and delvik cache, then rebooting. I actually tried this and the delvik cache got repopulated normally during bootup but the issue persisted. (the packages.xml file reappeared but I am not sure how identical it is to the one I deleted)

Does anyone have any suggestion on how I could fix my issue without doing a factory reset? I would greatly appreciate any help in solving this short of a full wipe.

Trending Posts

Forum statistics

Latest member