aGPS mystery solved

AndroidX

Active member
Nov 19, 2009
25
0
0
Visit site
I think I have found out what is causing aGPS to not work. If you enable WiFi on the device, and enable Use wireless network option, the aGPS will function. You do not have to be connected to a WiFi network, or even have settings for a WiFi network, just the fact of enabling WiFi will allow aGPS to function properly.
 

jeffgus

Member
Nov 9, 2009
9
0
1
Visit site
No go for me. My Wifi is enabled. I'm inside a building and my Pre knows my general location. My Moment thinks I am in Estonia. The 'Tricorder' app shows the cellular location as: 59? 24.892', 23? 45.334'.
 

jeffgus

Member
Nov 9, 2009
9
0
1
Visit site
Make sure you enable Use wireless network under the Security and Location, then try Google maps.

It is selected. Both 'Use wireless networks' and 'Enable GPS satellites' are selected. I am streaming music over the Wifi right now so I know it is up and running, but the location is still wrong.
 

AndroidX

Active member
Nov 19, 2009
25
0
0
Visit site
Hmm...interesting. Can you try turning off the connection to whatever WiFi you are connected to, reboot the phone, and try again without connecting to the WiFi (but make sure WiFi is still enabled)?
 

jeffgus

Member
Nov 9, 2009
9
0
1
Visit site
Hmm...interesting. Can you try turning off the connection to whatever WiFi you are connected to, reboot the phone, and try again without connecting to the WiFi (but make sure WiFi is still enabled)?

Forgot Wifi network, turned off, turned on, made sure Wifi is on. Still wrong location.

I think that I did this same thing at home and it worked. Is there a difference in the towers?

update: I just re-connected to the Wifi network and now I have the correct location showing up on Google Maps. Hmmmmm. Interesting. Why would a reboot and reconnect fix the problem?
 
Last edited:

Latest posts

Trending Posts

Forum statistics

Threads
943,742
Messages
6,919,886
Members
3,159,204
Latest member
franzmorais