Android System Recovery loop with no adb access


New member
Sep 12, 2011
Visit site
I screwed up when trying to wipe and flash my phone. When I turn on my Optimus V, it shows the LG logo, then runs "Android System Recovery", wipes data, cache, etc and reboots showing the LG logo permanently. The only time I can get adb access is just before the Android System Recovery reboots. if I quickly type in "adb devices" I can get adb to show my device is in recovery mode, but it reboots each time so I can't get access to a shell.

I've tried various forums concerning this topic, but it always boots up into Android System Recovery, and then hangs on the LG logo before adb allows me access. I've tried the various button combinations, and removing the battery and reinserting the battery as I plug it into the computer.

Fastboot doesn't seem to work either since it can't see the device until the last possible moment when it reboots. I could easily fix this if I could get it to stop rebooting after the pointless Android System Recovery and give me access to adb. Anyone have any suggestions?


I've also tried adb reboot-bootloader at the exact moment I have access to adb, but it just says error: procotol fault (no status) and then reboots to the LG logo.
Last edited: