Can I disable this new taskbar in Android 13?

kaiyoma

New member
Aug 18, 2023
4
6
3
Visit site
Last night my Lenovo Tab M10 Plus (3rd gen) updated itself to Android 13 and now I have this annoying taskbar when I open an app. It kind of resembles the macOS dock and it does this really annoying thing where it shifts the 3 navigation buttons over to the right. How do I turn this off? I've tried searching my settings for "taskbar" and it doesn't find anything. Lenovo forums also weren't helpful.

Attaching a screenshot of what this thing looks like when I have an app open.
 

Attachments

  • Screenshot (Aug 18, 2023 8_03_51 AM).png
    Screenshot (Aug 18, 2023 8_03_51 AM).png
    126.9 KB · Views: 47

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,155
2,854
113
Visit site
Welcome to Android Central! You may not be able to get rid of that in Android 13 compared to Android 12L. I see no option to toggle it off on my Pixel Tablet, but I don't have a Lenovo tablet on Android 13 to test.

I assume that you prefer button navigation over gesture navigation?
 

kaiyoma

New member
Aug 18, 2023
4
6
3
Visit site
Welcome to Android Central! You may not be able to get rid of that in Android 13 compared to Android 12L. I see no option to toggle it off on my Pixel Tablet, but I don't have a Lenovo tablet on Android 13 to test.

I'm also open to a third-party app that fixes this in some way. This new taskbar design is just really, really bad and I'd like to go back to what I had before.
 
  • Like
Reactions: DazP

Mr. Lucky

Well-known member
Jul 25, 2023
99
118
33
Visit site
Different device, but see if this helps:
 

Parja

New member
Aug 23, 2023
1
2
3
Visit site
Last night my Lenovo Tab M10 Plus (3rd gen) updated itself to Android 13 and now I have this annoying taskbar when I open an app. It kind of resembles the macOS dock and it does this really annoying thing where it shifts the 3 navigation buttons over to the right. How do I turn this off? I've tried searching my settings for "taskbar" and it doesn't find anything. Lenovo forums also weren't helpful.

Attaching a screenshot of what this thing looks like when I have an app open.
I also have an M10 Plus 3rd gen and have been looking for a way to disable it as well. By default, it looks like there should be a toggle for it under the Display heading in Settings, but there's no option there for me. I can't seem to find any setting to turn the darn thing off.
 
  • Like
Reactions: DazP and sauhaumjau

Ih8google

New member
Aug 25, 2023
1
3
3
Visit site
Same here. I really dislike the useless bar that makes using this tablet harder and more cumbersome. It's filled with google apps that I never use. Not only is there no visible way to disable it, there also doesn't seem to be a way to modify which apps are on it. Thanks google or alphabet or whatever you're called these days. Anyone know the procedure to restore what I had before this "upgrade"?

Screenshot_20230825-105743.png
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,155
2,854
113
Visit site
Same here. I really dislike the useless bar that makes using this tablet harder and more cumbersome. It's filled with google apps that I never use. Not only is there no visible way to disable it, there also doesn't seem to be a way to modify which apps are on it. Thanks google or alphabet or whatever you're called these days. Anyone know the procedure to restore what I had before this "upgrade"?

View attachment 355690
Welcome to Android Central! You should at least be able to customize the taskbar and add the app shortcuts that you do use: https://support.google.com/googlepixeltablet/answer/13590881?hl=en#zippy=,add-an-app-to-taskbar. If you don't add any, then it will show suggested apps based on your usage patterns.
 

sauhaumjau

New member
Aug 26, 2023
2
4
3
Visit site
Great, now I have this annoying taskbar covering the apps I use, and there is no option to turn it off. They also made the notification and setting swipe-down window seperate instead of conveniently being in the same, so you have to swipe left down and right down for each... Why?

What is even better is that if I try to use a 3rd party home launcher, the one in the system overrides it. Can't fullscreen read anymore because of this intrusive taskbar always being there, and the navigation buttons are now in bottom right, tightly squeezed together instead of in the middle so you don't accidentally push the wrong ones.

There is no taskbar settings, or navigation settings, only options for home screen customization is this:
 

Attachments

  • Screenshot_20230826-161351.png
    Screenshot_20230826-161351.png
    129.6 KB · Views: 22
  • Screenshot_20230826-161205.png
    Screenshot_20230826-161205.png
    189.9 KB · Views: 18
  • Screenshot_20230826-161333.png
    Screenshot_20230826-161333.png
    180.1 KB · Views: 21

DazP

New member
Aug 26, 2023
1
2
1
Visit site
I too have an M10 Plus, and after getting the update this morning, I have the same problem. Can't see any way to disable this unwanted, unhelpful "feature". As someone who tries to avoid as much of Google as possible, I'm stunned that I've had this forced upon me.

I use the MS Launcher across phone and tablet, and I can't help feeling that if this had been Microsoft introducing this task bar to an OS, chock full of links to MS apps, the whole world would be up in arms about it.

Had to create an account here to comment (and moan, sorry), and to find out if there's any possible fix. Until there's a fix, it's back to the phone or laptop for me.
 

Zerh

New member
Sep 12, 2023
1
2
3
Visit site
Last night my Lenovo Tab M10 Plus (3rd gen) updated itself to Android 13 and now I have this annoying taskbar when I open an app. It kind of resembles the macOS dock and it does this really annoying thing where it shifts the 3 navigation buttons over to the right. How do I turn this off? I've tried searching my settings for "taskbar" and it doesn't find anything. Lenovo forums also weren't helpful.

Attaching a screenshot of what this thing looks like when I have an app open.
Settings >Wallpaper and home screen>home settings> turn off the taskbar settings shown in my attached picture

You will also need to enable swipe gestures instead of using the traditional 3 buttons. This is located in settings>system>system navigation>gesture navigation.

Swipe out of settings for changes to take affect. The Lenovo m10 plus 3rd gen might be a tad buggy after these changes. A reboot will quickly resolve this.

You might need to be using an aftermarket launcher for the change to work. I personally use Microsoft launcher as I find it greatly improved frame rate vs the stock launcher on the m10 plus 3rd gen
 

Attachments

  • Screenshot_20230912-094127.png
    Screenshot_20230912-094127.png
    150 KB · Views: 26
  • Screenshot_20230912-094808.png
    Screenshot_20230912-094808.png
    120.7 KB · Views: 27
Last edited:

elver

New member
Oct 2, 2023
2
7
3
Visit site
Hi, I registered for an account here to post this answer as it's the only place I found that are as annoyed as me about this.

The only solution I've found is to set the "Smallest width" setting in Developer Options to 599.

This reduces the DPI of the screen so that android thinks it's just a large phone rather than a tablet.

The taskbar is only active on devices where the smallest width is set to 600 or higher.

My Lenovo M9 originally had this set to 640, when I set it to 599, the taskbar disappeared.

This doesn't resolve the navigation buttons being at the right, and the navigation bar being on screen at all times, but at least I don't have a grey stripe full of random apps at the bottom ofthe screen.
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
89,310
3,321
113
Visit site
Hi, I registered for an account here to post this answer as it's the only place I found that are as annoyed as me about this.

The only solution I've found is to set the "Smallest width" setting in Developer Options to 599.

This reduces the DPI of the screen so that android thinks it's just a large phone rather than a tablet.

The taskbar is only active on devices where the smallest width is set to 600 or higher.

My Lenovo M9 originally had this set to 640, when I set it to 599, the taskbar disappeared.

This doesn't resolve the navigation buttons being at the right, and the navigation bar being on screen at all times, but at least I don't have a grey stripe full of random apps at the bottom ofthe screen.
Welcome to AC!
Thanks for your findings
 
  • Like
Reactions: Atlassian

Mr. Lucky

Well-known member
Jul 25, 2023
99
118
33
Visit site
The only solution I've found is to set the "Smallest width" setting in Developer Options to 599.

This reduces the DPI of the screen so that android thinks it's just a large phone rather than a tablet.

The taskbar is only active on devices where the smallest width is set to 600 or higher.

My Lenovo M9 originally had this set to 640, when I set it to 599, the taskbar disappeared.
Good workaround for an issue that bothers many people. But doesn't reducing the DPI that much make everything onscreen huge?
 

Arizone

Member
May 11, 2011
23
10
3
Visit site
I agree this is an obnoxious feature which doesn't conform to Google's own Android 13 implementation, and having been in contact with Lenovo, there does not appear to be a way to properly disable it at this time, but I hope they will add one now that this issue has been raised.

Internally, it's connected to two Android 'secure' values called "ov_tbar_hide_flag" and "ov_fullscreen_tbar", you can try adjusting these values with ADB but I don't think that helps. You can also disable the Smart Launcher (com.tblenovo.launcher) package in ADB, the taskbar does go away, but even while using another launcher this will also break the swipe up go home gesture and app switcher.

Instead, if you tap and hold in the blank space in the sides of the taskbar it should hide, and tap and hold again on the home bar to reveal it again. You can also customize it by dragging app icons in and out of it while on the home screen, and as someone else reported removing all app icons and disabling the "Display 'All applications' list entry in the Taskbar" in "Home settings" can also get it to hide, except on the home screen.
 

Forum statistics

Threads
938,824
Messages
6,891,256
Members
3,156,410
Latest member
lucaspierref