Galaxy Note II stuck on Note II logo screen.


AC Question

I have searched the forums, but I can't find a working answer. Anyway, let me tell you how it all began. This is a long post, so put on your reading glasses and grab a soda.

My AT&T SGH-I317 Galaxy Note II phone had never been tampered with. It was legit stock. I updated my phone through the phone's "check for software updates" under the device info menu. After that, I began to have problems. Let me describe those to you:

Problem #1 : The phone would not come on when pushing the power button, after falling asleep. This happened randomly and not all the time. The only way to "wake it up" was to take the battery out, put it back in, and turn the phone on. I had to do this several times a day.

Problem #2 : The phone would try and "reboot" randomly. The LED notification light would fade in and out for hours, but the phone would not come on. Eventually, it would boot up. This would happen several times a day.

I read up on the subject and I found that the updated files might have been corrupted, so I did a factory reset. That did NOT work.

Steps I tried:
#1 : Factory reset
#2 : Wipe cache
#3 : Factory reset AND wipe cache.

Did not work. SOOOO, I downloaded Odin and tried to reinstall stock ROM. I kept getting an "Invalid magic string."

Downloaded the PIT file and the first version of software, which was KitKat or something and that WORKED! MY PHONE LIVED.

Then I tried to update my phone via ATT again. Oops? Apparently my phone isn't "legit" anymore so.....

When you push the power button, the phone LED flashed red BRIEFLY (nano seconds) and will not go past the black green that just says "Samsung Galaxy Note II".

Here is another issue:
Volume Up + Home + Power button DOES NOT WORK. Will NOT go past Note II logo screen.

Volume Down + Home + Power DOES work and tried to reinstall with and without the PIT file, but it will not go past the Galaxy Note II screen.

What now?