• Welcome to the all-new Android Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues please let us know in this thread!

HELP! Tried to root SM-G930P without a service connection, Odin FAIL

Mark George Jr

New member
Apr 16, 2019
I'm hoping that I can at least save my phone if rooting it is impossible. I had a heck of a time getting my number switched from Sprint to a 3rd party carrier(MVNO)- long story short: I had to move my number to a different phone. I then tried to root the S7 and failed with the first CF-Auto-Root-heroqltespr-heroqltespr-smg930p.tar.md5 file I found. Got a fail on Odin V. 3.11.3.
Then I found another video and link to an Unlock file, I only uploaded it to the CP spot on Odin and it wrote but then I get this WARNING- System has been flashed with unauthorized software and has been lock, please contact your carrier. . . blah blah...and a boot loop.
I can still get into download mode though so hoping someone can help. I spoke to Sprint, although I despise them and the CS tech said it was most likely due to the fact that I tried to flash the OS without any service on the phone. I've tried going into recovery mode and it says there is no recovery file. I have now added time/minutes/service through RedPocket on the SIM card in hopes it will help, but I have NO CLUE.
Odin log reads as follows:
<ID:0/003> Added!!
<OSM> Enter CS for MD5..
<OSM> Check MD5.. Do not unplug the cable..
<OSM> Please wait..
<OSM> Checking MD5 finished Sucessfully..
<OSM> Leave CS..
<ID:0/003> Odin engine v(ID:3.1301)..
<ID:0/003> File analysis..
<ID:0/003> Total Binary size: 61 M
<ID:0/003> SetupConnection..
<ID:0/003> Initialzation..
<ID:0/003> Get PIT for mapping..
<ID:0/003> Firmware update start..
<ID:0/003> NAND Write Start!!
<ID:0/003> SingleDownload.
<ID:0/003> recovery.img
<ID:0/003> cache.img.ext4
<ID:0/003> FAIL! (Auth)
<ID:0/003> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)

The last firmware was G930PVPS9CSB1. I'm downloading this now off of SamMobile to try it.

Can I root this phone? Can I save this phone?
I've watched so many videos of Odin and Smart Switch and none of them have helped. I'm not a tech guy but I can follow directions and I have been following them as far as I can tell.
Thanks for reading, hope you can help!


Retired Moderator
Feb 12, 2012
You put the firmware into the AP slot. If the phone is salvageable, that will bring it back.

Then you get the CF-Auto-Root for that specific phone, and it should be rootable. (Again, in the AP slot if you're using Odin, on the SD card if you're not - that depends on the file, not your desire. .tar and .tar.md5 files use Odin, zip files use the SD card and recovery mode.