Not booting into Cyanogenmod ROM Samsung Galaxy S2 (i9100g)

Iram Khan1

New member
Mar 28, 2014
Visit site

I am new to android forums so please don't mind if my question is either not in the right place or may have been solved earlier.

Basically my wife's phone is a samsung galaxy S2(i9100g) and I spent the whole night yesterday trying to get cyanogenmod on it without much luck. I initially followed the wrong instructions (Information: Samsung Galaxy S II ("i9100") - CyanogenMod) for Galaxy S2(i9100) and wasnt able to load clockwork recovery onto the phone which is when I realized I'm loading the wrong recovery for the i9100g. So, then I got the correct version from (Information: Samsung Galaxy S II G ("i9100g") - CyanogenMod) of the clockworkmod recovery and finally the recovery loaded using Heimdall. The recovery version was Version 5.x.x.x. like that on the wiki page. Now because I dint realize that even the cyanogenmod zip files can be different for both the versions, I first tried flashing to it which failed and told me that its the wrong file after which I got all the correct files from their website. i.e. first I tried the latest nightly i.e. 27/03 .zip and then because that dint work I tried (the stable version).

So basically I clear the data,dalvik cache, factory reset etc and then flash the ROM from my sd card. Now I tried both the nightly and the stable version and in both cases it says installation complete but when I click on reboot system now on my clockworkmod recovery, the screen goes blank and stays blank. When I push the power button it comes back to the samsung galaxy s2(i9100) screen with a big yellow hazard in the middle (which I'm sure is correct) but then it loads back into the clockworkmod recovery rather than loading into the ROM. Any suggestions on why this is happening? Spent all night trying to figure this out but no luck so far. Looking forward to your suggestions.

Note: I can put the device in download mode, install other recoveries without any problem.


Retired Ambassador
Aug 26, 2013
Visit site
Thanks that worked and was able to load stock Jelly Bean 4.1.2 onto the phone. Any directions if I can load cyanogenmod now from here?

Now you need to re-root your phone, and then flash a custom recovery like TWRP or ClockworkMod. Then you can flash CyanogenMod

Sent from my Galaxy S4 running SlimKat 4.4.2

Latest posts

Trending Posts

Forum statistics

Latest member