P7Pro Can't disable vibration from notifications or ringtones when sound is on

Davidoo

Well-known member
Nov 25, 2011
1,018
79
48
Visit site
OK, I swear this didn't happen in any of my prior Pixels, including the 6 Pro. When I turn the sound on (bell icon) with the volume rocker controls for notifications and ring tones, my P7P still vibrates too. There has got to be a way to have the device only play the sounds, not vibrate and sound at the same time.

So what I did is turn off Use Vibration and Haptics in the settings, then when it rings or notifies then I only have the ring, no vibration. BUT, if I use the volume rocker quick settings and I want to put my device in vibrate mode, it doesn't vibrate at all, so that's no good. In my P6Pro I had vibration and haptics on, and when I put the setting on the bell icon for audible ring and vibration, it only played the audio, and when I set the phone to vibrate, it only vibrated. I've combed over every setting and can't figure it out. Got to be a way not to have both audio and vibrate?
 

mxmarcus

Well-known member
May 7, 2010
407
5
18
Visit site
Settings > Accessibility > Vibration & haptics

I turned it off completely

Sent from my Pixel 7 Pro using Tapatalk
 

Davidoo

Well-known member
Nov 25, 2011
1,018
79
48
Visit site
Settings > Accessibility > Vibration & haptics

I turned it off completely

Sent from my Pixel 7 Pro using Tapatalk

Yes, but if you do that when you turn it on vibrate only it won't vibrate. When you turn the sound on seems like the vibrate should turn off. It's worked like that on every device I've ever had.
 

Tomster88

Well-known member
Apr 13, 2014
899
138
43
Visit site
OK, I swear this didn't happen in any of my prior Pixels, including the 6 Pro. When I turn the sound on (bell icon) with the volume rocker controls for notifications and ring tones, my P7P still vibrates too. There has got to be a way to have the device only play the sounds, not vibrate and sound at the same time.

So what I did is turn off Use Vibration and Haptics in the settings, then when it rings or notifies then I only have the ring, no vibration. BUT, if I use the volume rocker quick settings and I want to put my device in vibrate mode, it doesn't vibrate at all, so that's no good. In my P6Pro I had vibration and haptics on, and when I put the setting on the bell icon for audible ring and vibration, it only played the audio, and when I set the phone to vibrate, it only vibrated. I've combed over every setting and can't figure it out. Got to be a way not to have both audio and vibrate?
I have this same exact issue. I don't want my phone to vibrate when the sound is on. I only want it to vibrate when I have the phone set to vibrate mode. But I'm afraid turning off the haptics and vibrate willl shut it off completely.

Sent from my Pixel 7 Pro using AC Forums mobile app
 

J Dubbs

Well-known member
Jun 4, 2016
4,005
1,146
113
Visit site
There's a setting for turning the vibration on and off only when it's ringing... and it doesn't affect the haptics. You can turn the vibrate when ringing off, and still have the phone vibrate only in the rocker settings. Just do a settings search for vibrate for incoming calls. I'm sorry I don't remember where that setting is... it's on by default I believe and I like it so I never change it.
 

Stanley Kubrick

Well-known member
Jun 14, 2011
921
511
93
Visit site
I am not entirely sure what you are trying to do here but...go to settings > Sound & vibration > Vibration & haptics = make sure the toggle is ON - then move the slider for Ring Vibration and Notification vibration all the way to the left. This will have the same effect as turning off vibrations for your ringtone and notification tone while still allowing the phone to vibrate when placed in vibration mode only...at least I think it will???
 

Davidoo

Well-known member
Nov 25, 2011
1,018
79
48
Visit site
I am not entirely sure what you are trying to do here but...go to settings > Sound & vibration > Vibration & haptics = make sure the toggle is ON - then move the slider for Ring Vibration and Notification vibration all the way to the left. This will have the same effect as turning off vibrations for your ringtone and notification tone while still allowing the phone to vibrate when placed in vibration mode only...at least I think it will???

I tried that. If I have the toggle on, and move the slider for Ring and Notification vibration all the way to the left (off), then it won't vibrate when I go into vibrate mode only. This one just baffles me why Google changed this to make the phone vibrate AND ring at the same time.
 

Davidoo

Well-known member
Nov 25, 2011
1,018
79
48
Visit site
There's a setting for turning the vibration on and off only when it's ringing... and it doesn't affect the haptics. You can turn the vibrate when ringing off, and still have the phone vibrate only in the rocker settings. Just do a settings search for vibrate for incoming calls. I'm sorry I don't remember where that setting is... it's on by default I believe and I like it so I never change it.

That is what I would like to do, but I have no such setting on my Pixel 7 Pro. Thanks!
 

Davidoo

Well-known member
Nov 25, 2011
1,018
79
48
Visit site
Apparently the "vibrate while ringing" setting is missing from my Pixel 7 Pro. I'm on Verizon. Does anyone else have this setting? I'm thinking this is the culprit as to why I can't stop it from vibrating when I have the sound turned on.
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
91,910
6,470
113
Visit site
Apparently the "vibrate while ringing" setting is missing from my Pixel 7 Pro. I'm on Verizon. Does anyone else have this setting? I'm thinking this is the culprit as to why I can't stop it from vibrating when I have the sound turned on.
Settings>sounds and vibration>vibration and haptics
e606d087ad97069a8208a3f7c46c8d8d.jpg


Sent from my Pixel 7 Pro using Tapatalk
 

Davidoo

Well-known member
Nov 25, 2011
1,018
79
48
Visit site
Ring vibration calls top slide bar

Thanks. I get that, but if you turn the ring vibration all the way to the left on that slide bar, then when you toggle to vibrate on the volume rocker, it won't vibrate. If you get a call, you get no notification at all except the screen lights up, and that doesn't help when it's in your pocket.

The way it worked before is you leave the vibration on. When you select the bell icon on the volume rocker, it rings only, when you select the vibrate icon on the rocker it only vibrates. You can't do that anymore. If the vibrate while ringing setting was still there, you could do it. I put in a question in the Google Pixel Community Forum to see if they can help. Possibly a bug that the setting is missing. I can't believe even Google would force us to make it vibrate and ring for calls and notifications.
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
91,910
6,470
113
Visit site
Thanks. I get that, but if you turn the ring vibration all the way to the left on that slide bar, then when you toggle to vibrate on the volume rocker, it won't vibrate. If you get a call, you get no notification at all except the screen lights up, and that doesn't help when it's in your pocket.

The way it worked before is you leave the vibration on. When you select the bell icon on the volume rocker, it rings only, when you select the vibrate icon on the rocker it only vibrates. You can't do that anymore. If the vibrate while ringing setting was still there, you could do it. I put in a question in the Google Pixel Community Forum to see if they can help. Possibly a bug that the setting is missing. I can't believe even Google would force us to make it vibrate and ring for calls and notifications.
Yeah so in the volume mode selection ring/vibration/silent under ring it will vibrate under vibration selection it wont vibrate if you turn the vibration slider all the way down on ring for calls as in my screenshot
 

Davidoo

Well-known member
Nov 25, 2011
1,018
79
48
Visit site
That's correct. If you turn the vibration slider off for ringing, that eliminates the vibration when the ringer is on, but if you then toggle to vibrate it won't vibrate because that slider is off. Try it and I bet yours does the same. I looked on Google's help and it says to turn "vibrate while ringing" off to fix this, but I (and I bet others) don't have this setting.
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
91,910
6,470
113
Visit site
That's correct. If you turn the vibration slider off for ringing, that eliminates the vibration when the ringer is on, but if you then toggle to vibrate it won't vibrate because that slider is off. Try it and I bet yours does the same. I looked on Google's help and it says to turn "vibrate while ringing" off to fix this, but I (and I bet others) don't have this setting.
Yeah your right with slider off and in vibration selection it doesn't vibrate
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
91,910
6,470
113
Visit site
Ok main thing here is vibration selection mode and slider for vibration off no vibration, think that was the confusion
 

Davidoo

Well-known member
Nov 25, 2011
1,018
79
48
Visit site
Well, I guess this was intentional by Google. I just got an answer from a "platinum product expert" who says the setting was removed and "Now its either the phone rings and vibrate or it doesn't vibrate at all." They suggest I send in feedback. Here is the full response.

Welcome to Google Pixel Community.

I got your point here, If i recall that option was available earlier That gesture is not available on pixel.
Now its either the phone rings and vibrate or it doesn't vibrate at all.

Please leave a feedback about this,
Go to settings > Tips and Support > Send a feedback.

Hope this helps.
Thanks.
 

Forum statistics

Threads
943,970
Messages
6,920,832
Members
3,159,330
Latest member
ramiaec