problem with gallery when posting picture to facebook

A

AC Question

When trying to post a photo to facebook the fb app opens gallery but i have several folders in gallery which do not appear although they do if i open gallery normally. result is i cannot find the pictures i want and cannot post to fb. any help?
 

Lodingi

Q&A Team
Jul 21, 2010
872
23
18
Visit site
Hello and welcome to Android Central. As I was troubleshooting your question, I noticed the Facebook app didn't allow me to choose a specific folder to attach a photo. I was able to get around this by doing the following.

1. Go in to the Gallery.
2. Choose folder where photo is stored.
3. Select photo
4. Select the share icon. This will show a list of social and message apps.
5. Hit the Facebook icon and it will post the photo to your Facebook page. From there you can add comments and post.

If you want to post more than one photo at a time, select all your photos in step 3 and go to steps 4 & 5. Let me know if this helps.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,895
3,873
113
Visit site
Welcome to Android Central! Merged duplicate threads.

Are you using the Facebook app, or the Facebook mobile browser site?
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,895
3,873
113
Visit site
Try going to the App Manager, select Facebook, and Clear Cache/Clear Data, then Force Stop. Now open it again and log back in. Still the same problem? If so, then do the same for Gallery as well (don't worry, the Gallery's database will repopulate as soon as you open it again).
 

mikenixon59

Member
Oct 1, 2016
5
1
0
Visit site
the problem is how facebook calls up gallery. from facebook app i can post a photo from gallery but onlyffom what is visible. if i try to scroll through the photos to find the one i want then it (gallery) goes haywire and does not seem to be ordering the photos in any logical fashion and is not showing any sub folders. if i try to 'share' from gallery or from auickpic then it opens facebook but the facebook page no longer shows the photo for posting.
 
  • Like
Reactions: JonEQuest

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,895
3,873
113
Visit site
Ok, but what about the Google Photos app? Same issue there?

This is probably not the case, but you might try uninstalling QuickPic temporarily, to see if it's the culprit. QuickPic used to be really good when the dev was independent, but then it got bought by Cheetah Mobile, who proceeded to add extra stuff in the app. I trust Cheetah about as far as I can throw their collective staff, so who knows--maybe something in there is causing problems.
 

Forum statistics

Threads
941,284
Messages
6,907,757
Members
3,157,845
Latest member
Ahmet7883