Repeat Data Roaming Notifications - T-Mobile LG G2

WaarrEagle

New member
Mar 3, 2014
2
0
0
Visit site
Running KitKat and currently traveling in Canada where I am using Wifi Calling, I get the data roaming message over and over: "Do you want to turn on data while in roaming? (International roaming charges apply)." I have tried different combinations of the various data/roaming settings but the message keeps appearing. How do I stop this message? I really don't care where I have to set it as I spend the majority of my time here on wifi and roaming in Canada is free now.
 
Last edited by a moderator:

gmep

Member
Feb 21, 2014
15
0
0
Visit site
Re: Repeat Data Roaming Notifications - Tmobile LG G2

Similar problem here. I live in The Netherlands and work in Germany so I have a German provider. In The Netherlands I exclusively use WiFi and therefore I turned data roaming off. As I was running 4.2.2 I got the messages about data roaming being off when I was @home. They came about every 2 minutes. They went away as I set the mail app to automatically every 15 min. that's strange enough. Then I updated to KitKat and now I get that annoying messages when I'm in Germany connected to my provider even with full 3G signal! And they came with an horrible frequency (once a second). Today I tried to delete the phone app data. The messages still come but only every 2 minutes. When I'm in The Netherlands the messages about data roaming don't come any longer???? Any hint about how to get rid of this stupid messages will be greatly appreciated. LG support couldn't help so far :-[

Posted via Android Central App
 

WaarrEagle

New member
Mar 3, 2014
2
0
0
Visit site
Re: Repeat Data Roaming Notifications - Tmobile LG G2

I was able to find a temporary fix by going into the TMobile Wifi Calling settings and setting the device to "Never Use Cellular Network." It is a pain because TMobile offers free data roaming in Canada and I am not always near a wifi connection, but I found it to be the best compromise to stop the repeat messages from popping up.
 

gmep

Member
Feb 21, 2014
15
0
0
Visit site
Try switching flight mode on and then back off. That could help at least until you connect to another network. I' m really wondering who programmed that sh.. :-(

Sent from my LG-D802 using Tapatalk
 

bbz71

New member
Apr 8, 2014
1
0
0
Visit site
Same problem for me here in Italy, after updated to kitkat.
My mobile network operator is 3. I've tried to restore the system, without luck.
Anyone have an idea on how fix it?
 

gmep

Member
Feb 21, 2014
15
0
0
Visit site
There is no real fix to that only a couple of workarounds. LG recommends (@ least in Germany) to switch flight mode on and then back off. It works and I think LG doesn't feel pressure enough to fix that bug instead. Btw, I'm not really sure whether LG or Google is responsible for this as it seems that also htc, samsung and other devices are affected.

Sent from my LG-D802 using Tapatalk
 

gmep

Member
Feb 21, 2014
15
0
0
Visit site
ava6u7ez.jpg


I rooted my phone, installed xposed framework and finally installed G2 Tweaksbox (full version). It will let you stop that messages

Sent from my LG-D802 using Tapatalk
 

Frank Bevers

New member
May 1, 2014
3
0
0
Visit site
similar problem here in belgium; in order to be able to use mobile data while not roaming I have to enable dataroaming on my HTC desire 601. Wish I'd never install KitKat. Enabling WIFI now also fails intermittently & the volume is about half of what is used to be. HTC remains silent.
 

Members online

Forum statistics

Threads
943,795
Messages
6,920,117
Members
3,159,235
Latest member
TheCheekyDinosaur