Stuck on startup boot logo on rooted android device

  • Thread starter Android Central Question
  • Start date
A

Android Central Question

So today I rooted my android device, the Motorola moto g 1st gen, xt1032. I'm new to rooting, and I just followed an tutorial on how to do it. Everything went fine, I have TWRP 'installed' (if it's said like that) whenever I go into fastbood mode, and go to recovery. I've also double checked that I am rooting by installing one of those root checker apps. The problem came when I tried to install LineageOS, that's the main reason why I wanted to root my phone, and the 'flash' (i think) failed, I went to reboot my phone. It did say that there was no OS installed, so I went back and tried to re-install the backup that I made, but that also failed. I then just decide to reboot my phone, without any OS installed, and now it's just stuck on the startup logo, where it says, "Google", It isn't stuck into the animation or anything. I'm pretty sure that it is some sort of stuck, because i have just left it sit there for about an hour. If i try to turn it off, it just automatically goes back on, and there is no way for me to get in to fastboot mode. I have looked up some tutorials, but none of them matches my phone, beacuse it doesn't have an sdcard slot, and the battery can also not be removed.

Can anyone please give me advice on what to do?

I'm also new to this website, so don't judge me if this is in the wrong thread or whatever.
 

Rukbat

Retired Moderator
Feb 12, 2012
44,529
28
0
Visit site
Since it's the OS that gets rooted, you can't root a phone that has no OS. First reinstall the OS. Then install TWRP (if installing the OS replaces it with the stock recovery). Then learn how to root your particular variant of your particular phone on your particular version of Android. (If you're going to install Lineage, don't root, because you'll have to root Lineage after you install it.)