Unbearable lag

Flyingbanana

Member
Nov 23, 2009
8
0
0
Visit site
I've had my hero for a couple of months.Lately it's beginning to lag quite a bit. I've pulled the battery out , clicked the location items on and off. But no difference. I'm trying to avoid a hard reset since I have all my settings in place. Any ideas, tips or apps that will help Thanks
 

ladyslipper

New member
Jan 8, 2010
2
0
0
Visit site
I have noticed that when I start my phone, if I set it down and walk away and I do not mess with it in any way while it completely boots up, it behaves SO much better. If I try to open something or just scroll the trackball while looking at the screen that says "loading" at startup, when my phone finally does finish loading it will be so laggy I want to throw it out the window.

My husband has also tested this and it works wonders for him as well. It wasn't a problem when I first got my phone, so I do kind of wonder if it has something to do with an app that tries to load at startup...I have no idea, just that it's worked for me.
 

Ripjames

Well-known member
Nov 16, 2009
64
0
0
Visit site
I read on here somewhere, that if you goto location services and un check them all for 30 seconds, than turn them back on (or leave them off, I turn them abck onthough) that it will help dramaticlly, there is a bug in 1.5 with them, it really does help
 

husker723#AC

Member
Dec 19, 2009
10
0
0
Visit site
I unchecked and rechecked the location services and nothing seemed to help. However, I had handcent installed for texting and it was slow and pokey...as was the rest of the phone. I finally uninstalled it and my phone has been very fast ever since.
 

gmichie

Member
Oct 25, 2009
23
0
0
Visit site
I'm glad this conversation is picking up. I posted about this a week or so ago, saying my phone had started to lag horribly, and after a few people responded the topic kind of died. I tried toggling the location services but that did not solve the problem for me. The phone is very laggy -- sometimes when I wake it from sleep it won't do anything for 5-10 seconds, it's slow to open programs, just far less responsive in general.

I may try husker723's suggestion of removing Handcent. I like the app and have used it since I got the phone, but it is extremely slow to open and if that's causing other problems, it's not worth it. Are there other good text apps out there?

Also, if I do a hard reset, what steps do I need to take beforehand to back up apps, contacts, etc? I've backed up my apps using Astro but will the SD card be erased as well with a hard reset? And if not, how do I access it to reinstall the apps?

And how do I back up contacts?

Any help is appreciated. I loved this phone for the first 8 weeks I had it, but lately it's become a chore to use.
 

Jerry Hildenbrand

Space Cowboy
Staff member
Oct 11, 2009
5,569
2,797
113
Visit site
@gm46 -
Do you have the Android SDK installed? If so, please try this for me when your phone is lagging badly -

1. Plug in to PC
2. Open command line, navigate to the SDK/tools folder
3. Run adb shell
4. When you get the shell, run the command 'top' (without the quotes).
5. Copy and paste the text to notepad and post it here.

I'd like to have a look, and maybe I can help.

RE Backup- download and install Titanium Backup from the market. It's free, and marvelous. It backs up everything to a folder on your SD card. And no, your card does not get erased when you hard reset.
 

gmichie

Member
Oct 25, 2009
23
0
0
Visit site
@gbhil

Thanks for your help. No, I don't have the SDK installed. I've wanted to, but just haven't had time to figure it out. I've never rooted a phone before, and while I have some Linux tweaking experience with a couple netbooks, I have a feeling this is a bit of a different animal.

I'll think about giving the SDK a go if I have time -- otherwise, thanks for the tip on Titanium.
 

Latest posts

Trending Posts

Forum statistics

Threads
943,742
Messages
6,919,885
Members
3,159,204
Latest member
franzmorais