Unstable Network Connection on SGH-I747M

kristine2318

New member
Mar 29, 2014
1
0
0
Visit site
Can somebody please help me resolve this issue? After the upgrade to 4.3, I encountered wi-fi connectivity issue. I can connect to the wifi at home but after some time, a message pops in my notification bar that says " your internet connection is unstable". Though my connected to the wifi at home, I can't connect to the internet. I've read in some forums to do the following:
1. Forget network then add it again
2. Wipe cache partition
3. Uncheck the 3 boxes in your settings>location services
4. Restart/reboot the router
5. Make sure the date and time are correct
6. Back up data and do a factory reset.

I did all of them but nothing worked. Is there anything else that I can do? Please help... This is becoming so frustrating:((
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,766
4,965
113
Visit site
Welcome to Android Central, and thanks for listing what you've tried so far--it makes it much easier for us to answer! Look for the Advanced Wi-Fi Settings--is there a setting to avoid weak networks? If so, uncheck it. Also, if there's an option for "Wi-Fi Optimization," turn it off. On my Nexus 5, that is more for battery optimization, not improved wi-fi performance.
 

GSDer

Well-known member
Jan 30, 2011
8,471
15
0
Visit site
The usual recommendation is to select the checkbox in that pop-up that let's you ignore it in the future - it's just a useless warning.

However, you're saying that you get a connection to the router (you get an IP address?) but you don't have Internet access - is that correct?

How many curved bars do you get in the Wi-Fi icon?

Have you tried connecting via Wi-Fi somewhere else?

Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
 

Forum statistics

Threads
943,916
Messages
6,920,607
Members
3,159,300
Latest member
mt20apps