Why won't phone connect to network after screen replacement?

iainr

Member
Jun 8, 2020
5
0
0
Visit site
I recently had the screen replaced on my S9. Since the replacement, it won't connect to the phone network (O2, UK). It shows that it is picking up a signal, but will not register on the network at all. When I try to register it, the signal strength display immediately drops to zero and I get the message "unable to connect". The SIM card that I am using works fine in an old S7.

I have tried:

Dropping to 2G/3G only mode.
Deleting and recreating the APN.
Booting to safe mode.
A soft reset.
A factory reset.

All to no avail.

I took the phone back to the man that repaired it, he was able to get his SIM working in the device (after some time spent fiddling with settings), but couldn't get mine to work. He is disclaiming responsibility for the issue as a result of him being able to get it to work. I'm a bit stumped as to what to try next. Any suggestions gratefully received.
 

Morty2264

Ambassador
Mar 6, 2012
22,922
1,053
113
Visit site
I am wondering if an antenna got damaged when he fixed it. Did he tell you which network he connected to with his own sim card? Unless he tried with an O2 sim it may not be relevant to why your sim card isn't working.

Please register for an account so we can help you further. With a guest account, you can't reply. Thanks

https://forums.androidcentral.com/showthread.php?t=409154

That's true. If he used a different SIM card than yours, it wouldn't necessarily be a reliable indicator that *any* SIM card could work. I'm sorry you are going through this, OP! Please keep us posted on what happens.
 

iainr

Member
Jun 8, 2020
5
0
0
Visit site
Hi Kirstein, thanks for replying! He used a 3 sim. I have tried to get my wife's EE sim to work and it has the same issues. I initially thought that he must have damaged the antenna, but am juts a bit confused as to why would the phone show that it was receiving a signal? Is there a way that I can test that the antenna is working properly?
 

BergerKing

Moderator
Mar 11, 2012
1,268
428
83
Visit site
@iainr, just wanted to take a moment and welcome you to the Android Central forums. Moved your thread to the S9 subforum, and fixed the original post to give you ownership and credit for the thread. Hope you get everything sorted!
 

Morty2264

Ambassador
Mar 6, 2012
22,922
1,053
113
Visit site
Hi Kirstein, thanks for replying! He used a 3 sim. I have tried to get my wife's EE sim to work and it has the same issues. I initially thought that he must have damaged the antenna, but am juts a bit confused as to why would the phone show that it was receiving a signal? Is there a way that I can test that the antenna is working properly?

Do you have any updates on your situation, OP? Perhaps see if you could get someone with the same SIM card as you to insert theirs to see if they get a connection?
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
92,081
6,627
113
Visit site
If yours and your wife sim doesn't work in the phone and your sim works in your other phone something happened when they changed the screen , did you see for yourself the repair guy sim worked or taking his word ?
 

iainr

Member
Jun 8, 2020
5
0
0
Visit site
Hi Morty2264, sorry for the slow reply. That seems like a reasonable suggestion. I'll see if I can find one.

No update on situation, I've tried again with the phone, it did briefly connect to the network, then dropped again almost immediately. Doing some research online took me down the rabbit hole of system menus and internal configs, I've posted to a technical forum in the hope that someone might be able to help.
 

iainr

Member
Jun 8, 2020
5
0
0
Visit site
Hi Mustang7757, again, apologies for the slow reply. I didn't see that his sim worked directly, but I do see successful calls in the phone's log.
 

Morty2264

Ambassador
Mar 6, 2012
22,922
1,053
113
Visit site
Hi Morty2264, sorry for the slow reply. That seems like a reasonable suggestion. I'll see if I can find one.

No update on situation, I've tried again with the phone, it did briefly connect to the network, then dropped again almost immediately. Doing some research online took me down the rabbit hole of system menus and internal configs, I've posted to a technical forum in the hope that someone might be able to help.

No problem! No need to apologize! Let us know if we can do anything else to help, and please keep us posted on what happens! :)
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
92,081
6,627
113
Visit site
Hi Mustang7757, again, apologies for the slow reply. I didn't see that his sim worked directly, but I do see successful calls in the phone's log.
Hi, no problem!

The only thing I suggest is getting a 2nd repair shop opinion they going charge but if it turns out the first guy that work on it was a fault should give you a refund for whole repair.
 

iainr

Member
Jun 8, 2020
5
0
0
Visit site
Just to keep everyone in the loop, I posted to this forum: https://forum.xda-developers.com/galaxy-s9/help/s9-wont-connect-to-network-screen-t4112369

There is a reply from a poster with a similar issue, he believes that the antenna may have been damaged during the repair as a result of the significant amount of heating required to loosen the adhesive. I've spoken to the repair guy, he has agreed to fit a new antenna module. I'll update if this solves the problem.
 

Morty2264

Ambassador
Mar 6, 2012
22,922
1,053
113
Visit site
Just to keep everyone in the loop, I posted to this forum: https://forum.xda-developers.com/galaxy-s9/help/s9-wont-connect-to-network-screen-t4112369

There is a reply from a poster with a similar issue, he believes that the antenna may have been damaged during the repair as a result of the significant amount of heating required to loosen the adhesive. I've spoken to the repair guy, he has agreed to fit a new antenna module. I'll update if this solves the problem.

That's so awesome! Good for you for going back and talking to the repair man! Yes, please keep us updated! :)
 

Members online

Forum statistics

Threads
944,381
Messages
6,922,575
Members
3,159,526
Latest member
BuzZKillz78